[APP] CloudDAVMod various versions for firmware V4+ (01/2022)

Live Counter

Note: Can’t see live counter image above? Try again later as my WDMyCloud is offline!

This is my original release (-: On top of re-enabling the remote drive mapping which WD has unexpectedly removed from MyCloud, this mod provides a basic WebDAV webGUI based file manager that integrates seamlessly beneath the existing WD MyCloud Dashboard. No additional backend daemons. Fast, secure, light-weight yet powerful and easy to use (-:


  • Completely bypass MyCloud.com account login. It’s directly between you and your MyCloud NAS. With a personal DDNS 3rd party service, CloudDAVMod should work well even behind strict corporate firewalls or computers that blocks cloud services.

  • Unlimited filesize transfers where the usual mapped drives has a platform specific WebDAV filesize limit.

  • Common file/folder functions such as copy/paste/move/delete/rename/mkdir and advanced search/properties/export with keyboard shortcuts to these functions.

  • Multiple uploads via single mass selection OR Drag&Drop files from the desktop directly into a supported HTML5 browser.

  • HTML5 image previewer with navigation/zoom/pan/rotate support, HTML5 audio streamer with matching filename M3U playlist track order and track title support and HTML5 video streamer with matching filename SRT subtitles support.

  • System panel for MyCloud Dashboard admins; CPU/RAM/Disk/Network/Process usage, S.M.A.R.T. temperature, run simple WWW-SSH commands with simple color support, remote reboot/shutdown and download system logs.

  • MyCloud file/folder auto expiring URL links sharing with captcha and password protected zip. Safely share your selected files and/or folders with anyone!

This is CloudDAVMod v1.0 and v1.1 for WDMyCloud V4 OS3 Firmware. For features, setups and details, refer to CloudDAVMod v1.1 for WD My Cloud firmware V4 | TeaNazaR.com.

Below are my simplified instructions on how to get it installed on the V4 OS3 firmware (will not work on older firmwares).

AND I have also made an online generic 64K page size memory package installer to simplify the installations of Debian packages on WDMyCloud. This will not work on older version 3 WD firmwares and I’m not planning to support it either as I’m sticking with the V4 firmwares. Based on dynamic server-side FastCGI, perl and shell scripts, I’ll be using this method for newer guides from now onwards. Feel free to parse the script codes. All bug reports, opinions and suggestions are welcomed.

The Generic Online Installer:

1) Auto download of required debs including its dependencies if any.
2) Debs installation in the required order to prevent dependency issues.
3) Auto run custom configurations if any.

If you proceed further, you are fully aware of the usual WD’s _warranty void _clauses including disclaimer from any damages that may resulted from this guide.

  • Enable SSH on your NAS from the WD DashBoard settings if not done so. SSH to your NAS port 22 using i.e. putty root@wdmycloud.

  • To proceed with the installation, first you need to get the username and password from me. The credentials will expire hourly e.g. “1AM,2AM,3AM…” to prevent intentional abuse on my network resources. Click on the link below to get the credentials :

    WDMyCloud | TeaNazaR.com

  • After obtaining the credentials, just copy & paste into the SSH terminal session of your WDMyCloud:

    export NAZAR78_USER=user; export NAZAR78_PASS=pass; export NAZAR78_KEYS=keys;

  • Then run the online installer on your WDMyCloud copy & paste as below, follow the instructions and enjoy (-:

    Version 1.0-04.04.02-105:
    curl teanazar.com/installer.fcgi?clouddavmod_1.0-04.04.02-105|sh;

    Version 1.0-04.04.03-113:
    curl teanazar.com/installer.fcgi?clouddavmod_1.0-04.04.03-113|sh;

    Version 1.1-04.04.04-101:
    curl teanazar.com/installer.fcgi?clouddavmod_1.1-04.04.04-101|sh;

    Version 1.1-04.04.05-101:
    curl teanazar.com/installer.fcgi?clouddavmod_1.1-04.04.05-101|sh;

    Version 1.1-04.05.00-315:
    curl teanazar.com/installer.fcgi?clouddavmod_1.1-04.05.00-315|sh;

    Version 1.1-04.05.00-320:
    curl teanazar.com/installer.fcgi?clouddavmod_1.1-04.05.00-320|sh;

    Version 1.1-04.05.00-327:
    curl teanazar.com/installer.fcgi?clouddavmod_1.1-04.05.00-327|sh;

    Version 1.1-04.05.00-334:
    curl teanazar.com/installer.fcgi?clouddavmod_1.1-04.05.00-334|sh;

    Version 1.1-04.05.00-342:
    curl teanazar.com/installer.fcgi?clouddavmod_1.1-04.05.00-342|sh;

    Version 1.1-04.05.00-353:
    curl teanazar.com/installer.fcgi?clouddavmod_1.1-04.05.00-353|sh;


  • Only compatible with MyCloud Single Bay Gen1, sorry I don’t have Gen2 or others to support.

  • Extremely slow browsing after initial installation? Or what is the remote URL to access externally? Please carefully READ and digest the “features, setups and details” guide in the link on top of this page.


  • Theme inspired from Apaxy by Adam Whitcroft.

  • Thanks to the regular users on this WD Community Forum especially Bennor and PhatTrance who helped with the preliminary findings and testing on OS3 firmware.

  • Huge appreciation to the hundreds over kind souls who has donated, some of which, very generously.

  • Any generous donation is appreciated. It helps to motivate developers and contributors keeping them active. Any generous Donation (-:

Online Installer change log:

[20160426] Added CloudDAVMod v1.0-04.04.02-105.
[20160524] Added CloudDAVMod v1.0-04.04.03-113.
[20160923] Added CloudDAVMod v1.1-04.04.04-101.
[20161221] Added CloudDAVMod v1.1-04.04.05-101.
[20170420] Added CloudDAVMod v1.1-04.05.00-315.
[20171227] Added CloudDAVMod v1.1-04.05.00-320.
[20180517] Added CloudDAVMod v1.1-04.05.00-327.
[20190331] Added CloudDAVMod v1.1-04.05.00-334.
[20191018] Added CloudDAVMod v1.1-04.05.00-342.
[20220129] Added CloudDAVMod v1.1-04.05.00-353.
Simple way to Access MyCloud NAS files remotely (SMB)?
Stream from WD My Cloud to vlc app
Restrict access to PUBLIC folder
Backup to mycloud from another network
Is there a way to turn off Zip download?
iTunes Remote Access
Connecting MyCloud via VPN
Why Myclod sync doesn't work?
Very Frustrated, darn thing worked a couple of years ago
Help needed for a newbie
Mapping MyCloud from another network
WD Sync "Cannot connect to remote server"
No Longer Able to "Mount Shares" remotely
Why WD servers to connect to my cloud
Web Link Drive Mapping
Remote streaming music app for Android
Setting up a shortcut desktop folder from Cloud on a remote location
Can't connect as network drive/open in explorer via internet
Mount MyCloud in finder from different network
Help please, in accessing my WD my cloud outside of my network
Access wdmycloud map drive remotly
Backup an network drive to my remote My Cloud on win 10
MY CLOUD - Online access
Need Help with Remotely Uploading - Super Slow!
Mapping a drive on mac
Remote access to Wd MyCloud
Access My Cloud from abroad
Access my MyCloud in Windows 10 Explorer when I'm out of my home network?
Remote search application for MyCloud
WD Sync and macOS High Sierra
HD not showing in finder remotely
OpenVPN and myCloud
WEBDAV bei MY Cloud (nicht Mirror od EX od. Home)
Viewing My Cloud files in Finder/Thumbnails for photo viewing
Remotely Mount MyCloud on a Mac over the internet
How to stream videos from MyCloud
External Media Server address
[network access] User cannot access through network
WDSync and Free filesync
Cannot map MyCloud to a network drive?
Editing and saving documents remotely
WebDAV not listed in Network Service options in settings menu
Accessing My Cloud on a different wifi
Wabdav for myCloud on windowns
Direct Save
WD My Cloud Map External Network Drive
Adding new App
AFP Remote Access with MyCloud not working
How can I access WD MyCloud Single Bay OS3 via WebDAV?
Backup to a WD Cloud in another location
Adieu WD MyCloud; Hello Seagate Personal Cloud (endless search for mapped remote drive)
WD Sync is NOT reliable and a huge disappointment
Connessione remota a cartella
How to access my cloud remotely from Windows
How can i map unc network to mycluod?
How can i map unc network to mycluod?
How can i map unc network to mycluod?
Remote backup issues help!
Search on the my Cloud
Six Terabytes of Data. Is a search feature under Window too much to ask for?
WD Sync Installer quit unexpectedly! (Mac OSX El Capitan)
Update: WD2Go.com (MyCloud.com) Back Online!
Watch videos from my cloud without to download them for extern
How a user can gain same possibilities as admin
Make computer folder backup to a remote My Cloud
I can't use my mapped network from home, only have web access (pc)
Attach files remotely to emails in outlook?
Can you Back up remotely over the internet?
[HowTo] Airport Express + MyCloud + remote access via Finder [Mac OS X]

Awesome work NazaR :wink: … this will change the we people will access their data.

1 Like

Thanks @SectorGZ

I couldn’t have done it without tremendous inputs and tesings testings from both @Bennor and @PhatTrance as I’m still using a very old v4 firmware :sweat:

I think we are on the same Firmware to be honest. :wink: Also “Thanks” goes to @Bennor and @PhatTrance for all your help and testing. As I mentioned before, this will change the we people will access their data.

1 Like

Your welcome! I’m sure this is what a lot of users have been waiting for!

It’s become my new file manager :wink: of choice!

1 Like

UPDATES: CloudDAVMod v1.0 for firmware V4 now released to public! More info from the top post. Enjoy (-:

Hi Nazar.
First of all, thank you so much for this DAVMod.

I’ve noticed that straming movies with AC3 audio is not supported. The audio in video files only works if it is AAC codec. Also I’ve noticed that x265 codec is not supported.

Are you planning to add streaming support for this codecs?


Hello Joaco_AR,

This HTML5 media streaming is pretty much tied to the browser support for both mobile and desktop. AC3 is licensed under Dolby which I don’t think can be easily supported by browsers. As for h/x.265, it’s still considered as new which I believe only appeared during early 2013? Therefore could be the reason it’s not currently listed under the HTML5 supported format:

I hope that HTML5 media codecs support will mature in years to come as we leave behind flash support.

Hi again, how can i uninstall apps? i probably not gonna need this one. But thanks anyway.

There’s no daemon running for this instance, just modifications to the WD core files. So there’s no need actually to uninstall.

If you insist, you can only disable the mod by dpkg -P clouddavmod>/dev/null 2>&1; which will remove any extra files installed but traces of modifications still remains that can only be cleaned by reflashing or firmware upgrade.

Post edited to remove text that may not appear in general release WebDAVMod install which may cause potential bricking when trying to uninstall the mod.

Using this command blindly can cause brick issues, hence I did not print the uninstall commands to the generic installer output. It’s an app to app basis due to dependencies circumstances. Some of the apps I built requires an upgrade to the existing dependencies which I foresee to be the case with this mod in the future when WD releases a new firmware with WebDAV traces completely removed.

i succed install WEBDAV and the ssh process
but i can to map only local lan

if i exit and connect wan . its didnt work for me plz help

this is the output of installtion:

now i run this -

but i get error

Do you have any other modifications done to the MyCloud? Try this on the terminal: service apache2 restart; then wait like 5mins before retrying the URL.

ps: pls remove your image, don’t advertise the URL, it contains your deviceID.


but i get the same error :slight_smile:

I’ll reply to your PM.

After troubleshooting, done double port forwarding to both your ISP and Asus router, then set your ISP router to bridge mode, it still failed. Further test with other random ports such as 1024 indicates your ISP is blocking all incoming ports :frowning:

Reminder to those using this mod, with the release of release of 04.04.03-114 today upgrading to that firmware may (will) break this mod and you may (will) have to reload it.

For those who’s following this post, a new version has been added to the first post. If you’re using the WebGUI, clear your browser’s cache i.e. CTRL+SHIFT+F5. As promised to my donors, they will be the first to receive newer builds. I’ll make it public soon so stay tuned (-:

[20160524] Added CloudDAVMod v1.0-04.04.03-113.

Captcha temporarily unavailable, upgrade in progress!

How do you know when you will be back online?