Very Frustrated, darn thing worked a couple of years ago

I have a WD cloud device. I used it in 2013 to have folks to upload their pictures from a Mule Trip to bottom of Grand Canyon. It worked great. It has been sitting idle since then.

I have a new project and wanted to use it again… Wow, it does not look the same and simply does not work to any advantage.

I updated the firmware as instructed, I then went to WD ToGo.com. I signed on and created shares.
i gave rights to the people. As a test I assigned a Test ID. I logged on using the test ID. What a change!!!
In my notes from before I told folks to sign on, view their shares, open in explorer, they could then add and delete files. Now there seems to be only an option to upload files, and no delete.

My firmware is 2xxxx and the latest instruction manual says only for firmware 4xxxx. So I am unsure what to do.

I am using Windows 10, ISP is Infinity (Comcast), Router is Netgear 7600.

Here is the User Manual for your My Cloud, I hope it helps.

https://www.wdc.com/content/dam/wdc/website/downloadable_assets/eng/user_manual/4779-705147.pdf

thank you…

It appears that the My Cloud has diminished its capability since 2013. The use of file Explorer was great. The single file at a time delete is a Royal Pain.

Check the My Cloud Dashboard to see what firmware version you are using. Firmware v4.x is for the first gen single bay My Cloud units. The v2.x firmware for the single bay My Cloud units is for the second generation version and that version wasn’t released to the consumer market until sometime around October 2015.

If you actually have a first generation v4.x single bay My Cloud then you may want to look at the following discussion which explains how to use SSH to install an unofficial mod that allows for remote mapping of the My cloud similar to how one used to be able to remote map a My Cloud using the MyCloud.com web portal before WD removed that feature well over a year ago.

https://community.wd.com/t/app-clouddavmod-various-versions-for-firmware-v4-12-2016/161543

v4.x Single Bay My Cloud User Manual: http://products.wdc.com/library/?id=439&type=25&cn=4779-705103&lang=en
v2.x Single Bay My Cloud User Manual: http://products.wdc.com/library/UM/ENG/4779-705147.pdf

1 Like

Now I am confused… I used MyCloud in 2013. When I tried to use it on Friday, it updated the firmware and I could have sworn it was v2xxxx,
My confusion is that first gen single bay my cloud units used v4,x and then used v2.x firmware at least two years later in 2015.
. I do know that the darn web access thing went from user friendly to OMG this stinks, . my unit is an old 2 terrabyte. I am going to try (again) to do a 40 second reset. Maybe I can wipe it all away and figure out what to do with the unit. it is of no use to me as a file uploader (not allowing folders) and then deleting files on a one by one basis.

Just an FYI, the first gen single bay My Cloud units didn’t use v2.x firmware numbers. It was either v3.x or v4.x.

You can see the full release history in the Release Notes for the first gen single bay My Cloud firmware:
http://support.wdc.com/download/notes/WD_My_Cloud_Firmware_Release_Notes_04.05.00-315.pdf?v=523