No Longer Able to "Mount Shares" remotely

I used to be able to not only access shares but mount them on my mac as well as long as I had web access. I was then told that that would no longer be possible because of some Java business that changed and I should use the mycloud app. It does still work but it does not allow me to do a “save as” directly to the drive since I cannot see it on my desktop. I now have to save it locally and the use finder to drag and drop it onto the folder in the WD app. This adds another step everytime I want to save things or open them because I constantly have to use that app rather than using the share just like a drive on my desktop.

I see that I can again access the shares via the web but I do not see how to mount the shares. Is that still not available???

Is that still not available

No. That was one of the ‘improvements’ introduced by OS3.

No. WD removed that feature when they revamped the website (now There are a LOT of complaints about it in this subforum. Feel free to voice your views in the following thread as others have done.

Tried to post but the above discussion is now closed. I just bought the EX2 Ultra and didnt even realise the remote mapping of drives feature has been removed. I assumed it was a default feature. Has anyone received feedback from WD if it will be reinstated at some point? Do we really have to deal only with the Mobile & Desktop App? (which are terrible btw, I have only used it for 2 days and its extremely user unfriendly).

I plan to bring my EX2 Ultra back and get a better NAS. Anyone know any similar preconfigured NAS servers provide remote mapping of drives?

First, there is a dedicated EX2 subforum, this subforum (My Cloud) is generally for the single bay/single drive My Cloud.

Second, WD has stated there are no plans to reintroduce or bring back the ability to remote map a My Cloud device that they took away when they released the OS 3 firmware over a year ago.

For single bay/single drive My Cloud users who’s My Cloud unit is running firmware v4.x, there is an unofficial workaround to this issue that will allow one to map a remote v4.x single bay My Cloud. Note this ONLY works for v4.x firmware single bay My Cloud units. See the following post for more information: