[network access] User cannot access through network


I’m facing a strange problem now.
One of the users of my WD Personal Cloud cannot access through network share. When he tries to login the same fails and the login is prompted again. This happens in Windows but happens also in Linux.
When the same user tries to login in the mobile cloud app or in the browser (only in windows because after all this years the browser cloud funcionality still not works for Linux users, a shame…) it works as it should be.

Also i tried to create a new users and happens the same, in the app or browser works great in network share simply refuse to login!

I already rebooted, turn off, disconnected and did other things but nothing worked.

There are 9 users and 10 share in he cloud and the firmware version is v04.01.04-422. The diagnosis is OK!

Thanks for the help.

Best Regards.

1 Like

Hi there and welcome to the WD community.

what error exactly do you get when the user tried to log in ? I could be that there is another user logged in at he moment, you can also try to access the unit through the IP instead of the name or vice versa

Hi again!

There is no error.

When i enter the share ask for the login credentials, i insert user and password and when i click ok simply ask the credentials again, and again, and again… It’s the same compotment as if the credentials are wrong but they are not, i use them for online login in wd2go.com or mobile app and they work.

And another thing is that if i create a new user happens the same, i can login in mobile app and wd2go.com but in the windows share (or samba share if in Linux) it fails without any error, simply ask for the credentials again and again and again… The old users works fine.

The comportment is same with IP or name.

Thanks for the help,

Best Regards.

1 Like

I have the exact same problem. Some users can’t get access even though they have access granted (see attached screenshots)

Same issue. I am trying to set up a Win 10 to backup to MyCloud with File History and map a drive letter to MyCloud. Both times I get a message to sign in. I use the same userid and password I use to sign into the MyCloud website and it tells me access denied.

. I can use my credentials to access the MyCloud through the web or the MyCloud shortcut on the desktop. Win 10, Anniversary edition, Firefox 50.0. My Cloud 2 TB drive. Any help would be appreciated.

You use the User credentials you created in the My Cloud Dashboard, NOT the user credentials you used to setup a MyCloud.com web portal account. They are two different accounts.

Edit to add: Officially you can ONLY map a drive locally on the same local network as the My Cloud. Users with the v4.x firmware My Cloud units can install an unofficial app called CloudDAVMod that provides remote mapping capabilities.


1 Like

I set up MyCloud Dashboard with a password. I tried to back up using the userid and password for the MC Dashboard. Same message.

Are you trying to access locally or remotely?

Do you have any MyCloud shares mapped as network drives? Public, for instance? You must map all drives with the same credentials (those of your MyCloud user), even for Public; a Windows restriction. Unmap all network drives and map them again, forcing ‘use other credentials’.

*** SOLVED ***
My problem was that the users also were in a group that did not have access to the respecting folders. WD prioritizes deny access over read only or read/write access. I think this priorization queue does not make sense and unless it is changed such that deny has least priority, groups should hardly be used at all!