Easy method to downgrade to previous version of the firmware

Hi All,

I was having all sort of problems after upgrading to version 4. I am not comfortable with all the SSH editing but I got help from the WD support team to downgrade with minimal SSH work. It’s pretty easy. 

Here are the instructions: 

 Download the following firmware version and unzip the .deb file (File sq-030401-230-20140415.deb.zip)   http://download.wdc.com/nas/sq-030401-230-20140415.deb.zip

 

Then download Winscp and install it:  http://winscp.net/eng/download.php 

You need to “turn on SSH” from Settings > Network in Wd My Cloud web interface.

Now run Winscp program you have installed earlier. In the Login window 

select “SFTP” in File protocol dropdown

Enter your My Cloud IP adress in the host name

The default usename is root and password is welc0me (its the number 0 in welcome and not letter O)

Once you login you will see 2 panes in the window.

Go to the right pane and naviagte to the folder “etc”.

Once in the “etc” folder scroll down to the bottom and you will see a file called “version”.

Double click to ope the file and change the version name to 03.04.01-219 and save the file. 

Thats all the SSH work. Now close and exit Winscp application.

Reboot My Cloud.  (Settings > Utilities > Device Maintenance > Reboot)

After it has rebooted go into settings > firmware and click on “select from file”. Naigate to the sq-030401-230-20140415…deb file you have downloaded earlier and update. 

DONE. Now you will be running the previous version. Bye Bye buggy frustating version 4. :smiley:

MKAE SURE TO TURN OFF AUTO UPDATE FIRMWARE.

PS: It worked for me so hopfully it will work for others also. I am a noob, can some experts check it and provide feedback. 

Just to let you know  - try it at your own risk. I can’t be held responsible if something goes wrong during the process.

[Edit - Bill_S]

Note: Users, please be aware that making changes to your drive through SSH can void your warranty.

17 Likes
Cant Connect to My cloud after Firmware update ? Help
Ältere Versionen von "WD My Cloud" Firmware, Downloadlink
Slow slow performance after WDMYCLOUD firmware upgrade 4.00.00-607
Update Firmware Error: Device does not have enough space for upgrade. (370002)
Dasboard nicht mehr erreichbar, Netzlaufwerke weg etc etc
Apt-get always fails
How Can I roll back to previoius firmware
New Release Firmware Release 04.04.02-105 (1/27/2016)
[ Tutorial ][ SSH Method ] Downgrade v4 firmware to v3
Ruckler bei der 04.04.03-113
WD MyCloud Gen2 - Enable apps install tab + Apps!
Back to previous firmware, Is it possible?
Safepoint wont update automatically
WD My Cloud v3.x, v4.x and v2.x Firmware Versions Download Links
Manual Update error - Device does not have enough space for upgrade
No data on my external drive (connected on the USB port from WD My Cloud)
No data on my external drive (connected on the USB port from WD My Cloud)
Reverting back to previous firmware from WDMyCloud v04.04.00-303
My Cloud Firmware 4.01.04.42​2 Feedback
Music tracks disappear from My Cloud
v04.01.03-421 firmware is flaky
New Release - WD My Cloud Firmware Release 4.01.03-421 (2/23/15)
WDmycloud not working after installing new firmware v04-01.02-417
My Cloud will not set a Safepoint, WD says can't tell me why due to confidential nature of issue?
My Cloud becomes inaccessible when a USB drive is connected
Poll ! Who has reverted to V3 firmware and why?
Poll ! Who has reverted to V3 firmware and why?
Poll ! Who has reverted to V3 firmware and why?
Poll ! Who has reverted to V3 firmware and why?
Anyone upgraded their My Cloud Firmware to 4.01.02-41​7? Is this still buggy?
Wd ui iso image? (help!)
Crash as soon as usb drive connected
SSH in the latest firmware?
Safepoints and firmware 4.00.00-607
When will be new firmware? - My Cloud i s very slow
Very very slow MyCloud
Mycloud 2tb in small office - downgrade fixed my speed issue
How to rollback Firmware
Weird happening
Firmware update hangs at 10 percent
Firmware update hangs at 10 percent
Fluctuating transfer speeds
How to setup WD Mycloud?
WD MyCloud - Issue
ALL OF MY Cloud Problems Solved!
Updating it to a specific firmware build
Delete one file within folder
Firmware 4.00.00-607 needs to be updated ASAP
Safepoint failure since FW upgrade
My Cloud now super slow after firmware update
New firmware issues - can I downgrade?
Rollback Firmware?
OwnCloud
How to Install Bittorrent Sync on the WD My Cloud (Windows)
Problem mit extener USB-Festplatte bei Erstellung SafePoint
Ältere Versionen von "WD My Cloud" Firmware, Downloadlink
Update 2.31.149
New user,,,with issues!
[ Tutorial ][ SSH Method ] Downgrade v4 firmware to v3
Can't past Authentication in WD My Cloud UI, reset not working
Rolled back firmware to V3 now what do I do? (Shellshock)
Before you RMA your Device ... let's talk about your problems!
Disconnection issue, not yet solved, New WD Mycloud

hi there thanks for that suggestion but did not work for me

 when trying to update from file it say’s     ‘not enough space to do an update’

tried with automated wd update from gui and it worked  

now it is still on v.4.0

any idea?

Thanks this worked for me!

When performed properly, does this roll-back method result in any loss of data; either on the shares or in the configs (i.e. user accounts, etc), or does it leave everything else there just as it was before?

Hi cagoune. I do not have much technical knowledge. I have listed the steps used by the WD support person.
Did you reboot the device after changing the version? You need to reboot the device before applying the manual firmware upgrade.
Sorry I am not of much help.

1 Like

Hi iPCMD - as far as i know this roll back won’t result in any data loss or change is settings or shares etc. All my files and settings remained the same.

2 Likes

iPCMD - Just a quick suggestion if you don’t mind. If you are scared of losing your files I would suggest backing up all the files before you go ahead.

Registered just to thank OP.  Latest firmware is rubbish. Downgrading made my device usable again.

Also, FWIW, my tip is to stop using DLNA in favor of Samba.

I tried this today and followed the instructions step by step, but also got the error message “not enough space on this device to update”. Would appreciate any help to complete the downgrade…

Ha! I solved it myself. You need to have the BIOS saved onto the WD Mycloud drive, e.g. on the Public Share folder. I was trying to update the BIOS with the deb file on my laptop. Doh!

My firmware was on the HDD of my PC, so your error was caused by another factor, it would seem.

great, thanks for posting this, it worked but my transfer speed are not super fast i get 6mb writing and 5mb copying from the my cloud, at least now its constant speed…

Thanks this worked also for me!

Yes! Worked for me, too. Firmware was on my PC not on the My Cloud. It is now indexing ALL my media files without getting stuck and is responsive as it was originally.

Of course, this begs the question, why don’t WD “upgrade” back to the old versionuntil they get v4 working? They would have a better reputaion if thei rproducts worked, surely?

1 Like

Happy to know that it’s working for others.

The issue is when the system is unstable, it will actually show no space in the home screen and thus the system doesn’t see that it has room to update.  Give it a minute or two (or three or four or twenty) to stablize a bit for the UI to show the capacity amount.  When it finally shows that figure, then the system will accept the firmware.

To whom it may concern at Western Digital - this latest firmware *is* unstable.  You need to take action here.  This is unacceptable customer support.

1 Like

Your method worked flawlessly for me. I downgraded without problems. Only thing missing from fw v4 is LG TV Dlna srt support, but i can live without it :wink:

Worked fine for me. Thank you!!

What a difference, I just installed the MyCloud a week ago and it updated the 4.xx firmware immediatly so I couldn’t see what difference it was with the previous one. Downgraded as per your instructions and the device is A LOT more responsive, faster in access and in it’s interface…

Only must find out how to disable the constant database update for pics because I have 2 webcams attached over FTP so the disk is always updating the database but I will find out. The method as described in another posting here didn’t work for me but the downgrade is working a lot better so MANY thanks for the help!!!

Too bad WD won’t admitt something went bad with the 4.xx firmware upgrade since so many users have problems with it.

They should replace it immediatly with the old version and call it 5.xx :wink:

Regards and thanks again.

Thanks a lot!

Your instructions worked flawlessly (even though I used SSH).

4.00.00-607 was truly a dud (for me, your mileage may vary of course) and now I finally have my nice old NAS back again…

Thanks again!