Disconnection issue, not yet solved, New WD Mycloud

Hey Guys,

i bought a mycloud storage a few days ago and its been a nightmare.

i have had glimmers of the amazingness of the product but i am being consistently hampered by the fact it keeps disconnecting.

It works fine for a few hours after a reset, but the problem is my drive is not accessable when i get to work as it is at home.

i have seen many threads that say it is solved but i have upgraded the firmware and still have the issue, i cant even e-mail support or call them for some reason so i am very annoyed.

please help me


Not accessible using what software or web portal?

Is Remote Access enabled? Dashboard > Settings > Cloud Access > Remote Access = On.
Have you granted Users Remote Access? Dashboard > Cloud Access > [select User].

If you haven’t done so already, it is recommended one read the WD My Cloud User Manual as it explains how to configure and use remote access.

yes it is enabled, many people have blogged this issue, but said the firmware fixed it, mine has not fixed and i got the last firmware from december 15. Please help me as i realy need this working

apparently there was a fix, but the firmware dissapeared

There is a difference between not being able to connect to the My Cloud, and being able to connect and access the My Cloud remotely, but have it disconnect.

Again, what software or program are you using to connect to the My Cloud remotely from your work?

Have you checked that the My Cloud has “internet access” via the Dashboard > Settings > Network > Network Profile > Status field.

It is a bit difficult for we users to help diagnose the issue and provide possible solutions without more information. It helps to provide as much information as possible like; what steps have you tried to solve the problem, what is your local network setup, is the My Cloud using a static IP or DHCP, does the My Cloud indicate an internet connection, what software (and their versions) are you using to access the drive remotely, can the unit even be accessed remotely.

It is possible to roll back to an earlier firmware version. But please note that rolling back to a prior firmware version may break remote access using the latest WD software, apps and MyCloud.com web portal. See the following thread in particular my post in that thread with links to older firmware versions.


I have used it before at work and all settings are correct. I use my cloud app on Windows 10. My issue is that it disconnects while I am at work. So it seems it’s a firmware or software issue

Hi Lavjit_Sra,

Have you contacted support for them to maybe take you through all the steps, just in case there is more to this that we may need to know? And also, have you tried using Webfiles throught mycloud.com?

This sounds very similar to my issue - has it been resolved?


What solved it?

If you can SSH into the My Cloud. You can look at the daemon.log and daemon.log.1 files.
When the network goes down a message is logged to this file saying the following:
2016-01-19T17:47:13.747137-05:00 di=WfOf5hjVLP info ifplugd(eth0)[5876]: Executing ‘/etc/ifplugd/ifplugd.action eth0 down’
When the network comes back you will get the following:
2016-01-19T17:47:50.651920-05:00 di=WfOf5hjVLP info ifplugd(eth0)[5876]: Executing ‘/etc/ifplugd/ifplugd.action eth0 up’
Notice the date and time of the network going down. I caused these messages to be logged by pulling the network cable. If your network is going down as often as you say it is you should see a lot of these messages.

I was trying to see what happens when the network is down and you try to access the dashboard. If the network is down. When you try to access the dashboard you will see in the tab connecting with the arrow going round and round. If the network is up and apache2 is not running you will get the usual try again box.


Thanks RAC - did it help you pin point the issue?

Lavjit_Sra - what sorted it for you?

I didn’t have an issue. I was just posting information to help gather data about the failure. Have you checked the daemon.log file. You need to know if your network is dropping its connection. Or is it something else that is causing your disconnects.


Gave it a static id and stop the hard disk running down. It’s been online for 2 weeks and is fine

sorry guys, all i done was reserve an ip address on my router for the WD cloud, in my opinion you have good power ups and bad power ups… my system has now been running for 12 months constantly and not had any problems i stream 4 k content from it at home and save my work to it from work, it is a great product and this was a problem i only faced because i lacked the knowledge to assign it an IP