Safepoint wont update automatically


I have a My Cloud 2TB, with an attached 1TB external drive (I have only 630GB of used space). When I schedule the safepoint update it does literally nothing. But, if I manually update the safepoint, it works with no problem. I have this problem for almost an year and after several firmware updates it remains.

I already rebooted the device, deleted the safepoint, create a new safepoint and made a system reset, but none of these solutions worked.

Any idea what might be the problem?


I take it that you are saying after following the below steps nothing happens.

Updating a Safepoint
There are two ways to update an existing safepoint:
Automatically - you set the frequency, date, and time when the update occurs

To update a safepoint automatically:
Click Safepoints.
In the left pane, select the safepoint you want change.
Turn on Auto Update.
In the Safepoint Update Schedule dialog box, make your changes to the safepoint (frequency, day, and time), and then click OK.


Thanks for the reply. I’ve done that dozens of times :slight_smile:

If I click “Update” it starts the update, but if I go to “Details” near the “Auto Update” button and set the frequency/hour, nothing happens. You can see that the last update was on “February 04, 2017 4:48:19 PM” (last time I run it manually) but I’ve scheduled a daily update since then.

Couple of suggestions. First, have you checked the Dashboard > Settings > General > Language & Clock to ensure it is showing the right time, that the correct timezone is set and that NTP service is enabled? Second, have you tried a 40 second reset then a reconfiguration of the My Cloud to see if that clears the Safepoint issue? Sometimes a 40 second reset will fix the odd ball error with the My Cloud.

1 Like

Hello Bennor, thanks for the reply. Yes, the timezone is correct and the NTP was already enabled. I tried the 40 second reset, but the problem remains. :worried: I also format the external hard drive, but it doesn’t help either.

I also contacted the WD support, but so far we couldn’t solve this problem.

If I update the safepoint manually, it still works, but sadly the schedule option doesn’t work.

If someone have other ideas, I’m willing to try everything to make this feature work :slight_smile:


Did you get this figured out? Also, in reading on how to create the safepoint backup, I found that you have to set the Auto Update before you start your first backup, or it will only do the manual backup from then on.

I have exactly the same problem. In fact I have two MyClouds both running f/w v04.05.00-315 each connected to a MyBook USB for safepoint backups. The original safepoints were established with autobackup and this ran successfully. I suspect the auto backup failed when I updated from v3 f/w. Now the safepoint scheduling no longer works. The safepoints will complete successfully using the manual method.

I have already done factory restores. Please don’t tell me to delete the safepoints and redo them. I don’t want to downgrade to v3 again. There must be another way?

I managed to resolve my own problem by trial and error. It seems that the MyCloud must have a connection to the internet before it will do the automatic safepoint updates. According to my experience, the cloud access function does not need to be enabled, but the MyCloud must have a connection to the internet. My problem was that MyCloud serve my local network but sit behind the gateway router and could not access the internet directly. This was my idea of a more secure setup. Once I had set up port forwarding on the gateway the MyClouds would successfully carry out the automatic safepoint updates. That seems a bit strange to me as I thought that these devices would use their internal clocks when checking for scheduled tasks.

1 Like

Did anybody solve this problem? I bought a 2TB single drive unit and have never been able to get the safepoint automatic update to work. Regardless of making safepoint via USB or via LAN to a SMB share. No problems with creating the safepoint, but the device doesn’t auto update according to schedule.

I’ve tried resetting the device, checked all settings, re-created the safepoint and all the tips I can find on the internet. No help. Firmware is the latest available. My device has no problems with internet connection, it is connected all the time.

This is really frustrating, since I would have liked to have this as my main storage device for my work, but since the device doesn’t back up I can’t risk losing all my data if the device would fail.

And no, I’m not going to use any third-party backup solutions, I want the device work as it should, by itself.

I’ve been facing the same issues to for the past few months. I initially stumbled across this thread and tried allowing my NAS access to the internet as I had blocked it on the router, reformatted usb drive, wdcloud etc none of which worked.

Essentially the issue stems from one of the firmwares released this year has broken the functionality circa June this year 2017.

The only solution that’s fixed this issue for me was restoring back to a firmware version that I knew worked. Without wanting to try every iteration i.e guessing, I settled for the first v4 release this year v04.04.02-105 and it’s back to auto backing up.

However initially you will need to follow this guide and revert the firmware version to predate the version you want to update too.

Read this but substitute the new firmware to be the version I have. I tried V3, but it was not working correctly for me and lost all my content, albeit the revised v04.04.02-105 it was back as before.

I would like to iterate I have the same problems; V3 firmware would work with automatic safepoints, but somewhere along the line V4 will only do manual safepoints.

Western digital doesn’t ever look into complaints. It’s been over a year and it still doesn’t work. I suspect it is just not setting up a chron job or something.

For some Safepoints work fine, for others it doesn’t. Seems to be hit or miss. Currently Safeponts working for me to update every day on a first gen running 4.05.00-320. What I have found is that if a I do have a problem with Safepoints to delete the Safepoint in the Dashboard then delete the entire Safepoint folder from the USB hard drive. Then setup a brand new Safepoint.

Another issue I’ve found is that if I restart my first gen using the Dashboard or via SSH command, often times the USB drive isn’t mounted when the My Cloud reboots which predictably causes the Safepoint to fail. The solution was to Shutdown the My Cloud, then remove power. Then power the My Cloud back on rather than doing a Restart.

Scheduled Safepoint is not working for me.

WD MyCloud Gen 1
Firmware v04.05.00-342

I have attempted these steps:

I have also attempted the steps above, except deleting the existing Safepoint and starting over from scratch. Only the initial and manual Safepoint works, but not scheduled updates.

Scheduled Safepoints are not working for me.

WD My Cloud Gen 1
Firmware v04.05.00-342

Attempting to Schedule Safepoints via USB to a WD My Book.

Manual Safepoints work fine. Only Scheduled Safepoints do not work.

I have already attempted the steps detailed here (I’ve also repeated these steps, deleting any existing Safepoints on the USB drive):

Does the My Cloud or Safepoint page indicate a reason for the scheduled Safepoint failure? Is there an alert or warning message under the Notification/Alert icon (mycloudnotificationicon ) that indicates a reason for the scheduled Safepoint failure?

Do you have another hard drive you can use as a Safepoint target as a troubleshooting test?

As a troubleshooting step, can you change the hibernation/sleep time out on the My Book external hard drive? For example turning such a feature off for the external drive? Could be the drive is going into hibernation/sleep mode and isn’t coming back out when the My Cloud attempts to perform a scheduled Safepoint.

Thanks for the reply and suggestions. Answers to date below.



I’ll look into this.

I’ll look into this.

I looked into this. I turned off the hibernation/sleep time on both the My Book external hard drive and the My Cloud. It does not appear that the auto update Safepoint ran at the scheduled time.

If there are no changes to the data on the source My Cloud since the last completed Safepoint, will the auto update Safepoint “Updated On” datestamp and timestamp not change? In other words, does auto update Safepoint only run when there are changes on the source My Cloud?

The first time one creates and runs a Safepoint backup it will backup all information/files on the first gen single bay My Cloud. Each subsequent manual or scheduled Safepoint backup should only backup new or changed files to the backup location/target. And remove any files on the backup location/target that were removed/deleted from the My Cloud. This is why the very first Safepoint backup often takes a long time, and why subsequent backups typically are performed very quickly.

When the Update On option is enabled, and a scheduled time to run is set/created, the Safepoint should run at the scheduled date/time from that point on. Until one turns the Update On setting Off.

More Safepoint information and solutions to some Safepoint issues can be found in the following WD Support Knowledgebase Article.

My Cloud Safepoint and Backup Online User Guide and Solutions

Got it. Thanks.

If there is no new data since the last Safepoint, will the “Updated On” date stamp and time stamp in the My Cloud Dashboard change?