WD MyCloud OS3 : Constant disk Thrashing

I have noticed over the last few weeks that my WD MyCloud has been constantly thrashing the disk. As it sits in the cupboard of a spare room it’s not something I monitor closely but it’s the constant disk seeking reverberating through the house that drew my attention. I have moved it to my office and I see that it is constantly saying “rebuilding” in the Content scan, day after day after day.
I have owned this unit for 7 years and it has been great but it seems that maybe the latest firmware has caused this fault. I have tried going back one release to 040500-342 but when I try and load it I either get “Invalid firmware package. (370001)” or “Device does not have enough space for upgrade.”. All previous versions have been locked by WD so you can’t get access to even try them. The source that is available elsewhere needs an x86 Debian PC to build it and I just have Rasp Pi’s so that isn’t an option either.

I thought the impending demise of cloud access to be pretty bad PR from WD but if their penultimate release of firmware nobbles access when just on a LAN then it’s curtains for WD in my book.

I also have a MyCloud Home but this always was ■■■■ in comparison as it doesn’t have FTP and didn’t do DLNA so it nearly got returned within a few days but decided to use it purely for backup.

Generally the My Cloud OS won’t let you revert back to earlier firmware. Unfortunately WD removed or has hidden the previous firmware files that used to be available. If one does have a copy of the older firmware for a OS3 single bay My Cloud one can try to roll it back using SSH. One does so at their own risk!!! See the following post (or use the forum search feature) that has some information on trying to roll back the firmware of a single bay OS3 My Cloud. Note the information below applies ONLY to OS3 firmware. If your device is using OS5 that will likely require a different method of rolling back from OS5 to OS3.

Thanks, the downgrade seems to have been successful, frighteningly long pauses before it responded during the process…

The wdmcserver is top of the “top” list with cpu useage of 10 to 55% I will leave it for a few hours and see if it settles down and stops rebuilding.
Now I have started exploring with ssh and also realising there is the Twonky browser interface I have set the Twonky rescan to zero to see if it will stop once the rebuild has completed once.
If I look in the wdmcserver.log all the lines are saying database busy like this one:-
Info Database is busy, waiting a second before retrying: ‘BEGIN IMMEDIATE’.

I suspect it will be busy forever. Anyone know how to stop, re-initialise, rebuild the database within ssh ?
I suspect something is screwed and the WD browser interface doesn’t enable that level of control.

Disable Remote Access/Cloud Access, Twonky Media Server, and iTunes media server through the My Cloud Dashboard and see if that helps with reducing disk access. There are a number of other services the OS3 My Cloud firmware runs at boot that can keep the My Cloud occupied and running. Search the OS3 subforum for “sleep” to find a number of past discussions about disabling a variety of services that help with the sleep issue (and may help with other issues).

The general recommendation for sleep (and some other performance issues) was to stop (at startup) the following services, but doing so may impact certain My Cloud features. Various past threads describe how to stop these services in the gen 1 single bay My Cloud (v4.x firmware) and the gen 2 single bay My Cloud (v2.x firmware).


Hi Buchanan, The server should be idle as nothing externally is happening to request even a disk access let alone be swapping virtual memory.

I have disabled Cloud access anyway, I never enable or use iTunes. I tried disabling DLNA (Twonky) but that still left wdmcserver high on the process list. I have stopped the wdmcserver by following this:-
which settled down the disk activity. I then re-enabled DNLA which leads to twonkyserver causing significant disk activity which eventually settled down as expected.
I have now permanenty disabled wdmcserver using -
update-rc.d wdmcserverd disable
(and I will never load another version of the firmware)

It’s amazing how common this problem has been for so many people over the years with no interest from WD in fixing it. Especially when it is a process that doesn’t seem to do anything useful but can create such a big problem.
Thanks for your help ‘Bennor’.

If I re-enable cloud access then wdmcserver starts up again. It seems that wdmcserver is also involved with the sync backup of my ‘myCloud’ to ‘myCloud Home’ which I use but can’t even remember how it is set up.
Also disabling Cloud access stops my tablets and phone from backing up to the myCloud even when on the local LAN.
So it looks like in the short term I will be disabling Cloud access, disabling wdmcserver and doing manual backups until I can re think my system using non WD hardware even if I use the WD disks.
A real shame they have screwed it up big time.