What have they done with the WD mycloud. I cannot get it working anymore. I am not very good with tech but it was working now it’s not. NOT HAPPY AT ALL

Can’t you make this easy

Which WDMYCLOUD do you own, a 1st generation or 2nd generation? OS3 or OS5?

I have one of each and they are both working fine. I just updated the 1st generation OS 3 firmware last night.

I’m not sure, just frustrated. I set it up 3 years ago and worked great. I have tried to figure out how to upgrade but it’s not working. Thanks for trying to help me but I’m not happy with WD and their support. I have all Apple products and they update everything automatically so I just think they are set up for more people who know more than I do.

Post the specific error message you are seeing, the color of the front LED, or at the very least post the specifics (not generalities and not “it doesn’t work”) of your issue. People need additional information in order to try and help you fix or diagnose your issue(s). Can you access the My Cloud Dashboard? If so what does it indicate for the firmware version?

Note that a My Cloud Home is a completely different device than a My Cloud device. There is a separate subforum for My Cloud Home discusson.