Cant use WD My Cloud "cloud access" feature after firmware downgrade


I recently downgraded the firmware of my WD mycloud 4TB from 4.4 to v03.04.01-230 that im currently on. Everything is working much better except the only thing is i cant use the cloud feature now.

was working on 4.4 but now in settings > general under cloud access it constantly says

Trying to establish a remote access connection…

Tried all the obvious stuff, turn on and off, system reset, static IP, access ports forwarded ect ect

If anyone could help or has had a similar problem please let me know


You might need to contact support for them to help you on this. I know we don’t really recommend downgrading on the NAS drives. And, aside from what you’ve already done, I wouldn’t know what else to tell you.

welcome back Bill_S. I assume you are back from your extended needed holidays :stuck_out_tongue:

You should tell them what you told me last year that OS3 will be the only firmware supported for remote access which was the reason that I was reluctantly forced to upgrade which resulted in my whining in here for weeks on end.

With that said, @matt_mahdavi, you will need to go back to the latest firmware in order to get remote access. They changed their servers so older firmware is no longer supported. Bill_S is still recovering from his holidays otherwise he would have said so… again…

Yes, I probably am still recovering. :laughing: But the version 4.4 was throwing me off. That’s why I sent him to support.

is there absolutely no way around this?

That’s why I referred you to support. They would know. Have you contacted them, yet?

You will need to contact support. You went from OS3 to OS1. I didn’t think you could do that. Let me know if you have or haven’t contacted support.

Thanks for the replies,

If I do that I think they will just tell me to update the firmware.

I’m thinking that maybe I could SSH and change the version name to trick it into thinking it has the latest firmware, what do you think?

I’d be careful doing that. How exactly are you trying to establish a remote connection?

what i mean by remote connection is the actual cloud feature

That’s still not making sense to me. Are you trying to use Are you trying to use the original My Cloud desktop app to access your drive? If not, try those, and see if your drive shows up.