No network access since firmware upgrade


This firmware is obviously **bleep**. Since updating the WD My Cloud cannot be accessed at all. The light on the front is a lovely blue.  When you reboot it, for about 60 seconds the dashboard is accessible, then it gives error message about “Network connectivity issues”, after which it is no longer accessible.  Light is still blue, but cannot connect to it.  Why, or why do WD issue such **bleep** stuff??!?  Do they not have a panel of real users to test this with before issuing it in the wild???

So, I guess I’ll just have to wait now for someone at WD to realise they screwed up, like they did with iTunes in the last firmware upgrade.  Children at the wheel.  Sheesh.

 just updated the firmware yesterday and  …i cannot use my cloud anymore and trying to acces the dashboard also make me upset. WD please resolve this issues

Do you have a static IP set? if not check your router to see what the current IP is and I suggest setting a static once this is resolved.

these steps assume Windows, I assume there is similier things on Mac.

in a command prompt enter ping ipaddress. what do you get?

in a browser (try different onse if you have more installed) enter http://ipaddress/ui what does this do?

in file explorer enter \ipaddress and see if you see your shares.

do you have SSH enabled?

Hi larryg0, Thanks for your comments. I’m afraid though you miss the point. The issue is that a WD issued firmware upgrade should just work. Simple. Nothing more. Whether I have static or DHCP IP address, etc. ought to be irrelevant. I’m a normal user using the My Cloud as it is intended. I expect the firmware upgrade to work. Not for it to work only if I have a static IP, or only if I haven’t renamed it, or only if I don’t have USB drive attached to it, etc.

Right now the light is blue, but there is no connectivity at all after about 60 seconds following a reboot. WD have screwed up massively. How will I even access the My Cloud to launch a revised firmware? Assuming they get around to fixing it.

These screw-ups always go the same way: 1) Deny there’s a problem. 2) Accept there’s a problem, but it’s the users’ fault. 3) Finally, a senior exec at WD reports the problem on their own box - Oh-oh! Now it’s a real problem. And then some butts are kicked and a solution emerges after lots more backtracking by the techie staff.

Meanwhile, we hapless customers just have to wait.

I’m afraid I have to agree, everytime they release something, it’s rubbish and they never seem to acknowledge it. Following my last call to the tech support line whereby they didn’t even know that a firmware update had been released and then announced that they had had lots of calls listing the same things why haven’t they pulled this firmware?

They do themselves no favours whatsoever, WHEN ARE YOU GOING TO WAKE UP WD? You are risking customers valuable data here and have an attitude that **bleep**. As soon as I get mine in a usuable condition, i’m selling it and going elsewhere and am advising others who ask for my advice not to use this device.

Well I hate to ask, but did you stop to read the notice that was part of the firmware update?  Did you understand what it said before you went forward?   It did say NFS was removed.

You can access the IP adderss from the LCD on the EX4, and they punch it into your browser or explorer.

plz just try unplug and then replug your network-cable of my cloud. Worked for me! :smiley:

Same issues here, none of the desktop apps can connect to it as well as the android and ios apps. They can “see” the MyCloud but thats about it… One app reports I should upgrade the firmware! I got a good chuckle out of that one :slight_smile: I can however, map directly into the drive through Finder on my Mac but other than that that’s all she wrote. I made it into the dashboard once through my browser, but not since… Perplexing since it’s not completely broke…

Same happening to me.  jeez…  any solutions anyone??

Hello hamsterami, Tried rebooting Wd My Cloud, unplugging all cables, rebooting router, etc. All leads to same result: blue light, 60 seconds worth of access, then disconnected from network. Thanks for your suggestion, but didn’t work.

Hello reiverson, I’m not sure you appreciate that this is a consumer-oriented product sold on Amazon. As such, I don’t know what NFS, EX4 or LCD mean. Nor should I. Nor do I read any firmware “notice” since the My Cloud automatically upgrades firmware thanks to a switch that says auto-upgrade.

If there is a reason that means the firmware upgrade is not recommended for my setup, then I would expect the software to say so. Many software downloads check to see if they can be loaded beforehand.

Sounds to me that you were trained in the “customers are the problem” school of IT. You ought to click on the link that says “Hate consumers? We’re hiring - Join our team!”

In the real world, I just want a backup device that works simply. I have two Macs, two iPads, an AppleTV and they all work without my needing to know anything technical. The My Cloud has been a huge time-wasting disaster. Oh! by the way, I was told emphatically by WD customer service that I couldn’t get iTunes to work because I was technically illiterate. Of course, the real reason was the last firmware was rotten. But it’s so much more rewarding to blame the customer…

1 Like

I’m a day late and lost my cloud services.  Shame a firmware can do this to a very expensive piece of equipment.

this is a little messy but this just worked for me:

  1. go to your dashboard > settings > utilities

2.  Select “System Restore” Restore to Default

This will restore the settings but maintain the updated firmware and allows you to to function as normal.  You will need to launch the dashboard from the IP address then go through the setup but once you’re done you should be back up and running.If this works for you please share! Good lesson for me, do NOT upgrade the firmware until it’sconfirmed by others it won’t break anything.Cheers!!


i updated today and it all works fine, so the firmware cant be all bad

I agree, see image below, and I have not had any problems. When I found out about the update I went to the Dashboard and updated mine.

Posted by,
cat0w (USA)

Updated and all is fine, all files accessible, speec is good, app works better.

I updated with no problems and as far as the no network connectivity goes in all my cases about 99% of the time the issue is with a client firewall or router firewall blocking the connection. Go through your router and firewall settings try restoring your router to default and see if that helps. 

Mine was running fine but after updating the firmware it is slow and unresponsive, seems to hang and no longer will shut down properly.

I am going to try a system restore tonight and hope it keeps the shares.

Upon a reboot, the connected MyBook on the USB port for safepoints appears as per usual. When I get the MyCloud has been up and running initially, it sees the share for the mybook and recognizes the safepoint but after running for a while the USB drive disappears and the safepoint is no longer listed and the MyCloud becomes very sluggish.The MyCloud dashboard then is unresponsive, the light is blue on the mycloud and the light on the mybook is flashing on, off, on, off as though it is hung up.

I think since the update, it cannot manage the USB drive for some reason.

I suspect the firmware update did not actually update properly even though it said it was successful.