Not Accessible immediately following Firmware Update

Yesterday I tried to update on the Firmware. While it was updating, the dashboard said that the operation timed out.

I tried again to update the firmware but it kept coming back saying there was some kind of network error and to make sure that the network was fine.

All cables are properly plugged in and there is internet access. My computer is not on wifi, it is connected via ethernet.

There is always a blue light on the My Cloud.

I have restarted the My Cloud according to what is in the User Manual.

I have restarted my computer.

I can not access through the dashboard or through Quick View.

What types of suggestions would you have at this point?

Thank you very much for your time and help.

Have you tried downloading the new Firmware and then installing it?


Hi cat0w! Thank you very much for your reply.

Originally I tried downloading it via the dashboard but that didn’t work.

I just went to the link that you gave me and tried to download it from there. I have a WD My Cloud.

I am not exactly sure which Firmware I am currently using (whether it is 2.x or 04.x). I can not get to the Dashboard anymore for some reason. I used to get there via the Quick View, but that option is no longer available for some reason.

I downloaded both versions (the 2.x and 04.x) but both of them are odd file types that I was not able to open when I double clicked on them. (a .deb and a .bin file version).

Would you have additional suggestions for me? Thank you very much for your help.

You can find the firmware version on the Home page of the Dashboard under Firmware, or on the Dashboard > Settings > Firmware > Available Updates > Current Version.

You don’t “open” the deb or bin file, you extract the deb or bin file from the ZIP file then use the Dasbboard > Settings > Firmware > Manual Update > Firmware Image > Update from file, then select the extracted deb or bin file.

You cannot install the wrong version to the My Cloud, the upgrade process will fail indicating wrong firmware version.

Thank you, Bennor!

This information is incredibly helpful. The only problem right now is, as I briefly mentioned earlier, I can not access my dashboard. So, it appears that the My Cloud is offline, but there is quality internet connection throughout my entire house right now. The Blue light is also on.

So I am confused about how to even start accessing it at this point.

40 second reset?

Can you access the Shares on the My Cloud through Windows File Explorer or Mac Finder?

What error message does the browser display when you attempt to access the Dashboard?

Another option is to use the My Cloud’s IP address instead of the My Cloud name when accessing the Dashboard with a web browser.

If all else fails, try doing a 4 second reset via the back reset button. If that doesn’t work then try a 40 second restore via the back reset button.