My Cloud Drive 3TB - no blue light and cannot access shares

I noticed over last few weeks that I had no blue light but my drive was accessible on the network.

I upgraded my firmware to the latest version v04.04.01-112 and after this I could not access my drive. My blue light is still not lighting up. I called the support desk and they asked me to reboot the drive and it made no difference.

Has anyone installed this firmware and has it caused network access issues?

i tried using WD Sync and i could not add a folder to sync to one of the shares.

In my case I am not sure whether my drive has failed (as no blue light) or did the firmware did something to my functioning WD My cloud.

Are you able to access the device’s Dashboard? What happens if you hold the reset switch on the back?

Hi Trancer,

Yes i can access the device’s dashboard.

When I hold the reset switch on the back which I did with the support person, the yellow light flashes while it the device is booting up. After about 8 minutes of flashing yellow (beige orange) light stops flashing and blue light did not lit up.

I also could not share the link after i upgraded the firmware…too bad

On the Dashboard have you gone to Settings>General>Energy Saver and checked to see if LED is ON?


After about 8 minutes of flashing yellow (beige orange) light stops flashing and blue light did not lit up.

Flashing yellow suggests the blue LED has failed; I think the ‘white’ LED is actually implemented by enabling the yellow and blue LEDs together; I’m not sure if there’s a white LED in there as well (so that’s red, yellow and blue).

One of my devices had no blue LED, but otherwise works fine.

I suspect you may have the same LED failure (your blue LED had failed prior to the firmware upgrade, when the drive was accessible), and share access trouble is down to the firmware upgrade, and the LED failure is entirely incidental.

I checked my energy setting for LED lights, and it set to ON. After I turned it off, the LED light did not turn on. IT

Do you know how long does it take for the light to come on after you turn the energy setting off?

Thanks for pointing out this setting as I was not aware of it.

Hello cpt_paranoia,

Thanks for informing me about the LED lights. So what you are saying that if blue LED light fails which in my case has been for a while, my Cloud drive should still work fine. This means the issue I am having with connecting to the drive can be attributed to the firmware upgrade.

It can be set off or on. Perhaps yours is off. In the Dashboard, go to Settings/General and turn the LED on.


My LED energy setting was set to ON. I turned it to OFF and the lights are still off

On the disk in /sys/class/leds/system_led directory are text files that tell you what color the led
is currently set to. If blink contains “on” then the led is blinking. If color contains “blue” then the led is blue.
This would be an easy to tell if your blue led is bad. The file would say that the led is blue but the led is not blue.


After turning off the LED setting turn it back on and if the light is working it should come back on in a couple of seconds.

Which disk are you referring to? I use Macbook Pro. Is it on the Mac book?

I have to say that although my WDMyCloud’s LED is BLUE, you have to get right down and close to the box to see that it is actually lit - it is VERY weak. Have you checked real close?

Yes I have and it is completely off. No light whatsoever.

Did you check the files I mentioned above. The color file will tell you what color the led should be.


On which disk are asking me to look for this file? is it on the MacBook drive?

Its on the My Cloud. You need to SSH into the device. Then cd to /sys/class/leds/system_led
Then cat color or any other filename in that directory. The file name pretty much tells you what
it describes.


Hi. I can’t get a blue light on my MyBook. And I can’t see the unit on the network. Looks like I might have to try a reset. Will that lose the data?

This is the MyCloud forum. If you have a MyBook Live, ask on the MyBookLive forum: