New Release Firmware Release 04.04.02-105 (1/27/2016)

What OS are you running on your PC?

Paul

Here is what I have PC running Windows 7 on a gig Ethernet with many Raspberry Pi’s for watching TV
WD MYCloud 4tb v04.04.02-105 with a MYbook 4tb 1230 hooked up to the USB of MYCloud everything has been running smooth until I updated to the latest firmware on mycloud :frowning: When the firmware finished and after the reboot the USB drive got re-assigned to a new location so I remapped it to a drive letter “W”. That was a pain ! had to go around an update all my systems… Well as of today ! I can no longer see the USB drive on my PC or any machines. Come to find out Mycloud corrupted the drive. When I plugged it in to the P.C. with USB cable it needed scanned and repair, so I did.
Plugged it back into Mycloud used the UI it shows the USB drive installed but still not showing up on my PC

  1. did a reboot of the cloud
  2. 40 second reset
    And it still shows up on the MYCloud UI but not on my PC…HELP !! The drive is fine when I plug it directly to my PC. Both Drives are less then a year old …Hoping someone has the solution

I copy pasted this from my thread. Since basically I have the same problem ! What is the solution Ive tried the renaming and that didn’t work. Has anyone tried to roll back the Firmware successfully ? And if so which version ?

AND WHY DOESNT WD stop this new firmware !

Not sure why you would say that. After the initial issues with old safe points, I’ve had no issues.

Well just tried to manually to go back to older firmware sq-040401-112-20151013.deb and I get a Error •Device does not have enough space for upgrade. !

Its a 4tb drive with 148 gig left on it ! Now what do I do…

The amount of free space (148GB) in your case for your data files generally has nothing to do with the space the My Cloud OS needs to perform a firmware upgrade (or downgrade). To properly downgrade there are several ways to do so. See the following thread for one such method. See the thread following that one for links to prior/current firmware to ensure your using the appropriate firmware for your My Cloud.

https://community.wd.com/t/easy-method-to-downgrade-to-previous-version-of-the-firmware/93489

https://community.wd.com/t/wd-my-cloud-v4-x-and-v2-x-firmware-versions-download-links/148533

Well I followed the instructions how to roll back and Mycloud is now rolled back UI can see the USB drive all the settings are correct and my PC can not see the drive !

Interesting analysis with drive performance. I used Crystal Disk Mark to benchmark my My Cloud Mirror Gen 2. Here are my stats after 24 hours of uptime. I’d be curious to see your numbers. I put my defective My Cloud 4TB for reference.

Windows 7 Ultimate x64

My Cloud Mirror 8TB Gen 2
2.11.133
Device Uptime 0 day 23 hours 17 minutes

My Cloud 4TB

Snakedoctorunit, interesting numbers. However it should be noted that the My Cloud Mirror Gen 2 does not use v04.04.02-105 firmware (the topic of this thread), it uses v2.x firmware (2.11.133). And the hardware may be different than the hardware on the v4.x single bay My Cloud units which are loaded with the v04.04.02-105 firmware.

You may want to post that information, if you haven’t done so already, to the dedicated My Cloud Mirror subforum so others there can comment.

https://community.wd.com/c/personal-cloud-storage/wd-my-cloud-mirror

True @Bennor - I wanted to see if using the disk benchmark utility if performance stats can be reported by multiple owners to see if a trend presents itself. I did include the benchmark for the 4.x version from the defect My Cloud 4TB single bay.

What trend are you looking? Because the hardware is probably different between the Mirror and first gen My Clouds the performance stats will in all likelihood be an apples to oranges comparison. At best people can compare your faulty 4T My Cloud to theirs to have an apples to apples comparison.

if we correlate by model and generation when capturing the statistics, then we can present the data back to WD for analysis. Yes, the base hardware between Gen 1 and 2 is different and the underlying OS changed too. What hasn’t changed that much is the auxiliary daemons. Orion, apache httpd, twonky, RESTful API are prime examples.

What are you hoping WD would/will do with those statistics and analysis?

if people are experiencing performance issues after a certain threshold (e.g. uptime), the benchmarks in aggregate can help with the analysis or prove there is a problem. Yes, we would have to look at apples to apples, then oranges to oranges.

See my updated post.

What was wrong with your defective My Cloud 4TB?

I have similar performance issues after the update to v04.04.02-105, I did’n measure the performance before the update, but now it’s bad, backup of big directory with jpegs ran with the speed of about 14,7 MB/s, nice 2 photos/s :cry:.

My Cloud 2 TB, v04.04.02-105 performance

After the update it started the Content Scan, with the Error result after one day, I restarted the My Cloud, from the restart is the Content Scan in Idle state and on the Dashboard are in Capacity all zeros in Videos, Photos and Music Tracks fields. Status says "Scan complete. {0} photos processed.

@ZdenekH Can you re-run then select the mapped drive to your My Cloud. I see you have your C: drive selected. Thanks@

@chaoscreater - a few issues. USB backup and WD Sync were the trouble tickets. They could not resolve why WD Sync failed continually. Interesting your write performance was similar to mine before I shipped it back.

Sorry, I didn’t notice, what appeared in the screenshot. It was measured on the mapped drive, but I changed the language to English for the screenshot and in the same moment CrystalDiskMark changed the reported drive letter from W: to C:, the measured results are that for MyCloud on W:.