Update 2.31.149

After updating the firmware to on my EX2100 none of my PC can access the cloud with the desktop app (Version anymore.
I understand that this app is quite old and not supported anymore but it was working fine until the update! I even tried to downgrade the firmware manually but was not not successfull (Upload failed)!
Still can access the cloud via local network of course but what should I do from outside my network?
Is there any way to still run the app?
Is there any alternative to this app (I don’t like the web interface on the mycloud webpage)?
Somebody an idea why my downgrade isn’t working?

Thank you so much in advance for any answers or suggestions you can give me!

Hi thc_buckow,

It is not possible to downgrade the firmware of My Cloud device as per WD and they will not recommend to do this anyhow but here in the forum there are several threads discussing how to roll back to a previous firmware version. You can go through these threads:

It could be a remote access problem,. So, turn off NAS and router/modem. Now, turn router/nodem back on and wait untill fully booted. Now, turn on NAS and once fully booted try things again. You have now fixed cloud access so it should work fine.

i have the same issue, contacted wd and they just told me the desktop app isnt supported and hasnt been since 2016 which is bs because it worked fine up until update 2.31.149. told me it wasnt possible to roll the firmware drivers back and that you need to access the drive using the mycloud web portal

pretty stupid they stopped updating the desktop app tbh as im sure alot of people prefered it