My Cloud App Not Working After Firmware Update

Updated firmware to 2.31.149 today and then the desktop app MyCloud%20Login asked me to sign in, It called for the network login with email and then listed me EX4100 I tried to login and the dialog box will not allow me to enter my user name, when I click on it the box turns blue and doesn’t allow me to enter the user name, It does allow for the password which does not work on it’s own. I uninstalled My Cloud and reinstalled it to no avail

My Cloud Desktop App Login!
MyCloud%20Login|592x443

Are you using an EX4100? If so perhaps see the dedicated subforum for the EX Series where people more knowledgeable with that device may be able to assist and where there may be additional posts similar to your issue.

https://community.wd.com/c/network-attached-storage/my-cloud-expert-series

Because your having specific trouble with a WD app you may also want to see the dedicated subforum for WD Apps.

https://community.wd.com/c/wd-software-mobile-apps/wd-my-cloud-3rd-party-mobile-apps

The old My Cloud Desktop App for Windows and macOS was:

  • End of Life with the last release on 2/23/2016
  • Is not supported on Windows 10
  • Is not supported on anything higher than macOS 10.10
  • is not guaranteed to work with any My Cloud firmware released after 2/23/2016

This product is EOL

Great so with 4 4GB Red Drives and an EX4100 you tell me that I can no longer use the app that was working on and originally installed on Win 10. There has to be a work around even if you don’t support it. Why does it try to connect and then will not let me put in my user or admin name however lets me enter the password, of course it won’t go without the user name, I looked forward to the firmware update now I’m real sorry I installed it. Any help would be appreciated.

1 Like

You can use the My Cloud Desktop program even though it is end of life (EOL). I still use it on several Windows 10 PC’s to access a remote single bay/single drive first generation v4.x My Cloud. WD just won’t support it anymore and is pushing people to use the MyCloud.com web portal instead.

Here is a screenshot of the Desktop program accessing a remote My Cloud, I put the About screen up to show the version of the My Cloud Desktop program I am using.

If the recent update to the second generation v2.x My Clouds are now affected and cannot be accessed using the WD My Cloud Desktop program than that is something WD should have made users aware of before they installed/updated the firmware.

2 Likes

Having exactly the same problem here. Cannot access the My Could via desktop application, though i can via mobile application or web site. It can detect the device, under my account or in the same network but “not authorizing the login”.

I am downloading the previous firmware and try to install it.

Firmware downgrade ( My_Cloud_GLCR_2.30.196.bin ) solved this problem. But the WD My Cloud application has not any important funcionality (for me ) … maybe setting password ?

Hi could you tell me where can i find that firmware to downgrade my mycloud i need to use the desktop but i cant i updated the firmware.