Firmware 4.00.00-607 needs to be updated ASAP

Since this firmware was updated everything went wrong on my 3TB WD Mycloud

Endless scanning (days)

Bad performance

Lot of files (maps) are missing in DLNA environment (media streaming)

I performed diagnostic tests , reboots etc

No errors were detected, but the problems remains

Please reissue a new firmware or reset the firmware to the previous one


1 Like

I found this in the forum for you SectorGZ explains firmware downgrade awhile back.

You can downgrade your firmware, but you need to download the firmware you want to go back to from here:

After unzipping the file to get to your *.DEB version you have to rename that version. So lets say you are on and you want to go back to, do the following.

  1. Download

  2. Unpack the zip file to the *.DEB file.

  3. Rename the *.DEB file to a version number that is highr than the version you are on. Example: rename to to replace

  4. Go to your Dashboard and do a manual firmware update. This will restore the older firmware.

BEWARE : that any scripts/functions that have been changed with the firmware you are on and are not addressed with the older firmware are still the current version’s script. I would do this as a last resort in trying to find a fix elsewhere on the forum.

I posted 2 problems , and since one is solved I don’t need to restore my firmware

tags : twonky server

I realised that the dashboard is not the tool that should be used but why is WD distributing this ?

Anyway thx for your reply :smiley: 

After a few days other problems occured with this new firmware 4.00.00-607

It took me hours to find out which were the datasets causing the problem (pdf’ and wpl’ files are certainly causing problems  during the  scanning process) but at last i decided to downgrade the firmware to v03.04.01-230

All problems were solved 

Thx to