My Cloud becomes inaccessible when a USB drive is connected

I have a large amount of files to transfer to the MyCloud device so I connected a USB drive to it. After that I tried to access the MyCloud device using my browser. This was impossible. The page loaded never finished loading. Chrome dev tools reported that some connections to the device were being refused.

The desktop application could still connect though, so I used it to copy a folder from the USB drive to a folder on the MyCloud drive. The folder I was trying to copy has > 10GB of data and 1000s of files. At first the copy seemed to be working, but then the desktop application reported an error that the copy failed. Some files were copied though. I could see that the target folder was created and that it had files in it. And from that point on the desktop application showed a spinner icon on that newly created folder. I’m not sure what it means though.

I decided to come back later in case it was still copying files. So I let my laptop go to sleep. Hours later when I woke it up I was no longer able to connect to the MyCloud device using the desktop application. It reported “no device found” when I scanned the network. And the web access completely stopped working. All connection attempts resulted in “connection refused”.

Note that my MyCloud device has a static IP, so the issue is not the IP address changing. And it was on the network still. The device was still listed as active on my router’s status page.

Giving up, I unplugged the USB drive from the MyCloud device. To my surprise I was immediately able to connect to the MyCloud device again over the network, both with a web browser and with the desktop application.

It seems like others are having similar issues. I wanted to post this as a reply on the thread about the USB drive with time machine causing problems, but the reply button on that thread is disabled.

From the web dashboard:

Firmware version: v04.01.02-417

Diagnostics: OK


I still can’t connect to any network shares on the device using windows explorer.

And I just remembered… Before plugging the USB drive into the MyCloud I wasn’t able to connect to the device at all. I had to power cycle it to restore access. It had been several weeks since I accessed it. My power went off briefly about a week ago, so the device restarted since I last accessed it, but as I already mentioned the IP address stayed the same.

These connection issues concern me a lot. MyCloud runs linux. A properly configured linux-based NAS setup shouldn’t have connection issues. Either something is improperly configured or there are hardware issues. Hopefully it’s the former and the next firmware release will fix it.

Update #2

Restarting the device fixed the windows explorer access. Now I’m just copying all the files over the network with the usb drive plugged into my computer. I’ll let it run overnight.

Hi tiiiiiiiiiiim, welcome to the WD Community. Good to know the problem was solved. 

Just to be clear, the problem (summarized in the title of this post) is *not* solved. I cannot plug in my usb drive without the MyCloud device becoming inaccessible.

Hi again, I miss read the post update. Have you tried using another USB hard drive to verify if the problem continues?

I could try that, but if another drive works then we would still have a case of a functioning usb drive causing the mycloud to become inaccessible (my usb drive definitely works… I use it regularly to xfer files between 3 different systems).

I suspect that the issue might be the media scan. I have about 1tb of images and videos on my usb drive. The whole time it was plugged into the mycloud the activity light was on.

I have the same issue. With a 2 TB external drive plugged in, the My Cloud becomes inaccessible and the activity light on the external drive is on constantly.

During reboot, there is a brief period where I can access the MyCloud, then the activity light on the drive kicks in and bam, inaccessible again.

While the drive is inacessible, it does still repond to ping, e.g.,:


(your IP is likely different) - but not to ssh or any other type of access. Does your drive still respond to ping?

is there possiably a timemachine backup on thei USB disk? See the sticky that has recently been posted here

While the drive is inacessible, it does still repond to ping


is there possiably a timemachine backup on the USB disk? See the sticky that has recently been posted here

I saw the sticky about the time machine backups causing problems. Doesn’t apply to me.


I have made several posts about problems with USB drives that I have encountered with every V4 firmware.and there seem to be a lot of posts from other users experiencing USB issues

I always end up downgrading?  to V3 firmware which does everything I expect it to (how can this be classed as a downgrade) (even WD Support Staff have told me to keep using V3 until there is a solution)

Tel911 - thanks for the info! Any idea when a fix will be released?

jubei04 - did you know that support staff are advising users to downgrade the firmware to v3? As a forum moderator this would be a good thing for you to point out to the next person who has a similar problem.

Wd support staff are NOT advising users to downgrade firmware only telling me that I should continue to use V3 firmware if it works for me until a fix is available
Downgrading is not supported by WD

Tel911 wrote:

Downgrading is not supported by WD

But still possible: Just reupload rootfs partition and kernel. (md0 and part 5 of hdd)

Search in forum “Howto unbrick device” or new tftp method (w/o opening device).

So if downgrading is not supported and you’re running v4 then basically the product doesn’t work as advertised. Not good.

Is there anyone who represents WD on this forum? I’d like to hear what’s being done to address this and the timeframe for resolution.


I’ve the same problem; when i connecy my usb disk 3.0 (that is another WD product, it’s a mybook live) to a WD Cloud, all the shares become unaccesible, even the console of a WDCloud not responding.

This is the second WD Cloud i’m trying… the first was returned as in warranty… 

It’s not possible to work in this way!

To work again well, i’ve to disconnect my USB 3.0 from the WDCloud and restart the WDCLoud.

The WD Live work well attached to a PC.

The firmware is the lastest release.

Is there anyone that have solved this kind of problem?



Do you mean a WD MyBook USB drive? The WD MyBook Live does not have a USB connection.
Assuming you are plugging in a MyBook, if the drive contains a lot of data, the MyCloud will begin to scan and index all this data and will become unresponsive. If th drive is empty there should not be a problem although the most recent firmware updates seem to cause problems with connected USB drives. You could downgrade the firmware to v3.0, which will probably solve this issue.

Yes, sorry, i mean the code WDBFJK0030HBK (MyBook 3TB).

Can i disable the scan of the USB MyBook? I’ve to put in this share a backup of a MyCloud, every night… but it’s not possible to work in this way because the MyCloud stop working.

I think i can not downgrade a firmware!!!

You can kill the media scanning by running some commands by SSH into the MyCloud. Check the following post:

I fully understand your reluctance to downgrade the firmware. However, if you take some time to browse through the various posts in this forum you will see evidence that the most recent firmware updates from WD have caused more problems than they have solved. So, many of us have found that a simple solution is to downgrade. You can study the method here:

Unfortunately the only way to get a functioning device seems to involved hacking into the device in one way or another.

If you prefer not to do that I can only suggest you contact WD support directly. Good luck!