WDmycloud not working after installing new firmware v04-01.02-417

last 2 weeks I took update for the firmware , and all problems started.

i called support but they were not able to help, at least they offered to send another Drive, but I care more about my data than having new Drive ( I mean used one , I hate when i get used one because you don’t know how much remaining of the hard drive life ) after restarting it many times and did the 40 second trick , now I can log to the dashboard , but the only thing i see that the latest Firmware is ok . i can not change any setting and the hard drive capacity doesn’t show.

the network i have access to them and I can see my data. the Problem is with the dashboard.

and every while I lose the connection to the network drive  so i have to unplug and plug again the power for the wdmydrive.

before the latest update my drive was working excellent never a problem.

support said might be a corruption  of the installation , but I don’t think so since the firmware shows ok.

any way to re install the old firmwere?


many times shows this also , but never finished scanning , and soon i will lose connection.

and I get this after

the error


Here is the link to downgrade your firmware: Easy method to downgrade to previous version of the firmware


thanks for reply ,

i tried this method last week , and since the dashboard never gave me the exact size of the drive , I got this error message.


but also I found this in russian language and after translation

# Качаем и распаковываем архив с 230-й прошивкой в публичную директорию на WD (Public)

# Исправляем в скрипте обновления запрет на даунгрейд:
nano /usr/local/sbin/updateFirmwareFromFile.sh

# комментируем строки 256-259 (Добавляем в начале #, либо стираем вообще)
if [-z “{update_container}"] && ["{vnew}” -lt “${vnow}”]; then
error=“failed 200 “invalid firmware package””
pre-update_error $error

# ctrl+x, y, enter (Закрыть, согласиться на замену, подтверить)

# Запускаем скрипт апгрейда, указав путь до прошивки
/usr/local/sbin/updateFirmwareFromFile.sh /DataVolume/shares/Public/sq-030401-230-20140415.deb

# Процесс занимает около 5 минут. Сидим и смотрим на лампочку девайса :slight_smile:

and the english :

# Download and unpack the archive with the 230th firmware in a public directory on WD (Public)

# Fix the script updates the ban on downgrade :
nano /usr/local/sbin/updateFirmwareFromFile.sh

# Comment lines 256-259 (add # at the beginning , or erase all)
if [-z "$ {update_container}"] && ["$ {vnew}" -lt "$ {vnow}"]; then
error = "failed 200 \" invalid firmware package \ ""
pre-update_error $ error

# Ctrl + x, y, enter ( Close , along with the replacement , Confirm )

# Run the upgrade script , specifying the path to the firmware
/usr/local/sbin/updateFirmwareFromFile.sh /DataVolume/shares/Public/sq-030401-230-20140415.deb

# The process takes about 5 minutes. Sit and look at the light bulb devaysa :)

i think I will try it too.

Just a FYI … Did you do a “System Only Restore” after you downgraded your firmware to see if the Dashboard will display all the correct information?


after I changed Ver name to 408 , I tried to install the older version but it gaves me error , no space as you can see from the pictures up. the problem is the scanning is taking time and the drive does not know how much space he has.

the scan all passed with green check but still report error.

IIRC, Those are two different things.

The TOP section is the WD My Cloud server.

The BOTTOM section is the Twonky DLNA scan.

I had this problem and tried multiple re-boots and system resets but had no success. This is a pain as I also could not downgrade the firmware because i was getting the “not enough space” error message. I finally solved the capacity issue in the dashboard by turning off the DNLA and itunes media servers and then rebuilding the content database. Two minutes and it was fixed!

See under: General - Cloud Access - Configure - Content Database - Rebuild

Once you have downgraded the firmware, I recommend you perform a full factory restore. This will wipe all your data, so you need to back it up onto another device. Also, it would be nice to keep the DNLA and iTunes media servers turned off.

Lastly, see this post:

1 Like

in almost all cases the system only restore will have the same effect as a quick factory restore except the shares and data would be left in place. unless you don’t want the data always start with the system only

the only time i would ever recommend a full factory restore is if you are getting rid of the mycloud as it is very slow do to writing multiple patternes over the entire drive to prevent data recovery

Hi dubie

thanks your post helped me a lot. since 2 weeks and I am having problem , and support wants me to replace the wdmydrive.

after I turned off the DNLA media server , I saw big Improvement of the dashboard behavior was faster.

but for the link you gave “See under: General - Cloud Access - Configure - Content Database - Rebuild” I was not able to see that maybe we have different model.

also I followed the link down

and I did what Chyre sujested :

chmod 644 /etc/init.d/wdmcserverd

chmod 644 /etc/init.d/wdphotodbmergerd

find . -name .nflc_data -exec rm -rf {} ;

find . -name .wdmc -exec rm -rf {} ;

find . -name .twonky -exec rm -rf {} ;

and it gave more improvement for the data size on each share , and now on the mounting drive I can see how much free space there.

I am still waiting to see the full size of the harddrive in the main dashbboard ( capacity ) for now it is showing just small dash.

Hi Streamview,

Under the General -> Settings page of the dashboard do you see something like the screenshot below?

(I am using V3 firmware.) Once I clicked on the “rebuild” option it solved the capcity issue on my device.

Hi dubie ,

thanks , i didnt see this before.

so I did it , but it gave me error.

The error messages you’re getting look very much like the ones I noted here:


Strangely, this seemed to be fixed by closing the browser tab for the Dashboard, and opening another tab and re-connecting to the Dashboard.  I have no idea what made me try that; annoyance at the series of repeated error messages, probably, trying to shut the thing up in exasperation…

I know it’s a long shot, but it’s so simple, it might be worth trying…

Oops… It looks like you’ve got over those errors; I should read the whole thread before replying…