SSH in the latest firmware?

I have tried to update my fimware to the lastest but not greaest FW.  But when I update from a file or from a browser it gets stuck at 100% for hours.  

  can I place the actual FW update file somewhere in the filesystem?  

Wasn’t there a popup message telling you to close the dashboard tab? Because packages needed for displaying dashboard are also reinstalled, you have to reopen the dashboard to check whether FW update was successfully done - meaning even if FW update was success, the progress bar would still be stuck at 100% until you refresh the page.

If dashboard still shows old version of FW, then you can update bia SSH through:

cd /shares/Public



rm -f

/usr/local/sbin/ /shares/Public/sq-040001-623-20140904.deb

I tried everything but after I see 100% and reboot im still on WDMyCloud v03.04.01-230 : Core F/W . im not sure what else to do besides a full restore. I have been having disconnect issues all the sudden and I cant connect remotely all the time or at the moment any of the time

when I enter these commands in the terminal they all work but the last command , I get file not found.  

/usr/local/sbin/ /shares/Public/sq-040001-623-20140904.deb

***edited because it was a wrong answer but I can’t erase it, so I’ll just change the content for tips:

“rm -f” is not really a necessary command, what we did here is

  1. move to /shares/Public
  2. download firmware file there in zipped form
  3. unzip the file
  4. erase the zip file downloaded
  5. install the firmware from .deb file unzipped at 3.

It’s fine if the zip file isn’t erased…

when  I manually drag and drop the update into the folder /shares/public and run the command

/usr/local/sbin/ /shares/Public/sq-040001-623-20140904.deb

I get this error 

/shares/Public$ /usr/local/sbin/ /shares/Public/sq-040001-623-20140904.deb 14:20:37:: ( /shares/Public/sq-040001-623-20140904.deb ) 14:20:37:upgrade start: /shares/Public/sq-040001-623-20140904.deb 14:20:37:check_size= 14:20:38:version_current=030401230 14:20:38:version_newfile=040001623 14:20:38:package_newfile=sq 14:20:38:master_package_name=sq 14:20:38:master_package_new=sq 14:20:38:update_container=
/usr/local/sbin/ line 219: syntax error near unexpected token fi' /usr/local/sbin/ line 219: fi’

Oh wait, I was the one who gave you the wrong command lines;;;

change the first command to

cd /shares/Public

 sorry for misguiding.

I’ll edit the first response so anyone else to view this thread won’t do the same…

no problem I willl try that thanks so much

when I log in the web interface it says downloading 0%  should it not say installing?  should I just let it do its thing.  If in fact its doing anything at all. lol 

Uh…After update command Putty will show a stream of texts, which ends with something like “rebooting to apply update” and something about itunes. During the process WDMC LED will turn from blue to blinkering white and back to blue - that rebooting message and blue light shows that FW update has finished.

After that itunes somethings, putty will stop and soon disconnect - that is normal.

I used winSCP I just logged in with putty and Im not sure what to look for. Is there a cmd that shows status

If firmware was updated successfully, there should be no problem accessing dashboard page, and you can check firmware there…If it doesn’t open(which I doubt since you could access it before the update as well), you’ll have to run the update command again and wait for those two signs I mentioned earlier.

1 Like

I think I found out why I could not upgade

using this guide…

i was stuck on the 03.04.01-219 since I updated the “version” file with winSCP.   I could not update to 4.00.01-62​3 at all.  I even tried to SSH my was in and manually do the update as per the help in this post .  I just get stuck at 100% updating for hours.   

 I renamed the version in the “version” file in the /ect folder to 4.00.01-623  from 03.04.01-219 it was at before I tried to update.   Finally a restart did the trick after I replaced the version to 4.00.01-623

this method is not working for me again.  Why is this thing so hard to update?  

what else can I do?  im backing up now and plan to do a FULL restore.  But I wish I did not have too.  I have 2.4 TB of data to backup… 

maybe ill try putty instred of winSCP  


It says in winSCP

in the /etc path

version-filename = sq-030401-230-20140415.deb

in the windows UI it says version v4.00.01-623

is why I cant update to sq-040103-421-20150217.deb ?  

after the last command nothing happens in putty and in the dashboard shows downloading 0%

is there a way to see if something is happening in putty? i can see the file downloads unzips and is int the public folder. I did see an error the first time I did it but could not copy the test in putty. So deleted all the .deb files and started all over. But the second time I just get the dashboard to say 0% downloading and putty says

3.2.26 #1 SMP Fri Dec 27 13:50:41 PST 2013 armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sun Mar 8 10:45:18 2015 from dell7000
PetoelloCloud:~# cd /shares/Public
PetoelloCloud:/shares/Public# wget

–2015-03-08 10:50:03--

20140904.deb. zip
Resolving (…,
Connecting to (||:80…

connected .
HTTP request sent, awaiting response… 200 OK
Length: 138641809 (132M) [application/zip]
Saving to: `’

100%[======================================>] 138,641,809 5.80M/s in 23s

2015-03-08 10:50:26 (5.77 MB/s) - `’ saved

[138641 809/138641809]

PetoelloCloud:/shares/Public# unzip
inflating: sq-040001-623-20140904.deb
PetoelloCloud:/shares/Public# rm -f
PetoelloCloud:/shares/Public# /usr/local/sbin/

/shares/ Public/sq-040001-623-20140904.deb 14:51:22:: ( /shares/Public/sq-040001-

623-201 40904.deb ) 14:51:22:upgrade start:

/shares/Public/sq-040 001-623-20140904.deb

here is my error

PetoelloCloud:/shares/Public# unzip
inflating: sq-040001-623-20140904.deb
PetoelloCloud:/shares/Public# /usr/local/sbin/ /shares/ Public/sq-040001-623-20140904.deb 18:03:25:: ( /shares/Public/sq-040001-623-201 40904.deb ) 18:03:25:upgrade start: /shares/Public/sq-040 001-623-20140904.deb 18:03:25:check_size= 18:03:25:version_current= 18:03:25:version_newfile=040001623 18:03:25:package_newfile=sq 18:03:25:master_package_name=sq 18:03:25:master_package_new=sq 18:03:25:update_container=
/usr/local/sbin/ line 219: syntax error near unexpecte d token fi' /usr/local/sbin/ line 219: fi’