Important - MyCloud.com changes


#1

Dear My Cloud Users,

We have made extensive changes to the MyCloud.com website following the launch of our My Cloud Home device. If you are an original My Cloud user please use http://files.mycloud.com to login to your original My Cloud device.

Original My Cloud Products

My Cloud Home Products

If you have any issues with our My Cloud products and need help, please contact support: https://support.wdc.com

My Cloud Team


My cloud not accesible through web
9 digit device code
Connection Setup
Problems with files.mycloud.com
Can Connect With My Cloud at Home via Laptop; Can't Connect Remotely
MYCloud Drive offline 971
, my power led is solid red My Cloud Personal Cloud Storage
Gerätecode zum Schnelleinstieg
Cant Sign in using Safari
pinned #2

#3

Why?

Why have you made changes that only confuse users? Look at the “I can’t connect to MyCloud.com” threads that are already appearing. It’s inevitable if you use the same product name, but have different access methods for different products.

Your customers don’t work for your product dev or marketing departments. They don’t see any difference between a MyCloud Gen1, Gen2 or Home. To your users, it’s just a MyCloud, and they expect it to work in the same way.

It was bad enough with the confusion over gen1/gen2. Another product, and different portal are only going to add to the confusion. I don’t look forward to answering the same confused questions again and again.


#4

Hi @cpt_paranoia,

The new My Cloud Home product is using a different back end than the older My Cloud products so a different portal is needed to log into the device. We are currently looking into a possible solutions that would allow the same log in portal can be used for both My Cloud Home and My Cloud devices. In the short term we have created knowledge base articles and have posted a notice here in the community. I do understand this is a band-aide but we are working on a better solution.

We would like to thank you and others for the feedback on this issue. We have passed the feedback to our product and marketing teams.

Forum Admin
Lance_C


#5















#7

So I spent 4hr with WD on my issues and they declared my 12 TB drive as having an issue… so when I tried to login to it again, I get the same device not available message… when I login to it using the new web address… it works perfectly.

So is my device defective ? Should I reload everything just in case ? I am sooooooooooooo angry with the 4 hours of my life gone… listening to techs trying to blame my internet service provider.


#8

if you can log in using the link in this post it seems like you have the older My Cloud not the My Cloud Home. I am not sure how wd support didn’t find this issue. If you can log in the device may not be defective. I would reload everything and test it out. If you don’t see any issues the device is likely fine.


#9

I echo cpt_paranoia’s comments to the fullest extent. What are you guys thinking. Did anyone consider the impact on the users (that is US! the people that buy your products, pay your wages and impact your stock?)

We’ve come to depend and share data between our users on “mycloud” and now you took that away.

I’m taking my “My Cloud Home” back to Best Buy in the morning. You guys can keep your changes. New “back end” or not, someone the, “Product Manager” should be fired for this stupidity.

Good bye!


#10

I agree with cpt_paranoia and zkost. The worst strategy I´ve seen in the recent years. The online platform was far away from it´s competitors, as Synology for example and, after the bad decisions of split the portal on Mycloud Home and Mycloud, I see the difference even worst. I´m using Mycloud since 2 years ago. It needed a deep update but not in this way for sure. I even recomend the product to some friends who bought it, and now I even feel upset for this.

I can not take my Mycloud back to the store, but I would like.

Regards.


#11

Lance, I am a VERY angry new customer for MyCloud Home. My device’s serial number is EXTREMELY small, I could only read it AFTER I bought a jeweler’s loupe. Do you know how RUDE it is for your company to make such text so small, and then obstruct access to your services due to a customer’s inability to READ the device’s serial number.
To add injury to more injury, when I finally managed to read the serial number, the WD side wouldn’t accept it as a valid serial number.
I have always said that it’s a very bad sign when a company’s representatives rely on the fact that its customers are too far away to get their hands around your necks.


#12

buenas. no puedo registrarme como usuario my cloud. el unico registro que veo es para my cloud home


#13

I can not register as a user my cloud. the only record I see is my cloud home


#14

If you have a My Cloud device you can set up using the following methods

Using mycloud.com/setup
https://support.wdc.com/knowledgebase/answer.aspx?h=p1&ID=19864&lang=en&p=904

Using the Dashboard


#15

Does this mean my device should no longer be using devicexxxxxxx. wd2go .com and devicexxxxxxx. local-wd2go .com URLS? Or this means only that the browser based public cloud homepage has changed and it’s normal/okay for our device to use wd2go.com

We have lost cloud access using the Windows desktop software. Visiting by internal IP https://192.168.x.x in Firefox showing cert belongs to those 2 wd2go style URLs. If it’s outdated how do we refresh to get a new URL?


#16

This has to be one of the biggest loads of rubbish on the market, can you believe there is no ‘forot username’ link? I wish I had never bought it - until WD get their act together - online chat would be one obvious way - DO NOT BUY!!!


#17

Well, that goes nowhere. I get the “no results found” alert. Thanks


#18

Thanks for letting us know. We’ll look into what’s wrong with the article and hopefully have it fixed tomorrow. Sorry for the inconvenience!


#19

He-he… I use custom firmware (Ubuntu) on my device and dont have any problems :stuck_out_tongue:
(SyncThing + FTP + Samba + GoogleDrive + WebAccess and many other things. All works as expected)


#20

Hi @jshaw42

Thanks again for reporting this. It looks like the link @WD_Admin posted was malformed. I modified his post above and fixed it so it went to the correct article. I’m also posting it below:


#21

Hey Scott,
Yes, you are great thanks for all the follow up.