Permanent Blue flashing LED0-HELP

hi all…need some advice please, my cloud 4tb home drive, was working ok, but suddenly i could not connect to it via any means and the front LED is continuously flashing blue, even if i leave it for a few days!. i have tried a 4 sec reset and the 40 sec reset, but still the same issue. i have emailed WD support a few days ago but no reply yet. So was hoping someone on here maybe able to help with any ideas how to recover/fix it…thanks

Hi @Dloveridge99 - Can you verify you have a My Cloud Home and not a My Cloud? The My Cloud Home was just announced a few days ago and does not have a blue LED at all:

If you can provide your model number (P/N on the drive’s label) I can tell you for sure.

hi @Great_Scottt it has p/n WDBCTL004OHWT-10 appologies for confusing use of product names…dave

Yeah, that’s the older My Cloud product line. I’m going to move your post to the correct board, but here is an article explaining what a flashing blue LED on your model drive means:

https://support.wdc.com/knowledgebase/answer.aspx?ID=15036

thanks, but i already read that and it has not helped…so appreciate moving it to right ‘board’…

How long have you been waiting for the LED to change? I’ve read that the file system check can take quite awhile to complete.

hi, yeah i read the same, so left it for 2 days, and still sits there with fast flashing blue led

i have the same problem with prod no WDBCTL0030HWT-10
i have also rebooted the system
how do i solve it?