Mycloud serial number not recognized on support site

Just bought the updated Mycloud Home 2TB with the new look. Setup paper in book says to go to Mycloud.com/hello, this redirects to the main website. I tried using /setup instead but it can’t find My Cloud. My Cloud is recognized by my router and gives an IP address but typing that address into a browser doesn’t connect me to the dashboard or anything. I tried to set up a call with support but the pre-form keeps kicking me out as it doesn’t recognize my serial number. Any ideas?

You can use the My Cloud Dashboard to setup and configure your My Cloud Device.

https://support.wdc.com/knowledgebase/answer.aspx?ID=13965

You should also read the My Cloud User Manual if you haven’t already which will further assist in setting up the My Cloud using the My Cloud Dashboard. The user manual can be viewed/downloaded from the following link:

https://support.wdc.com/product.aspx?ID=904

You should go back to WD Community and post this in the new forum for the My Cloud Home and hope that someone can help you. You may want to contact Lance_C by message and ask your question.

https://community.wd.com/t/my-cloud-home-support-information-page/214799/2

Hi jlunt14,

www.mycloud.com/hello should go to the page below. Is this the page you are seeing?

If you are on www.mycloud.com the page will look like the one below. You will need to create a new mycloud account for the new product. You will not be able to sign in with any existing My Cloud account you may have. www.mycloud.com/setup will not work for the My Cloud Home product and there is not dashboard set up for the My Cloud Home product.

I got it worked out. I got the new mycloud before the site went live for it. Got it set up this morning when the site went live. Thanks.

1 Like

Please EXPLAIN what you just said. You understand what you wrote; the problem is that others may not understand what you said.
I just purchased a MyCloud Home product (POS!!!) I try to set up a phone call for it, enter its serial number, and it claims that the serial number isn’t recognized. How the hell do they do that? VERY rude to actually obstruct a genuine customer on the basis of a mistake that WD itself has made.
I am still trying to set up the backup location for my MyCloud Home product. It seems to back up my photos, but when I went into the Start>setup>backup location, it only showed the options of Drive D and E for the backup, neither of which were the MyCloud drive. Something is very wrong with this product!!!

@jim2 Have you visited the Learning Center? http://learn.mycloud.com/

if you are trying to set up windows backup see the knowledge base article below for directions.

You seem pretty upset though so if you are still having issues i would suggest contacting WD techical support directly.

I just got through talking with WD “support”. My Serial Number didn’t work using the webpage, and they had informed me previously that it was an invalid serial number. Only later on did someone “manually” enter that Serial Number. BTW, that serial number was written in such tiny letters on the bottom of the device that I had to acquire a JEWELER’S LOUPE to read it. And then, they are rude enough to block access through their portal if you don’t have a working Serial Number. Problem it, the fact that the system wouldn’t accept my serial number caused me to waste a few days, so NOW Best Buy informs me that I have gone over their arbitrary “15-day” return policy. And, I was not told when I bought the product that there was going to be some sort of incompatibility between my Arris router and the MyCloud Home device.
And just an hour ago, I discovered that this device wasn’t going to back up the OPERATING SYSTEM!!! Why would anyone want to buy a backup system that was incapable of backing up the operating system as well as user data?
In 40 years of buying computer products, I have never seen a more utterly disastrous combination of mistreatment and general abuse than this product, and its company.

Hire the Geek Squad at Best Buy to come out and get it set up for you!