[HOW-TO]: Troubleshooting Remote Connectivity Issues

Note: This guide gives examples using the WD My Cloud NAS. Other NASes will differ slightly, but will be similar.

Here’s a few steps you can take to determine why mobile devices might be unable to connect to your My Cloud (or My Book Live, Duo, N900C, etc.).

This would apply to:

  • WD Photos
  • WD My Cloud Mobile app (iOS / Android), formerly known as WD 2go
  • Access via the WD My Cloud web application ( www.wd2go.com or www.wdmycloud.com))
  • …or the My Cloud Desktop App for Windows and Mac.

Step 1)  Check to ensure you can access the drive while you are on your own local WiFi network.

If you cannot, then STOP.  You need to configure your WD device and network correctly, which includes:

  • Making sure Mobile Access is enabled
  • Making sure your Wireless IP network is the same as your WD Devices IP network

Step 2)  Check to ensure that your WD Device has internet access, and that it’s able to reach the WD service:

The simplest way to ensure Internet access is functioning is to configure a Notification Email, and once configured, send a Test E-mail.  Wait a few minutes, and you should receive the e-mail (assuming, of course, your spam filters don’t kill it.)

Once that’s verified, and assuming your router supports UPnP, then on the My Cloud NAS, log into the Web UI and navigate to SETTINGS / GENERAL, and scroll down to Cloud Access.

Ensure the Remote Access slider is ON. If not, slide it to ON and save as needed.

cut1.PNG

After a few moments, you should see:  Connection Status: Connected.  If needed, change to another page in the UI and come back to force a refresh.

Under this, you may see Port Forwarding Connection Established, which is what is preferred, or it may say Relay.

Either way, if it says Connected, you should skip to Step 5. But if it is using RELAY mode, just be aware that this requires all of your connections to pass through WD’s servers…a less than optimal and untestable situation.

If not, continue to Step 3.

Step 3)  If your router does not support UPnP (or doesn’t support it correctly), then you will need to manually configure port forwarding.

If you need to configure manual port forwarding, then before continuing, you *MUST* configure your NAS to use a Static IP address.  Consult the Cloud’s User Manual for instructions.

Configure manual port forwarding by clicking the Configure hyperlink on the Cloud NAS, as shown above in Step 2’s screenshot.

In the Pop-up that appears, click the “Manual” button, and note the two ports listed. By default, the Cloud will have ports 80 and 443 already entered in the blanks.

If no devices on your network are using ports 80 or 443, then click the SAVE button and manually configure your router to pass those two ports to your My Cloud NAS. Consult your router’s documentation for instructions.

Go back to Step 2 and wait a few minutes to see if the connection status changes. If the status changes to Connected, then skip to Step 5.

If your some other network device is already using port 80 or port 443, you will need to select two different ports for your My Cloud NAS and continue with Step 4.

Step 4) Select two unused ports for use with Remote Access.  They can be any arbitrary ports, with a few exceptions, between 1024 and 65535.  The NAS will warn you if your selection is inappropriate. Also, consult your router’s documentation to determine which ports are available and unused.

Enter the two ports you’ve chosen as shown below. I’ve chosen ports 9080 and 9443 for this example.

Click the SAVE button.

Next, configure your router to forward those ports to the STATIC IP address you have configured on your Cloud NAS. Again, consult your router’s manual for instructions on how this is done.

After all settings are saved to your router and NAS, I recommend first rebooting your router, then rebooting the NAS.
Once everything is back up, go back to Step 2 and check the connection status again.

If you’re still unable to get a “Connected” status, then you will need to contact WD Support for more guidance.

Step 5) If your Cloud NAS’s “Connection Status” is CONNECTED, then the NAS is communicating with the WD server infrastructure. If you are still unable to reach the NAS via remote access apps when not on your home network, then try this:

Using a web browser on the same device, navigate to the EXTERNAL IP ADDRESS of your router.

To determine the external IP, go to the website  http://www.whatsmyip.org/ and note the address.

Now, using your Web browser on the same PC or device from which you’re trying to use remote access, navigate to that IP address and port used, such as:

http://334.116.115.1:9080  [Yes, I know that my example IP address is not valid.  I don’t someone reading this guide to try it and accidentally connect to someone and get confused]

(Note: The :9080 part at the end of the URL is important. That number after the colon must exactly match the “External Port 1” port you chose in Step 4.  If your router is using UPnP, and you didn’t do Step 4, then consult your router’s documentation to determine how to see what port was given by the router to the My Cloud NAS.)

When you navigate to that address, you should see:

In this testing case, that error message is actually what you SHOULD see. The Cloud doesn’t allow actual web browsing using an external source, so if you see this error, it means you ARE able to “reach” the NAS via your configuration.

Do the same thing for the “External Port 2” address, such as:

https://334.116.115.1:9443

After possibly receiving a security warning, and accepting the warning, you should see the same error again.

If you do NOT receive the above messages on BOTH ports, then there are a few possibilities (in no particular order)

  1. Your ISP or router are blocking the connection. Try going back to Step 4 and using a different port for the one that doesn’t work.
  2. Your configuration is in error. Start back at Step 1 and verify all settings are exactly correct.
  3. The place from where you’re connecting is implementing firewalls or policy filters that may interfere with data connection (doesn’t usually apply when using Cellular data, but may depending on where in the world you are.)

Step 6) If all the tests from Step 5 pass successfully, but you are still unable to use Remote Access capabilities, then the problem possibly lies with the mobile device (or PC) being used.

Try these steps:
On iPhone / iPod / iPad…

  • Force-close the WD App.
  • If your device is Cellular-capable (3G / 4G / etc): DISABLE WiFi to force the phone to use cellular data.
  • Put the phone in Airplane Mode.  Wait 10 seconds, and turn off Airplane Mode. Wait for your device to rejoin the cellular data network.
  • Restart the app and try connecting again.

Windows PCs:

  • Close all WD Apps.
  • Open a CMD window and issue the command

ipconfig /flushdns

  • Try connecting again

Android devices:

  • Disable WiFi
  • Force-close the WD App
  • Force (Hard) Reset the device
  • Try connecting again

(The above steps are intended to clear the devices DNS Cache and force new DNS/IP Lookups.)

13 Likes
PROBLEM accessing WD from internet
Can't establish cloud access no matter what I try
Cant remote access between WD My Cloud & Sir-655 router
User does not have permission (403) in mobile network
No 3G connection
Can't connect to WD MyCloud Drive away from home
WD My Cloud: Unable to access device. (0)
No remote access but device online and config correct
Cloud Access problems
Using a WD My Cloud with an Apple Airport Extreme Base station router through OpenDNS
Unable to connect to Device
Cannot acces to my cloud
Cannot Access EX2 from the Internet
External cloud access works no more
Cannot access EX4 remotely
No file transfer despite relais connection
Inconsist ent access
WD My Cloud Internet Access
MyCloud 3TB Unit Remote Access Speed Issue
Remote access only on relay mode
WD 2tb mycloud **bleep** still will not work correctly after 5 mths?
WD My Cloud 4TB connects fine on local network but no devices can access remotely
Cloud access is disabled - Invalid parameter (400033)
Problem to conect to my cloud outside my home
Problem to conect to my cloud outside my home
Cloud Access through iPhone and outside personal wifi zone
WDMyCloud.com
iOS App - no access using 3G
Device Offline
Remote access troubleshooting
Cannot establish remote access
Very Frustrated....can only establish a relay connection
Can only access My Cloud on my home Wifi
wd2go, desktop app, FTP access - everchanging access problems
Do we have a NEW outage?
Ipad Device Offline?
Remote Access on BT Home Hub - Please Help
Access my cloud outside network
[Issue] Remote connection switches from port fowarding to relay connection
Cannot access WD My Cloud Remotely
Port forwarding failed to connect on port 80 and port 443
Unable to connect to device via desktop app
Device Offline
My Cloud remote access failed
Trying to access my cloud on college network
Android Network connection failure (903)
WD2GO - JAR - My Cloud
What on earth with remote access on my cloud?
Mobile ap
Unable to connect remotly
How do I configure Airport Extreme to access WD MyCloud on my iPad from outside my home?
Remote access error message
Working fine, then all of a sudden no remote access
No 3g connection
N900 - Remote Access issues
Remote access problems
Remote access to MyCloud on Live Duo
DX4000 network problem
Can't connect to MyBookLive on WD My Cloud app
Kindle Fire Apps
Can i remote access WD Drive via WD My Cloud Apps using 4G mobile network?
What port is Mycloud application (IOS, PC, MAC) using to connect to the NAS
Iphone and iPad on local network "LOADING"
WD My Cloud with WD Photos Android First Time Setup fail Galaxy S4
Imposible conectar a My cloud fuera de mi red
Acceso Cloud ha dejado de funcionar
WD General Network Error 500, iPhone App, HELP!
Cloud access not working
[GUIDE] Troubleshooting Mapped shares and local connectivity (Windows only)
Fed up with port fordwarding eror and WIFI connection (Ipad)
wd2go access remotely on iphone not working
WD - Frequently asked questions
Port forwarding fail Error 31526 with dlink DIR-615
Changed ISP and now unable to access drive remotely
URL log In Problem from Tasmania to UK
Connection Issue (web access) - Everything was working fine... WAS
Access my cloud outside network
Remote Access Issue on wd my cloud 3tb
Remote Access
Cloud access - no access
WD My Cloud Unable to access device. (500) error! Worked great then just stopped! FW V1.03.41
New User EX2
Transfer/Upload files from a remote computer to My Cloud EX2
Setting up router for ex2

Now that’s what I call a dummy-proof guide.

no, not really :confused: my problem still persists as the guide simply avoid what it seems common cause of the problem. So let’s see:

Step 1) checked. Working locally

Step 2) WD My Cloud has inet access, feature is turned on, and it says: “Connection Status Connected (Relay connection established)” so skipping to Step 5

Step 5) can’t check IP adress with port as I don’t have any set (no step 4). I can’t set upnp or port forwarding. That’s the main reason I bought this device. If I could set it I would have used simple and cheaper USB drive.

I’m not sure what “cloud” and “relay” means if not this. As Steam server relay works. And TeamViewer server relay works well.

Well, you’re right in one regard… I don’t emphasize that RELAY is quite undesirable. Relay has lots of dependencies on WD’s infrastructure that’s completely avoided if you have port forwarding working.

Dagnabbit… I edited one line on my iPad and it messed up all the formatting and tossed all the images. Ugh.

may be undesirable but still should work :frowning: It’s not “slow” or “sometimes servers are down”. It simply doesn’t work at all and I have no idea why. As said, with only portforwarding ability working this seems useless as any USB external or “not clouded NAS” will do the same job.

I agree it should still work – but my guide cannot possibly test their servers.  ;)  I don’t claim to find every problem – just several of the ones the user has control over.

I got my cloud last weekend. It’s proving a right pia. Every day I lose my 3G connectivity because it keeps changing to relay mode. I have to keep turning cloud access off and on and it works again. Is the new firmware causing this? My ports are all forwarded fine.

I have an existing MyBookLive (2TB) which works well (but slow via 3G) then i just installed a new MyCloud (4TB) on the same wired network a few days ago.

Connecting remotely to MyCloud is intermittent. Most of the time i get the error  “Unable to access device”.

Both device use the same ports 80 or 443. should i manually assign ports in one of the device in this case?

temiatwork wrote:

I have an existing MyBookLive (2TB) which works well (but slow via 3G) then i just installed a new MyCloud (4TB) on the same wired network a few days ago.

 

Connecting remotely to MyCloud is intermittent. Most of the time i get the error  “Unable to access device”.

 

Both device use the same ports 80 or 443. should i manually assign ports in one of the device in this case?

They can’t both use the same ports externally-- that’d cause a failure.  They must have different ports on the outside so the router knows which NAS is which.

1 Like

When I use the site Tony posted in his tutorial to inform me which ports are open with my external ip address it says ports 21 and 443, are these the right ports for streaming etc…?

This was a wonderful how to but I think it is important to add two things

For some of us where ports 80 and 443 it is not an option it is important to point out that you can through NAT using port forwarding to forward to those ports onthe device. In my case I have used 9080 and 9443  and forwarded them to 80 and 443 respectively. I only discovered doing this by looking at threads in other forums. My device now works perfectly and I have other machines that use internally 443 and 80 but there is no conflict as I have the external ports addressesd through NAT.

Also one other nit picky things in step 5 you might have to do https  when testing on 9443 as this is may not work if you leave the s off

Catullus wrote:

 

Also one other nit picky things in step 5 you might have to do https  when testing on 9443 as this is may not work if you leave the s off

Good find!

Corrected; thanks!

I did have the “Connection established” message and my router was showing the WD device IP address on the UPnP tab. But I still could not access the cloud from outside my home network. Actually when I first set the device up (about 3 months ago), everything worked as it should. Then, suddenly it stopped working, I don’t know when.

Now I tried the manual port forwarding setup as you mentioned and it still did not work because it could not connect. I reverted back to “Automatic” and now it connected with a “relay connection” and not direct connection any more. And viola, the remote access started working even from outside my home network. I don’t know exactly what made it work, but thank you a lot for writing such a detailed troubleshooting guide. It really helped me.

I spoke too soon. After about an hour, the WD My Cloud is showing “Connected: Port forwarding connection established” and I cannot access it from outside any more.

I discovered there was a conflict in ports 80 and 443, so I went back to manual port forwarding and used 9080 and 9443 and this time did the port forwarding correctly. It is all good now and everything is working again with “Port forwarding connection established”. I believe this time it is going to stay.

Thanks for this tutorial, unfortunatley it didn’t solve my problem. I’m using the Western Digital My Cloud with the newest firmware installed.

I can connect to the device and open every folder in my local network via laptop. No problems here. Problems occur when I try to connect via the WD 2 go Android App (tested on two different devices). I can connect to public folder. And I can connect to one of my private folder. But in my private folder there is one folder I can’t connect (error 903). An other folder in this private folder can be opend without difficulties.

Anyone a clue why I can’t use this one folder via app?

Alex416 wrote:

Anyone a clue why I can’t use this one folder via app?

My guess is that the permissions on the folder or the contents thereof are not correct.

You’d have to log in via SSH to see that level of detail.

You might want to open a separate thread on that matter, as it’s out of scope of this thread.

Hi all,

Could someone please help me with a problem i have while connecting with Android App to WD My Cloud (4 TB). It displays the error 903 if i try to connect the disk using only my local network (disconnected from internet). If i connect phone and disk to internet i access the disk from Android phone without any problem (using WD cloud access?).

It is mandatory that the disk and the Android App on phone are both connected to interne t (accessing the WD Cloud )) or is it possible to access the disk with Android App using only wifi (local network only) without Internet Access (from a computer with windows 7, without internet access, i can access the disk  using only  wifi router in my local network).

Thank you.

Best Regards

Even on the local network a brief internet connection is required just to find the host.  That’s all.