Cloud access - no access

Hello guys,

For a long time I had a problem that once every few weeks I couldnt access the my cloud remotely using the app or
When trying to access it using the app when connected to my wireless network it always worked.
A reboot to the unit solved the problem every time.
All of the network settings (ports, dhcp) were always on automatic\default.

Now my problem is a bit different.
I cant access it on the app (for backups and such) even when at home and connected to my network.
Reboot does not make a difference
So I searched here at WD Community and tried everything written in those how-tos but no luck. #1 #2
My ‘my cloud’ is now on a static internal IP, ports are forwarded as they should, but still no access from inside nor outside my network.

Is there something I can do before restoring everything to default?


I am witnessing exactly the same issue… no access since this morning (24th of july, 11 am CET)
Can somebody from WD kindly tell us what is happening???

apparently - at least here in italy - it seems that the mycloud service is down.
I tried connecting via web directly to the device (using the IP address + port number) and it works.
Instead I cannot get access via the mycloud portal.
So I am more and more convinced that the service is down…
Somebody from WD can please confirm???

Ok I solved the issue by myself…
I found a thread on the web regarding basically the same issue that happened to me…
The solution is the following:

  • type in the email address(es) to register in mycloud service in CAPITAL LETTERS (I know this might sound fun, but it worked…)
  • change the DNS (go to Settings>Network) of the device to the google ones ( primary, secondary)

I cannot tell which one of the two changes described produced results in my case (i implemented them at the same time…) but they worked!

So, thanks WD but now I no longer need support (btw, I have been waiting more than 24 hours now to get a reply from customer service…)

Hope this will help other users that will fall in my same situation, my device was working perfectly till yesterday, it stopped working without any changes being made to the router, connection, pc, device, mobile.