Access mycloud drive from outside my home?

hello everybody , I am new & I need your help
i want to access my WD cloud drive from outside my home in my work computer or in internet cafe using WDmycloudlogin.com but after successful login showing this message : No devices avaliable , please notify the device owner or admin user . this is what i get on my browser :
https://postimg.org/image/dytkgec7l/

I reinstalled it several times to see that message " Want to access your files from outside your home ? " but no use . I want to gain access to my drive from any computer as google drive with only user name & pass .

PLEASE HELP , i am a beginner as compared to anyone here
THANKS ALOT

The mycloud.com site was upgraded last week, and I believe there is a problem accessing it according to many other posts here. Maybe it will be fixed after the weekend. Explore the “Latest” section of this forum from main forum menu for similar messages.

1 Like

Same problem here. …been trouble shooting it all weekend and I can’t get mycloud.com to load the login page

Tyler, I believe my reply above yours answers the question for now!

thanks every body
I had contacted them yesterday 30 minutes of international calling & by Go assisit , he told me i had 2 ports closed which are port 80 & 443 , and I should contact my ISP to open them , other wise remote access will be disabled . !!! is this logic
upon calling my ISP he had no idea & promised to contact me again
If any one know how to open these ports ?

Hi Ahmed… did you get answer how to open the ports??
Thanks

IF your broadband provider is not blocking ports 80 and port 443, you can access your local network router and configure port forwarding within the router to forward ports 80 and 443 to the My Cloud IP address. You will need to perform an internet search for your particular router model for directions on how to setup port forwarding.

For the My Cloud one can manually set the ports used through the My Cloud Dashboard > Settings > Cloud Access > Configure > Manual.

You could try enabling UPnP control on your router, so your MC can open the required ports. I don’t like doing this, because I dont want rogue software to be able to open holes in the router’s firewall. So I use manual port forwarding setup.

I had the same issue and I changed nothing and I took at nap earlier today w. Sane issues and I woke up about an hour ago to everything working …there is no problem on our end and there magically is a new firmware update too…when this problem initially occurred I was told the same by CS …that I had port 80 and 443 closed…we’ll I opened em and still couldn’t reach mycloud.com, everything now on my network was set to default like I had originally and it worked for over a year…same setting now that had issues all weekend…and same setting now but ,now it works great …idk why everyone is pointing fingers here at the consumers when it’s obvious that mycloud.com was the issue. If anyone can read u can tell this product has been riddled w. Service issues for years. …so once again …I have a gen 1 my cloud set to factory default and it works great now …

Still not working & no reply from ISP
But if I set my cloud to factory default setting will it erases its contents ?

No sir nothing yet . & I did not think they will reply

Hi Ahmed… I got advise in another thread that set back to “factory default” without loosing any content :slight_smile: I did the 4 second reset and the only thing it did was erasing my password and setting the Network settings to default, and all started to work great again… :slight_smile:

Just for declaration , I had never logged in using Mycloud.com .
Someone told me that I should connect my WD account with my physical drive but I do not know how to do this

Anyone in the know of why my myCloud, all of a sudden, stopped remote access? It works fine when on home network, but not elsewhere. Says in the dashboard cloud access failed. Even after re-boots (bith the AirPort Extreme and the unit), static IP, renewal of the latter, and 4 second reset. Nothing works.

Have done no major upgrades or updates to my systems of late. Was an update for the WD app some week ago with minor bug fixes. That’s it.

Have read WD servers can be down. Issue here? Would be terrific could I get the access working again: streaming my music from it at work.

Help? Please?

*** EDIT *** Changed the DNS to some OpenDNS IPs I found. The myCloud now says it’s connected. Tried accessing the cloud on my iPhone (wifi off), and it worked. Still wonder, though, why the heck it stopped working all of a sudden…

Please can you tell me how to do the 4 seconds reset ?

See the following WD Support document on how to perform a 4 second reset or a 40 second restore and what each will reset to default values.

http://support.wdc.com/KnowledgeBase/answer.aspx?ID=13986

Hi buddy,

to connect your device with Mycloud.com account you need to login to youre device then go to “Cloud Access”

and there you’ll see “blah blah - don’t have Mycloud.com account” at the right side you’ll see “sign up”

blah blah = user name

press on it and fallow the instructions

ps: I’m not sure that you need to open any ports…

SOLVED
Thanks for every one

I made 4 seconds reset & still not worked , so I go to " My cloud dashboard " & removed all cloud devices & users > sign in to WD program on my laptop > go to dashboard again > cloud access > go to mycloud.com account & deleted it then i had made a new one & activated the sent email > sign in > every thing works

THANKS FOR ALLAH
then thanks for every one here , your expert advice is highly appreciated