Remote access used to work and today it does not?

I set up My Cloud 3Tb 2 days ago and it worked perfectly.

I accessed it remotely yesterday using both my android phone and my work PC.

Today both my phone and work PC are saying they cannot connect to My Cloud and a message pops up saying “cannot access network (900)”.

The blue light is on the My Cloud at home and internal is ok.

I have seen several other posts with similar issues on this forum, but aside from a few super-technical “blabs” about static IP address etc., no simple fix to this issue.

I am concerned as clearly I spent a considerable amount to buy this My Cloud system and it should in theory be very simple to run.

I am wondering if this is a software issue with WD?

Please help!



This can happen if you have a dynamic ip from your internet service provider and your internet service is interrupted for any reason and when the service resumes you have been allocated a different ip.

if this is the case the easiest way to correct it is to log into the MYCloud dashboard from your home network and navigate to Settings/General and switch off remote access for a few seconds then switch it on again.

unfortunately this cannot be done remotely however I believe there is a thread on this forum where a user was trying to create a script to let the WD MYCloud check the exteral ip and reset access if different from previous

Hope this helps


1 Like

I am having exactly the same problem and see this very error message myself.

I will try to the above but even if that works: is this really by design? is there absolutely nothing that can be done to remedy / fix it in any other, invisible to users who cannot be bothered in knowing their IP addresses way?

Hi, Much thanks. I had the same happen on my Samsung Galaxy S5, but my Samsung Galaxy Pro Tablet 8.4 was fine.  I did as you said, and turned off the cloud access, waited, then back on.  The phone once again worked.


I had the same issue, unfortunately I was on a road trip and could not reset cloud access and did not have access to my files for 10 days.  The suggested fix did work once I got home.

This is not related to dynamic IP addresses.  Mine is dynamic but it has not changed.  (I access other things on my network remotely using my assigned IP address.)


We have passed this along to support.

I have a post about the same issue and got a stupid email from support saying my ports were closed even though I told them they were not and I wasnt having an issue until this past week.  Looks like WD support are not even trying