Unable to connect to MyCloud outside my home network

This is extremely annoying. Part of the ‘benefit’ of My Cloud is the ability to access your file from anywhere, any time.
I am having issues connecting through my Android App (getting the infamous "Network Connection Failure (905) error. I was able to connect to my Home PC remotely and re-establish a remote connection from my phone, but clearly this defeats the purpose of having access to your own server. Once does not need to have a remote control app on his home PC to fix things.
Also, I am working outside my home on a PC using my cell’s hotspot via tethering and I am unable to connect to mycloud.com in the browser (tried both Chrome and Mozilla). After typing my login ID and password a new tab opens and it is stuck on Signing In forever.
This is extremely frustrating.
Does WD have a solution for that?

Thank you.

It sounds like you have lost Cloud Access in NAS due to a router reboot. When you get home you can reboot the NAS, or just turn Cloud Access (within dashboard) off and back on in 30 seconds or so. A way to test this from home is turn off phone wi-fi and attempt to connect to NAS thru cell only signal using the MC app. If you connect, Cloud Access is working again

I am a user responding, not WD staff., so go easy on us witj the complaining please. We ALL know these things can be frustrating.


Thank you Mike.

The complaining is with hope that WD people are here reading this :grinning:. I am able to connect through my Android app but as I mentioned, the point of having this cloud is to be able to login when you need it. No one should expect to be far from your cloud and unable to login, and the solutions are re-booting either the cloud or the router. If it should work, it should work. Reliability is the key.
I am just curious why would the app (finally) connect and the PC browser won’t.


I only connect remotely with iPhone or iPad MC app. Just know that if you reboot router and the NAS, the router must be first because it gives the NAS an IP address that is fresh and good for cloud access again.

Thank you Mike.

I am using a static IP for the NAS.

This has nothing to do with the router’s static IP. It has to do with the port forwarding to the internet which changes with each router reboot. So, go into dashboard Settings/General/Cloud Access as described and follow the steps I described to get the port forwarding corrected.

Well, the port forwarding seems to be fine. As I said, I am not able to access the NAS on my Android app (after logging in remotely which should not happen), but I am unable to access through a pc browser. The bottom line is that the NAS needs to be reliable. Users don’t need to login in remotely and/or reboot devices and routers.

Thank you.

So, did you do the steps to fix Cloud Access? If you don’t do this you are spinning your wheels Good luck.

I did, and as I mentioned, I am able to access through the phone’s app, but not through a PC browser, so no - it is still not working properly.

Edit: so it works in IE, not in Chrome or Mozilla.

Good, some progress was made. I do not use browser to access MC, only the MC app. Why not contact WD Support?

Friends I am having similar problems. If I reset the Cloud Access in the dashboard (turn off and then back on) I can access remotely, but inevitably (after a day or so) it requires another reset. Can anyone give me specific advice on how to set up port forwarding (if that is in fact the issue) so that this does not recur? Thanks in advance.

Same with me… it seems that is a usual problem… it should be a usual solution! :confused:

Have any of you used the Cloud Access fix link here?

I know this is an older post, but I just wanted to say that I lost access to cloud services recently, and Mike, your suggestion of turning cloud access off in the GUI for several seconds and turning it back on worked like a charm! Thank you for posting!

Glad I helped, and thanks for searching the forum for assist instead of asking the same question for the hundredth time!

But that’s not an acceptable solution. If you’re away from your home network, you can’t really tweak settings on your server unless you have remote access which not everyone has.

I understand your point. I have not encountered this issue in a very long time, so I don’t really consider this a huge ordeal now that it is working again. If I run into this issue again in the near future, I will look into it further.

I just wanted to stop by and say thanks to Mike for replying to you, because it helped me out.

I have had the same problem for years ever since I upgraded to window 10. I have had ed people try and help. I have had outside people come to my home and help with my router / network to no avail. I am completely frustrated and do not trust this product and I am not sure whether to trust an WD product anymore. I can not have to reset my router or my book drive everyday. I need something I can trust and rely upon and unfortunately after seeing other people with this issue I realize it’s drive or software and not the network. Any suggestions for a new external drives with remote capabilities?

This is undoubtedly a Windows 10 issue. Microsoft changed the Windows 10 network setting defaults (supposedly to improve security - I guess it worked)! Google your issue and you will probably find a solution.

To the two people who commented directly above:

In no way is this a Win 10 issue. As I and others have stated, the loss of remote access for My Cloud devices is due to a loss of Cloud Access in a My Cloud due to the port forwarding IP address being changed by a rebooted router. Since the My Cloud does not auto refresh, the My Cloud either can be rebooted, or Cloud Services in the My Cloud can be refreshed by turning it off and back on.

This is totally a My Cloud issue that WD should fix!