MyCloudEx2 remote access

Access to files from Android/PC (via MyCloud.com) works fine when device is on same {Home} network. MyCloud device says successfully connected to MyCloud servers with Port Forwarding. Ports manually set, and appear open from outside network.

When attempt to access files from network outside home network (cell network, or even home ‘Guest’ network) with device that minutes previously had no problems accessing files, now reports MYCLOUDEX2 not online/connected (errror 906 on Android App).

FIrmware updated to latest (one year ago, which is last/most recent firmware), worked okay previously, not sure when stopped, but now cannot access remotely. Not sure what to try next. Rebooted MYCLOUDEX2 multiple times, rebooted home router, etc. No Joy :frowning:

It appears some are having trouble (still) with WD’s remote access to the My Cloud devices. Couple of troubleshooting suggestions. Access the My Cloud Dashboard > Settings and turn off Remote Access/Cloud Access. Wait five to ten minutes. Then re-enable the option and wait for the Dashboard to indicate a connection. If that doesn’t work, assign a static IP or reserve an IP address (within the router) to the My Cloud. Change the remote access/cloud access setting to manual and assign alternate ports (example: 8080 and 4443), then enable port forwarding for those two ports within the network router.

Also note that there is a dedicated subforum for the EX2 series where users more familiar with that series of devices may be able to assist.

https://community.wd.com/c/network-attached-storage/wd-my-cloud-ex2/109

The multi bay My Cloud models may support other methods of remote access (WebDAV, SFTP, etc) that bypass WD’s back end issues and would allow one to potentially have remote access to their multi bay My Cloud. See the My Cloud User Manual for your device for more information.

Interestingly enough, I power cycled the device, as I noted very sluggish response times when trying to access dashboard, and that the drive LEDs were active, wonder about what it was doing…and ever since, remote access works!!! This is despite having rebooted several times, as I stated. Clearly something with the device itself, software/hardware…unsure.

Thanks for the suggestions. I’ve already tried them all, but randomly (as I listed below), power cycling the device has restored REMOTE ACCESS, at least for now. And thanks for the specific link to the EX2 subforum that I was unable to find on my own…