WD MyCloud - unable to access remotely

Hi there,

I am hoping somebody can help? I have never been able access MyCloud remotely. I have tried accessing it via the WD2go site, (device is shown, but states ‘offline’ in devices). I have also tried accessing Mycloud through the App (it shows my device, but when I try to connect it says ‘can’t connect to this device’).

I have set up & mounted 2x network drives, ideally I would like to access both drives remotely (by accessing MyCloud remotely on a separate WIFI network). Is this even possible? Are all my problems related?

Any ideas on how to solve will be forever cherished!

Big thanks


this forum is a saviour of invaluable help, so hopefully

Sounds like the router the My Clouds are connected too may not be properly passing traffic to the My Clouds.

If one is using two My Clouds on the same network there are a few issues to keep in mind. Make sure each My Cloud has a distinct unique name. That both My Cloud’s are configured to use a Static IP, either issued by the router or configured in the My Cloud Dashboard. That the router has UPnP enabled (see the router’s administration page to set or check UPnP support).

There is a way to check on the WD My Cloud Dashboard if Remote Access is working. On the Dashboard, navigate to Settings > General > Cloud Access. Ensure Remote Access is set to On. If Remote Access is working and can access the Internet, the Connection Status should indicate “Connected (Relay connection established)”.

Hi Bennor, thanks for taking your time to respond.

I only have 1 My Cloud set up. I have set it up with a static IP and UPnP is enabled. Sadly I am unable to check the dashboard that ‘remote access’ is turned on (as I am away from my home Network and unable to access My Cloud remotely). However I am 99.99% certain that this is also set to ‘On’.

Any other ideas what could be causing this?

As indicated above check the router to ensure UPnP is supported and activated. However without access to the local network to even check the Dashboard it will be difficult/impossible to check the router’s settings.

I can confirm that UPnP on my router definitely enabled.