Wd mycloud remote access issues

I have remote access issues with mycloud 2TB connected in network.

It works fine with networking mapping but it cannot be accessed on iphone, ipad or any other device remotely accessing it using wi-fi, 3g/4g connection.

I have tried resetting device by pressing the reset button on the back of the device and rebooting, which unfortunately isnt the solution.

Everytime it says “device offline-device is not accessible” when trying to access remotely and on rebooting by removing power cable and restarting it works fine for sometime.

When it is remotely inaccessible, i cannot access it through dashboard as well.

Only way to get it to work is by rebooting which is very frustrating.

Any solutions??

I have installed the latest firmware update recently.

sounds like it has worked in the past. If this is correct coupled with the UI issues I would do a system only restore, this leaves data and shares and resets everything else

i was trying to log in to mycloud 2TB via IE and my account works fine.

However, when i try to log in with the 2nd user password, after entering to the main page, it says WD devices not available.

and there is no other option except Change Password and Log out.

I thought after updating the firmware would helps but it clearly is not helping either.

Do anyone here encounter same issues?

please clarify exactly what you are doing? what is the main page? how are you getting to here?

each ,ycloud user needs there own WD account for remote access. have you entered an email for this 2nd user? have they created there own WD account? are they using this email for access?

I tried this, but problem persists.

When i loose connectivity remotely, i cannot even log on to mycloud dashboard through ip address.

All i can do is pull power cable and restart device after which i can access it remotely for an hour or so and again same issue… it is very frustrating…

Should i try uPNP forwarding through router? Right now it connects using relay connection. WIll this address the issue though?

sam, have you tried the system only restore yet? with the 2 issues it is more then a remote config issue

Hi larryg0,

Yes i have tried system only restore but still both the problems persist.

Mycloud device is plugged into network and connection shows as relay connection.Would connecting mycloud into router with uPNP connection make any difference in regards to these two problems?

upnp could be causing issues with the remote access but it dosn’t explain loosing access to the UI at the same time