MyCloud.com no devices?!


#1

Hi,
I’ve been using my MyCloud 4TB drive without problems for quite a while up until recently. Now I have issues with the remote access for no apparent reason. Here’s the summary -

  • Locally at home I have full access and everything works as normal (access via Android & iOS phones, iPad, Windows 7 pc & Windows 10 laptop).
  • Via my android phone using the wd app I have full remote access as normal
  • Via my android phone using a browser I get the following message after login - ‘No Devices available. Please notify the device’s owner (or Admin user)’
  • Via my work computers (a Win10 laptop & Mac Pro) I cannot access the My Cloud at all, via the WD Access/Sync apps or through any browser - it will let me sign in but comes up with the same error - ‘No Devices available. Please notify the device’s owner (or Admin user)’
  • If I try and sign in to the browser at home (i.e. via the internet as opposed to the local network) I also get the same error message.

Regarding the My Cloud setup - it is all behaving normally (ports open and visible through my Virgin Superhub and ‘port forwarding established’ rather than the relay message showing). I haven’t changed any hardware recently or firmware (the My Cloud is running the latest firmware update).
Any ideas or help would be greatly appreciated!
Thanks!


#2

Hey Cain77,

Please refer below mentioned link and focus more on these 3 solutions which are listed in the below link:

  1. My Cloud Firmware Update
  2. My Cloud User Email Address
  3. My Cloud Cloud Service

If the issue still persist then try all the solutions listed in this article or better to call WD Support if these above 3 solutions doesn’t help you.


#3

Hi,
Firmware is up to date, when I try to re-enter the email address (as per directed) I get the following error -

  • This email account cannot be deleted. Make sure your device is registered and your network connection is functioning properly, and then try again. (250010)

I will try the other steps but if anyone has seen this error before and can help that would be very much appreciated,
Thanks!


#4

Hi - just a follow up on this. I tried everything with no success so ended up doing a system only restore (and then re-importing the config settings via dashboard). This appears to have fixed the issue. So if anyone else has similar issues, that might be the quickest way in the long run,
Thanks


#5

Thank you for this update. I am happy that you issue has been fixed