HELP! "No Devices Available" error on mycloud.com. Going nuts!

#1

I am trying to get a 3T WD My Cloud to work. I have network access all day long. I can access on my phone through the network, but if I go to mycloud.com, I get the message "No devices available - Please notify the device’s owner (or Admin user).

I have searched online and gone through a number of options with no avail. Why don’t I have devices available?

The drive is set to Public. I can access on a mac, on a pc, and on phones with them all on network. The problem is trying to use a browser interface. I have tried both websites.

Cloud Access is Connected. Port forwarding connection is established. I only have one user who is the Administrator. Remote Access is on and the Connection Status reports connected. I have checked the firmware and it is up to date. Remote access is On. The email address is correct. Access is set to public. Shares has Public Access on. Media Serving is on, but not necessary as I am just storing files. The network shows internet access under Status with a local IP address. The network mode is DHCP. No ftp access. Media streaming is off. I have rebooted the drive, and I just unplugged it for a few minutes hoping for some type of reset…

What have I missed? Why can’t I go online and see the drive? And WHAT DOES No Devices Available mean? At least give me a clue in the error message. I keep repeating to myself, no devices available, no devices available. The device. The drive? Available. Public? Online? Bad passwords?

I’m at my wits end. If anyone can shed some light on this. I have google searched myself to death! There about about 10 to 15 similar articles on the subject, but most of the resolutions end up failing again. In this case we have had this drive for months as it was a gift, so there is no returning it. I hope it isn’t a lemon.

Thoughts?

#2

Log into the WD My Cloud Dashboard, then go to Settings > General > Cloud Access. Ensure Remote Access is configured for ON. Then check the Connection Status to see what it indicates. It should indicate “Connected (Relay connection established)” or “Connected Port forwarding connection established.”

In certain cases one has to configure port forwarding of ports 80 and 443 within their router/gateway to forward to the IP address of the My Cloud. It is generally recommended to configure the My Cloud for a static IP address either within the router’s DHCP server setting or within the My Cloud Dashboard > Settings > Network section. One may also have to enable the UPnP option on their router if their router has that option.

In certain instances one may have to disable Remote Access, wait a few minutes, then re=enable Remote Access in order to get Remote Access to work properly. In other instances one may have to use alternate ports (both within the My Cloud and when port forwarding within the router) because their broadband provider blocks access to port 80 and or 443.

One may also want to review the My Cloud User Manual (http://www.wdc.com/wdproducts/library/?id=439&type=25), the WD My Cloud Dashboard Help, the My Cloud Learning Center (http://mycloud.com/learn/?id=mycloud and http://setup.wd2go.com/index.php?mod=product&device=mc) in order to understand the various features and options of the My Cloud device.

Note that setting a Share (or folder) to Public has nothing to do with that Share being “public” with respect to Remote Access. Rather setting a Share to either Public or Private is about controlling User level access to that Share. When a Share is set to Private one can configure User level access to that Share. This is useful to control which Users (configured through the My Cloud Dashboard) have permission (no permission, read only permission or full access permission) to access that Share and its contents.

#3

On the home page of the Dashboard, how many Cloud Devices are shown in the status box in the lower left?

‘cloud devices’ are devices that have established a connection with your MyCloud. They need to do this to be allowed to access remotely, using either the mobile app, or MyCloud.com. See p35 of the user manual.

#4

Log into the WD My Cloud Dashboard, then go to Settings > General > Cloud Access. Ensure Remote Access is configured for ON. Then check the Connection Status to see what it indicates. It should indicate “Connected (Relay connection established)” or “Connected Port forwarding connection established.”
response: Yes Remote Access is ON and reads Port Forwarding Connection Established.

In certain cases one has to configure port forwarding of ports 80 and 443 within their router/gateway to forward to the IP address of the My Cloud. **Yes that is done and correct already, with the possible difference of: Active: Yes, Protocol TCP, then two port setting for 80 and 443. Int.Port 80, Ext.Port 9091, and Int.port 443, Ext port 443. Should both Ext Port numbers be the same as in 443? Port 80 has a different Int. and Ext. Port number ** It is generally recommended to configure the My Cloud for a static IP address either within the router’s DHCP server setting or within the My Cloud Dashboard > Settings > Network section.If I use static, what IP address do I enter? The address for the My Cloud, my default gateway, or something else entirely? One may also have to enable the UPnP option on their router if their router has that option.Yes, this router has that option and it was already turned on

In certain instances one may have to disable Remote Access, wait a few minutes, then re=enable Remote Access in order to get Remote Access to work properly.I have already done this with no success In other instances one may have to use alternate ports (both within the My Cloud and when port forwarding within the router) because their broadband provider blocks access to port 80 and or 443.Maybe, but it sure seems like we are working hard for a solution. The ports were already set to 80 and 443, so I assume they function. The only caveat was that Int port 80 was matched with Ext port 9091…whatever that means.

One may also want to review the My Cloud User Manual (http://www.wdc.com/wdproducts/library/?id=439&type=25), the WD My Cloud Dashboard Help, the My Cloud Learning Center (http://mycloud.com/learn/?id=mycloud and http://setup.wd2go.com/index.php?mod=product&device=mc) in order to understand the various features and options of the My Cloud device.I have searched the web, searched the knowledge base from WD, downloaded and searched the manual, and read everything I can. This post is my option of desperation in the hopes that SOMEONE can help. So thank you for your thoughts thus far.

Note that setting a Share (or folder) to Public has nothing to do with that Share being “public” with respect to Remote Access.Yes, I have picked up on that. Right now everything is pretty simple. Minimal passwords and everything is public. Rather setting a Share to either Public or Private is about controlling User level access to that Share. When a Share is set to Private one can configure User level access to that Share. This is useful to control which Users (configured through the My Cloud Dashboard) have permission (no permission, read only permission or full access permission) to access that Share and its contents. At this point I am just going for the function of communication. I will delve into the other complexities once my base communication is established. I didn’t want to get to tricky right out of the gate.

The only thing I can think of that I haven’t done is to do a 4 second “reset” on the My Cloud. I have unplugged the drive for a few minutes and plugged it back in, but nothing else at the drive. I have rebooted from the My Cloud software, and have checked the Firmware. The only hang that I didn’t address was possibly going to a static IP address, but I need to know which one I am shooting for.

Thanks for all your input and taking the time. Please bear with me if you have any other thoughts. I’d really like this to be more than a wireless hard drive.

#5

On the home page of the Dashboard, how many Cloud Devices are shown in the status box in the lower left?
The answer is 4 Devices, 1 User, 5 Shares

‘cloud devices’ are devices that have established a connection with your MyCloud. They need to do this to be allowed to access remotely, using either the mobile app, or MyCloud.com. See p35 of the user manual.
All my devices are connected with the mobile app, or by being wired directly to the home network. I can connect anything via wifi, but nothing via the internet remotely using mycloud.com, or the other variation, wd2…something. No external access. Thanks for the thought, keep them coming!

#6

So you can connect remotely using the mobile app? But not mycloud.com?

#7

No, I may have misstated. I can use the mobile app if I am on the wifi network. So whether hard wired to the local network or wifi to the local network, I am good. Trying to log in from a browser is a no go.

#8

By the way, page 35 of the online pdf manual must be different than your hard copy. My wife did the original setup, and I am following up. I don’t know what she may have done with the actual print manual.

#9

You say your wife set the My Cloud up and you are using the same email as she entered, are you sure the password is the same as what she used?

#11

Hello,

Open your browser to http://www.canyouseeme.org/ and check port 80 and 443

#12

The only way to know for certain if ports 80/443 are not being blocked by your internet provider is to test/probe those ports from the Internet/Broadband side of the network. As SBrown indicated visit http://www.canyouseeme.org and run a test to see if ports 80/443 are open/reachable.

Also note that there are two DIFFERENT My Cloud User Manuals for the single bay My Cloud devices. Thank WD for the stupid confusion. You will need to check your firmware version (listed on the My Cloud Dashboard) and download the right User Manual for your version. While the two User Manuals are similar there are some key differences due to WD changing the Dashboard slightly with the newer v2.x version single bay My Cloud units.

#13

None of us have printed manuals; they aren’t supplied. You have to download PDFs, and hope that you have one that matches your hardware and firmware… I quoted from the ‘OS3’ version of the Gen1 h/w, v4 firmware manual. But it’s still page 35 in the gen2 h/w, v2 firmare manual. Read the page number on the page, not the PDF page number…

#14

You say your wife set the My Cloud up and you are using the same email as she entered, are you sure the password is the same as what she used?

Yes, wife made first attempt. It showed on my Mac, but not on her PC. I then picked up, downloaded appropriate software for phones and her laptop and we had network access. She didn’t remember her password, so I had to reset that as well. I am getting logged in, just no device available.

#15

“Open your browser to http://www.canyouseeme.org/ and check port 80 and 443”

Error: I could not see your service on 99.166.6.555 on port (80) Reason: Connection timed out.

and

Error: I could not see your service on 99.166.6.555 on port (443) Reason: Connection timed out

Not the actual IP address, but the rest of the message is accurate. I may have created this problem while trying to set a static IP earlier. I changed from DHCP to static, and now I can’t get back in settings to change the IP address back. I will try to resolve that problem first. But the answer to your question is above.

#16

A 4 second reset will drop the Mycloud back to DHCP, and clear the admin password.

The fact that you can’t see ports 80 and 443 suggest something is blocking them; could be you ISP, or could be your router firewall.

If using port forwarding mode, I find that if my router gets re-assigned a new global IP by my ISP (due to router reboot), the mycloud says port forwarding is established, but I get no access. I have to toggle the cloud access setting off/on to restore external comms.

I wish WD would fix this problem; relay mode re-establishes connection without problem.

#17

Great… like I don’t have enough problems. My pdf is 4779-705103.pdf for what that’s worth. I just don’t get how they offer an error message with no solution. I think we are on the right track, but I can’t believe I am the first to have this discussion. Anyway, thanks for your input.

I changed my IP in WD My Cloud software while trying to address the IP problem, and now I can’t get back into the WD software to change the IP back! The situation is deteriorating…

#18

What does “I changed my IP in WD My Cloud software” mean? What WD software did you use to change the IP address?

The WD My Cloud Dashboard is not WD software, it is the interface to manage the My Cloud device. It is better to set (or reserve) the static IP for the My Cloud through the router via its administration page rather than changing the setting within the My Cloud Dashboard from DHCP to Static. See your router’s documentation on how to set or reserve an IP address for LAN/DHCP clients.

If you can no longer access the My Cloud via its IP address then perform a 4 second reset which will change the IP setting to DHCP and clear the Administrator password.

http://support.wdc.com/KnowledgeBase/answer.aspx?ID=13986

The 4 Second Reset will reset the following:
Admin Password (No password by default)
Network Mode (Default = Dynamic Host Configuration Protocol (DHCP))

#19

I have found these urls which check port access to be unreliable. Sometimes they show success and sometimes they show failure. As a point of interest, I have three WD NAS devices, (2) 3TB MvBook Lives and (1) 4TB MyCloud. Even though the two ports (80 & 443) are forwarded in my Surfboard 6580 modem they don’t always comeback visible on the test sites mentioned above yet the (2) MyBook live units are accessible remotely all of the time while the MyCloud unit is not.

#20

I am doing the 4-second reboot now. Glad to know that…and hope it works. As far as firewalls, this is a very simple setup. I have Cox cable and use their router hooked up to my My Cloud. There are no special fire walls or things of the like.

I know that DHCP creates an IP address that can change, but in talking to Cox some years ago, they don’t change the IP very often and it is usually caused by some major reset like a power outage or something.

So back to my problem. I’ll reset everything on the My Cloud and do the port test again.

#21

I went into settings and changed from DHCP to “static” and manually entered the IP address and such. Fortunately the 4-second reset just solved that problem.*