HELP! "No Devices Available" error on mycloud.com. Going nuts!

#22

So, back to this, and yes, now I can see port 443, but port 80 still gives me an error. I am attributing this all to the 4 second reset. About to test the function to see if that cleared the problem, well ■■■■! Same message, "No Devices Available"

At least I can see port 443, but no port 80, but bottom line, same error message when trying to access from mycloud.com.

#23

Per the following Cox web page they DO “filter” inbound port 80.

Internet Ports Blocked or Restricted by Cox
http://www.cox.com/residential/support/internet/article.cox?articleId={cacf82f0-6407-11df-ccef-000000000000}

The workaround to a broadband provider blocking or filtering inbound port 80 (and port 443) is to use alternate port numbers; for example 8080 and 4443. One would reconfigure the My Cloud Dashboard > Settings > General > Cloud Access > Remote Access > Configure. Set the Connectivity to Manual and change the two External Port fields to alternate port numbers. One then would have to configure their router to port forward these alternate ports and forward the two alternate ports to the My Cloud.

#24

Can you give me an example in more detail. Right now I only have 443 https showing open. Port 80 does not show from those test sites. I do have access to my router, but don’t fully understand port forwarding and all the settings.

#25

As my posted alluded to above. Open the My Cloud Dashboard Then go to Settings then go to General then go to Cloud Access then go to Remote Access, and assuming Remote Access is set to ON, then click on the Configure link. The Cloud Access Connection Options dialog box should appear. On that dialog box one selects Manual, then one fills in an alternate value (for example 8080) for External Port 1 and an alternate value (for example 4443) for External Port 2. Then one clicks on the Save button.

When it comes to your router, you will have to search the interent for directions on how to setup port forwarding to the My Cloud using the same port values you used on the Cloud Access Connection Options dialog box screen.

One can see the My Cloud Dashboard Help > Home > Configuring My Cloud (Settings) > General > Configuring Connection Options for more information. And one can see My Cloud Dashboard Help >
Home > Configuring My Cloud (Settings) > General > Enabling Port Forwarding for more information.

The My Cloud User Manual (http://www.wdc.com/wdproducts/library/?id=439&type=25) also has a section in Chapter 9, Configuring Settings, Cloud Access that explains how to use the Manual setting for Cloud Access.

There is also the following WD Support document on port forwarding:

http://support.wdc.com/KnowledgeBase/answer.aspx?ID=8526

#26

Ok, I have setup port forwarding through Cox.

I accessed my wireless router through my browser and added Port Forwarding for port 80 and 443. I did as someone suggested in numbering so I now have ports 8080 and 4443. So, http, or port 80 has External settings as Start and End Port set to 8080, but the Internal Start and Stop ports are still set at 80. I set the IP address to the IP address of the My Cloud hard drive.

In the Settings menu under Cloud Access my Remote Access is on, and under Configure I have changed from Auto to Manual. The http External Port 1 is 8080 and the External Port 2 https is now 4443 to coincide with my router forwarding above.

Now, through the port check tool http://www.canyouseeme.org, I can now see my service on both ports, 8080, and 4443.

Now to mycloud.com and drum roll please!!???

Yup, same error: No Devices Available

Next?

#27

Why did you leave it at 80? The inside port forwarded numbers of the router have to the the exact same as the External Port 1 and 2 numbers you input into the My Cloud.

Edit to add: Here is an example from my ISP’s router. I configure two custom entries for forwarding ports. The Global Port Range is (I assume) the external broadband ports, the Host Port is (I assume) the internal local network port. Your router will be different but the settings should be somewhat similar.

When a proper port forward connection has been established with the My Cloud, the My Cloud Dashboard Remote Access section should indicate the following:

Connection Status Connected  
Port forwarding connection established.
#28

I talked to Cox and that is what they instructed me to do. It appears to be working. I’m not sure why. I added another user and had external access through that user. So I don’t have access with my administrative user, but any others I add can see the hard drive. The Cox support person said that I wanted to change the External ports, but to leave the Internal ports alone. At this point I can use a port check tool and I have access to 8080 and 4443, but not 80 or 443. Bottom line, after about 6 hours of reading, changing settings, making calls and typing messages, I can now access the drive… simple. (slap to the forehead)

Thanks for your input.

#29

Port Forwarding should allow you to forward any external port to any internal port. They do not need to be the same number. It’s like a ‘port alias’.

#30

got exactly same problem, happened when changed name of device! done it hard reset (40 sec) , name of device are default like before but no luck!
tried few times logging by my browser google chrome and after while comes message on screen “no device’s available please contact with device owner or Admin user”
any suggestions?

#31

sorry is all ok now, after hard reset and new first step by mycloud.com/local start working again

#32

I had the same problem. I think WD wording on techie jargon is a little confusing.

I also knew this error had absolutely nothing to do with Port Forwarding. Why would it? (rhetorical)

If you are trying to remotely connect to your folders and files on your server via a web browser, such as a laptop away from home, a friend or clients computer, a library computer, an internet cafe, etc. You will likely find you cannot log in to mycloud.com with your admin account, you must set up a user account (it can use the same email as your admin though).

Its a little confusing, because you, like me, would think you could access everything with your admin account. Obviously not.

Thanks for bringing this topic up.

#33

Hi Phillip, I have a similar issue and noticed that the time stamp in the settings is way off and I cannot figure out how to manually adjust it? Is your time on the cloud showing correct? Mine is still in April 2017? I cannot talk to mycloud unless it is directly connected to my computer, not even via wifi? Any suggestions? I hope this might help you?
Alan

#34

Have you enabled the NTP service?

If so, is it pointing to an active NTP server? Is it connected to the internet?

#35

I bumped into this Dilemma myself and without calling WD as it was 4am in the morning I managed to workout the confusing issue behind all of this and yet it is so simple, so here it is…YOU HAVE NOT YET OFFICIALLY CREATED AND LINKED THE DEVICE TO A MY CLOUD ACCOUNT! LOL.

As much as having your drive set up with your local home network which is currently visible by your network you need to now visit your drives online dashboard in order to create and link your device to a my cloud account via the cloud access tab within the dashboard itself.

This can be done via:

  • Using a computer that is connected to the same network as the My Cloud device, launch a web browser

  • Enter either the name or IP Address of the My Cloud device into the URL field of the web browser.

Important: If the My Cloud device name was changed, please use that name instead of ‘WDMyCloud’.

Once on your Dashboard, simply navigate to the cloud access tab on the top menu, click on your drive in the list on the left hand side pane and fill in the my cloud account section. You will then be emailed a validation link to whatever email you have provided where you then need to click on the link within this email link to sign in for the first time in order to validate your my cloud account officially and have your device officially linked to my cloud.

Once all the above has been covered then WALA, you can now sign in and view your device as visible on your my mycloud.com account when signing in as much as downloading and dealing with your drive via the WD Sync and App installer apps on your MAC or PC.

I hope this helps all of you and saves many hours and or days pulling your hairs out from intense frustration.

Your welcome and Best Regards,

Chamakh :stuck_out_tongue:

#36

Btw: links to dashboard if you haven’t changed the name of your drive via both Windows or Mac OSX are as followed: