No Devices Available

Hi All,

when I go to and put in my email address I am showing no devices available.

Also, when I try to get to use the desktop app WD My Cloud Public it says it can not find the public share.

However when I ftp to the device everything is fine. I have tried the firmware upgrade etc.

I found some other articles on here with the same problem but I did not undestand the solutions. It looks like these people have deleted their account on the device and recreated them in some way.

I have tried to create new access codes but because there is no device showing there is no entry point for the access code.

So kind of wondering how I establish a new entry in for my access and for the access the other people who I want to have access to the device.

It seems strange there is not some routine way to correct this problem that can be easily found. It seems others have had the same problem.

All pointers to any articles how to fix this most welcome!

Thanks in advance


Hello there, Try to disable remote access from the dashboard and rebooting the device and then re enabling it, i have tried this and sometime it helps me out.

If you tried this and it did not work for you then i recommend contacting support: