WD2GO - No device available

I’ve seen one other post on this and similar posts in other boards but haven’t been able to find the answer.

when I sign in to WD2GO.com, I get the message “No Device Available”.

This was working when I first got the drive but then stopped working after a firmware update.

I’ve tried, resetting the device but it didn’t help. I can’t delete my account because I’m the administrator.

Any other Ideas?


Hello, welcome to the community.

I’ve had this in the past, and I solve it by setting a static ip addres on my drive and manually forwarding the ports in my router. But before trying this, are you able to access the drive from the mobile aps while on your local network?

Yes, I can access it by the mobile apps and through my home network.

I’ve tried a lot of the solutions that have been printed elsewhere but none of them seem to help. It was working fine until the drive did a firmware update about 6 months back then it stopped working.

Thanks for any help.

so many possibilities but since you mention a FW upgrade I would start with a system only restore, this will leave shares and data in place but everything else is reset like new so you need to redo everything else. this can clear up a lot of issues