No devices found in wd2go

Hello all,

So recentely I’ve changed the static IP of my “my cloud” because of certain problems.

After changing the IP, I can still connect to it in my local network. However,  I cannot connect from remote network (from wd2go web).

Then I remove the device in the wd2go account, hoping that it can be added again later with the newest ip address.

But apparently, I cannot add any device to the wd2go account. Now that account does not have any device in it.

Therefore, I cannot open the cloud from anywhere, except my home network, which make it kinda useless.

I can still access the “my cloud” in my local network. I can also open the dashboard.

However, when I use the “wd my cloud” application" it shows this kind of message:


Do any of you know how to fixed this? I’ve contacted wd to restore the device in my account, but there is no reply to that.

If this cannot be restored, I will returne this device. Not much use as a normal external storage.

Thanks in advance.

Pheasant wrote:

 it shows this kind of message:



What’s showing you that message?   The Web Dashboard, or something else?

Thanks for the reply,

it was the application “wd my cloud”.

This program is installed at the same time as dashboard, learning center, and coud public share.

Log in via the Web UI and try adding the device back into the cloud from there.

That’s the thing.

How can I add the device back in the web UI ?

there is no such option there.

Are you trying to connect through or the My Cloud App? What type of device are you using, desktop, laptop, tablet, cell phone etc.?

If you are using the My Cloud App have you tried creating a new shortcut? See image below. Click on Start>All Programs>Western Digital>WD My Cloud then do a right click on WD My Cloud and Send To►Desktop (create shortcut).

Posted by,
cat0w (USA)

I tried to use both the “” and the " mycloud app" . 

The device that I’m using it on is a Laptop.

Basically, this happened because I clicked the “remove device” in the, as what is shown in the picture.

Now, When I login to to the, this is what I get.

and when I log in to mycloud app in my laptop, here is what i get

after I push enter, the error pop out

I think this is related to the event in which I delete my device in the wd2go. Does anybody now how to add a device again in the ?


Re-pair it with an activation code.