WD My Cloud 4TB connects fine on local network but no devices can access remotely

Hi everyine

I have set up my WD My Cloud at home and when connected to the LAN (via WiFi) everything is fine. I went out today and tried to access using my laptop (through the browser and the desktop application) and also my iPhone (through the iPhone application) and none of the devices could access the WD My Cloud. I had already downloaded and tried the apps at home before I went out and all was working fine.

Now I am back at home, on the same WiFi network, everything is fine. The firmware on the device is the latest (WDMyCloud v04.01.00-408 : Core F/W) and Java has also been updated to the latest version. Does anyone have any suggestions that might help please?

Thanks for reading :slight_smile:

Hello,

Take a look at this link. It is a guide created by another user about troubleshooting remote connectivity.

http://community.wd.com/t5/WD-My-Cloud/HOW-TO-Troubleshooting-Remote-Connectivity-Issues/m-p/617261#U617261

1 Like

Thanks - I have started working through this and have got as far as step 5.  I am not sure how to work out the External Port 1 and External Port 2 numbers.  I do have this option in my router control panel:

When I click Apply I get this:

I haven’t tried this yet - does this look like it is what I need to do to get remote access working?

Thanks

Do not proceed with this if you don’t know what you’re doing. This is DMZ mode. If you do, your nas will be open widely to the internet.

Look for port forwarding functions in your router menu and just setup to forward ports 9080 and 9443 to your wdmycloud’s local ip.

Or look for upnp function in your router and enable it then toggle the cloud access off and on again in wdmycloud’s dashboard settings. 

1 Like

Thanks for the advice.  The settings in my router seem to show that UPNP is enabled, it always has been:

I have found the section for port forwarding:

Where the drop down menu shows “Any” I can select a protocol - either TCP or UDP, which should I choose, or should I leave it as “Any”?

And do you  have any advice what information I should include in the rest of the boxes, how shoudl this read?  Sorry, networking is not my strong point at all!

Thanks

I can’t see your screenshot yet till the mods approved the pics.

The port forwarding protocol, it must be TCP.

But since your router has already upnp enabled, go back to your wdmycloud’s dashboard settings, toggle the cloud access->remote access off (wait few secs) then on again. You should be able to access your cloud remotely if there’s no error.

1 Like

Thanks - I have done this and see the following:

cloud access.PNG

I will try this shortyl when I am out and see if I can access, and will post back :slight_smile:

Need not wait till you’re outside :smileyvery-happy:

Off the wifi on your iphone and try the app on modile network…

1 Like

Aha yes good point.  Unfortunately it isn’t working - on my iPhone I get a message saying:

Device Offline

WDMyCloud is not accessible.  Local documents are available.

If I take my laptop off of WiFi and tether it to my iPhone, then try to access via the WD My Cloud desktop app I get this:

These are the same errors I have been getting since I installed.  Not sure what to do next?

Try setting the port forwarding manually. I don’t know what is your router brand and model, but I’m guessing see below:

  1. From your previous router screenshot (I can’t see the 2nd port forwarding screenshot as the mods still haven’t approved) go to, “Game & Application Sharing” -> “Assigned Games & Applications” -> click the link " ‘click here’ to create it ". It should ask for few things, like new name, device IP, ports and protocols. Give it a new name of your choice ie. wdmycloud. Then the device IP should be your wdmycloud’s lan IP. Set the port to 9080 TCP. If it allows multiple ports, give another 9443 TCP, else repeat the steps to add another port 9443 TCP.

  2. Go to your wdmycloud’s dashboard “Settings” -> “General” -> click “configure” -> select “Connectivity=manual” -> input “External Port 1 (HTTP)= 9080” -> input “External Port 2 (HTTPS)= 9443” -> click save. Toggle the remote access off then on again.

  3. Use your iphone mobile network to test again.

If it still doesn’t work, we need to review your router’s port forwarding page and the “Connection Status” of your wdmycloud dashboard -> settings. Upload the screenshot elsewhere and post the links as it will takes time for them to appear here.

1 Like

The manual port forwarding has resolved the issue - thanks very much for your help and guidance!