Network Problems

I have had My Cloud 2TB Storage unit for almost a week and have been very impressed with both its operation and  speed, however whilst using either my desktop PC or Laptop in my home, I can access WD MyCloud with no problems.

I can even access my files with my iPad and my Smartphone as I would expect, so I must have set it up correctly, but when I took my laptop to another location some 15 miles away from home, I was connecting with local networks in a building I visited and NOT MyCloud - why?

At that location my smartphone picked up MyClous but my laptop didn’t. When I returned home, my  laptop correctly found MyCloud again. I really need my laptop to work away from home.

i am obviously new to this and need help…please!

Apologies:wink: if I’m stating the obvious…

1)On Dashboard while at home check settings - general to see if cloud access is disabled

  1. From the user manual page 60

Enabling Cloud Access for the WD My Cloud Device
To enable the WD My Cloud device for remote access and to check the status of its remote
connection(s), see page 76.
Enabling Cloud Access for a User
You can assign the user remote access rights to the WD My Cloud device via the
WDMyCloud website and from mobile devices.

  1. On the navigation bar, click Cloud Access to display the Configure Access page. The
    admin’s name has a check mark beside it to differentiate it from other users.
  1. Check id UPnP is enabled on your Router / Firewall

Thanks Peter,

As I quite new to this, it perhaps isn’t too obvious and thanks for your quick feedback.

I will work though the comments you mention and see how it goes.

Still trying to get my head around this ever advancing technology!

since the phone works remotely it sound like you have remote access setup.

how are you trying to access the mycloud from the laptop when remote? you either need the WD desktop app, which I recommend for remote access (generally not recomended for local access) or you need to go to the web site, i have had many issues with files larger then 200M with this