Help Unable to access wd mycloud locally since remote access was removed

Hi
pulling my hair out here, since the removal of remote access I am unable to access my wd mycloud on the network.
operating system is windows 10 pro
things tried up untill now include:- 40 second reset, smb 1 enabled, network set to private,
I am able to access settings by plugging directly into the wd mycloud and using browser and I can see all my shares (greyed out).
I have other network devices and they are all showing so it looks like its unique to the mycloud.
Any help greatly appreciated.
Chop Armstrong.

Is the My Cloud (not My Cloud Home since that’s a completely different device) connected directly to the main network router or gateway? Do not connect the My Cloud to a network extender, power line adapter or mesh network node device. Can you access the My Cloud Dashboard? How is the computer connected to the local network? Connect it directly to the same router the My Cloud is connected to. Do not use “guest” wifi if connecting wirelessly to the local network since guest wifi may block local network access or have client isolation enabled.

How to Access the Dashboard on a My Cloud (single bay) Device
https://support-en.wd.com/app/answers/detail/a_id/15104

What color is the front LED on the My Cloud?

As a troubleshooting step, disable any security/antivirus/firewall software on the affected computer. Sometimes those programs can block local network access to NAS devices like the My Cloud line of devices.

#WDUserRewards

@chopster

These are the steps I would use. With your My Cloud connected to your router as shown in the User Manual, reboot your router. After it reboots check to see what shows under Network. See example image below of mine on my router. Below that image see what is showing under Network for my desktop computer.

image

To open the Dashboard, use the address for your My Cloud. If you know how and must, look at your router to find the address. Be sure in Settings that internet connection is off!

To see your shares use the address shown below. See example image below.

image

Hi Bennor
Thanks for your reply, I can confirm it is a mycloud, it is connected to main router via ethernet cable, I can not access mycloud dash either via http://mycloud or via ip address (only way i can do this is connecting device to my pc directly) I have tried turning firewall off still no sign.

Make sure to do a 40 second reset as detailed in the following WD Knowledge Base Article:

How to Reset a My Cloud Device
https://support-en.wd.com/app/answers/detail/a_id/27402

What color is the front LED on the My Cloud? Is it blue or some other color?

With the My Cloud connected to the local network router, access that router’s administration page and check to see what IP address the router is handing out to the My Cloud or the address the My Cloud is obtaining from the router.

How is the computer connected to the local network? WiFi or Ethernet?

If you can access the My Cloud Dashboard, does the Diagnostics field indicate an error? Does the Alert icon (mycloudnotificationicon) indicate any errors? What firmware version does the My Cloud Dashboard indicate is installed? v4.x/v2.x or v5.x?

What other troubleshooting steps have you tried.

If one can access the My Cloud Dashboard, one may need to run a full test and or a system test on the hard drive to see if there are any drive issues. See the My Cloud Dashboard > Settings > Utilities > System Diagnostics.

#WDUserRewards

Hi Bennor
The front led is solid blue
, I have been unable to find the mycloud via my router page everything else is showing but no mycloud.
The computer & my cloud are both connected to the network via ethernet.
I can access the dashboard, but only when directly connected to the pc.
firmware version is v04.06.00-111
I am out at the moment but will be homw soon and try access the dashboard again, & i’ll get back to you ,Thanks for your help.

Hi Bennor
Well I have eventually got there, I reset the network adaptors (which wiped out all my wifi connections) however after googling & reinstating all connections, the mycloud once more showed in my network and all is good, thanks for all your help.

Hi cat0w
Thanks for taking the time to reply, I have eventually traced the problem to my network adaptors and after resetting all is well, thanks again.