PROBLEM accessing WD from internet

I can’t access to WD from internet (using Mycloud app) - it’s possible only when accessing from LAN. The problem occurs with windows app and android apps (mycloud and WD photos running cellular connection) as well. The remote access is turned on and port forwarding connection established (ports triggering is enabled in router (tplink) for ports: 80 and 1025 - I found out that my ISP blocks port 443). Also IP for WD is set up static. I’ve already tried this as a troubleshooting: [HOW-TO]: Troubleshooting Remote Connectivity Issues and found out that I can connect from internet on port 80, but get “ERR_CONNECTION_REFUSED” on port 1025 and some others that I tried (don’t know if that’s a problem). Please help me to estabilish cloud connection.

PORT 1025 (and some others I tried):

I’m having trouble with the OS3 firmware and android MyCloud app too, and I haven’t got to the bottom of it yet. One device (pre-OS3) connects okay in relay mode, a second device (OS3) doesn’t connect in port forwarding mode (which is set up correctly and shown as working in the Dashboard).

The android app doesn’t seem to know what it is doing, and its online help is out-of-date, referring to pre-OS3 behaviour.

I’ve deleted all connected services from both Dashboards and app, and created new connections with activation codes. The app will show both devices locally; now need to wait until I can go remote to see if the problem is fixed.

The MyCloud app certainly isn’t a model of UI clarity; in fact, it’s confusing rubbish. It’s possible to connect locally by logging in with device user credentials. This creates a ‘device connection’. It’s also possible to create a connection using an authorisation code. This creates another ‘device connection’. Both give the gmail ID of the tablet running the app, but the connections are indistinguishable on both Dashboard and app; how do I know which is local, and which is remote? If i connect locally, should that also enable remote access? Do I need both local and remote connections?

I found that I had to drop and re-add the My Cloud both in the WD Desktop program and on my Android mobile devices (both WD My Cloud app and WD Photos app) post OS 3 firmware update. So far, on the local network, not having a problem with access. Haven’t done much remote access offsite as I usually have remote access disabled within the Dashboard.

Well, the odd thing is that, immediately after installing OS3, and the revised android app, everything worked fine, and I was able to download stuff to my tablet. I know, because it’s still there in the WD MyCloud app folder, with the correct timestamp. Sadly, I lost my ‘system notes’ from that period when my main device got rather confused about what shares were called, and allowed me to rename one over the top of an existing one, destroying it…

Then it stopped working, and I don’t know why. I’ve been trying to fix it for over a week, but it’s a slow cycle, since I can’t do remote access at home (no, don’t have a data contract on my phone).

Okay… but the problem comes out not only on android apps but on desktop app also, which is much more important for me (can’t access files at work when being home.). Anybody knows solution?


I manage to connect to device from internet and download files from device when logging in via portal (browser).

Since upgrade Android version today (8-Nov-15) I cannot access the My Cloud using Internet (Only using LAN Connection is accessible).
Any issues can be solved by My Cloud Team?