24p playback issues

Should 24p playback on the WDTV be perfectly smooth? I’m running the latest firmware and experiencing frequent subtle but noticeable stutters with 24p output that I don’t experience with 60p. I haven’t done extensive testing, but it happens with 720p and 1080p 23.976fps mkv files and with 24fps files as well. In each case, switching to 60p fixes the problem. My television definitely supports 24p and I have no issues with my standalone Blu-ray player.

From googling it would appear that most media players suffer from one problem or another with 23.976 or 24fps playback. Does that include the WDTV? Do other people have these same issues with 24p playback? 

What happens when you set Match video framerate?

Setup > Audio/Video Output > Video Output > HDMI > Auto > Auto > On

Having match frame rate on or off makes no difference.

Sanjuro, I noticed this too. It was not happening before, saw it happening with new firmware. I watched Sinister, in MKV, 1080p, DTS Core and I saw stutters here and there. Not something tragic but still noticeable. As I said, no issues with older firmware. Are you on latest f/w?

Glad I’m not the only one.

Yeah I’m on the latest firmware, although I was experiencing it with the previous firmware as well.

So what does your TV show when you play 23.976 or 24 material? On Samsung I’m getting a @24 notification in both cases.

Yeah, my Sony just shows 24p as well. I think it’s the same for most HDTVs, they don’t tend to differentiate between 24fps and 23.976fps, although they are usually able to handle both. The vast majority of Blu-ray sourced material is 23.976fps.

The problem seems to be with the WDTV. I’d be interested to know if anyone experiences consistently smooth 24p playback with it, or if it’s only certain files or set-ups that causes problems.

My samsung tv always shows 24p but I have this stutter on all firmware starting from 1.03.10.

Match framerate on or of makes no difference.

We’ve been over this, with match framerate set to on it should work. Do these clips stutter for you?



Auto match frame rate is on.

I experience stuttering with the Iron Sky clip. I can’t really tell with the Ip Man clip as there’s a lot of cuts and static camera shots. 

Although it should be noted that both files are 24fps and I’m having this problem with 23.976fps mkvs as well.

I’ve had a WD TV Live for almost 3 years and recently picked up the newer Streaming model before Christmas when WD had a $50 cashback promotion here in Australia.

Connecting it to a Samsung 60E8000 model plasma which does not have any sort of motion interpolation (Panasonic call their version Intelligent Frame Creation), I observed the exact same behaviour as Sanjuro.

It didn’t happen on all 23.976 frame rate MKV files but happened often enough to make it unuseable. I would actually describe it as dropping frames rather than stuttering.

It happened with 720p and 1080p files.

The same behaviour was observed from an NFS network share and from a locally attached USB drive.

It happened with autoframe rate on or off (with it off and HDMI output set to 1080p/24).

It happened all on firmware versions that were available at the time from 1.08.17 to 1.12.14.

It didn’t happen when output was set to 1080p/60.

As a final test, I remuxed an offending test file from MKV to M2TS using tsmuxer and it played perfectly.

And, of course, the original MKV file played perfectly on the older Live model.

I have since passed the Streaming player to a friend who needed a new player for his kids and set it to 1080p/60 as they don’t care about the pulldown introduced when going from 23.976 to 60.

Sanjuro, perhaps you could also test remuxing to M2TS and see if it plays okay?


So can you mux a short clip with MKVToolnix and if it’s also dropping frames on your TV, upload to Mediafire so we can verify whether it stutters on our TVs too?

I’ve sent you a PM.

mankmeister wrote:


I have since passed the Streaming player to a friend who needed a new player for his kids and set it to 1080p/60 as they don’t care about the pulldown introduced when going from 23.976 to 60.



Pulldown? What pulldown?

Thanks, mankmeister, your post clarified a few things.

I remuxed a couple of previously troublesome 23.976fps MKV files to M2TS and they played back perfectly. No dropped/duplicated frames. However, remuxing to M2TS doesn’t seem to work for 24fps MKVs, or at least it didn’t work for the one I tried, though I may need to do more testing.

I can also confirm that the problem doesn’t affect all 23.976 files or even all MKV files. I’ve tested several 23.976fps AVI files which played back perfectly at 1080p/24hz.

I will also try the mankmeister solution. Never used tsMuxer. Annoying thing is that out of the box, you want MKVs to play properly in 24p. My Panny VT30 plays everything without issues from other sources. Seems that something in those new MKVs is not WDTV gen3 friendly. Annoying… BTW, here’s some media info from something i watched yesterday and the stutter was really really bad:

Unique ID : 219944032448937801359720385095003436784 (0xA577AE0891EF5DBBBA4341AAF20676F0)
Complete name : MyDriveLetter:\whatever\HDMovies\The.Collection.2012.720p.BluRay.x264-DAA\daa-the.collection-720p.mkv
Format : Matroska
Format version : Version 4 / Version 2
File size : 4.37 GiB
Duration : 1h 21mn
Overall bit rate : 7 666 Kbps
Encoded date : UTC 2013-01-25 23:06:14
Writing application : mkvmerge v6.0.0 ('Coming Up For Air') built on Jan 20 2013 09:52:00
Writing library : libebml v1.3.0 + libmatroska v1.4.0

ID : 2
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.1
Format settings, CABAC : Yes
Format settings, ReFrames : 5 frames
Duration : 1h 21mn
Bit rate : 6 155 Kbps
Width : 1 280 pixels
Height : 536 pixels
Display aspect ratio : 2.40:1
Frame rate mode : Constant
Frame rate : 24.000 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.374
Stream size : 3.42 GiB (78%)
Writing library : x264 core 129 r2245kMod bc13772
Encoding settings : cabac=1 / ref=5 / deblock=1:0:0 / analyse=0x3:0x133 / me=umh / subme=7 / psy=1 / fade_compensate=0.00 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=18 / lookahead_threads=3 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=24 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=2pass / mbtree=1 / bitrate=6155 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / aq=1:1.00
Default : Yes
Forced : No

ID : 1
Format : DTS
Format/Info : Digital Theater Systems
Mode : 16
Format settings, Endianness : Big
Codec ID : A_DTS
Duration : 1h 21mn
Bit rate mode : Constant
Bit rate : 1 509 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 48.0 KHz
Bit depth : 16 bits
Compression mode : Lossy
Stream size : 881 MiB (20%)
Default : Yes
Forced : No

00:00:00.000 : en:00:00:00.000
00:06:29.375 : en:00:06:29.375
00:15:08.875 : en:00:15:08.875
00:22:12.791 : en:00:22:12.791
00:30:06.958 : en:00:30:06.958
00:37:45.750 : en:00:37:45.750
00:45:24.500 : en:00:45:24.500
00:53:11.875 : en:00:53:11.875
00:58:20.375 : en:00:58:20.375
01:04:21.833 : en:01:04:21.833
01:10:12.208 : en:01:10:12.208
01:16:16.583 : en:01:16:16.583

Vertical, have you tried the first clip I linked to? Does it stutter on yoyur TV?

Yes it does. When the the spaceship approaches ths plant (not when landing but when it is flying), I see a small break in the picture. Checked in my PC and there’s no such thing.

Honestly, never had issues on 24p in the past. Yesterday I watched another new movie, and stutter like **bleep**…

Just thinking if WDTV PAL/NTSC makes a difference here.

I had several 23.976 fps clips but had a PAL system.

I played those clip through my laptop via HDMI was real smooth.

With WDTV (PAL) it was ok, but can see bits of choppy comparing with laptop quality.

Laptop I used Roxio player FYI

I have read that PAL version could never match 23.976 FPS clips.

Is that true?

On my PAL CRT 23.976 runs fine without any stutter.> * * *
vertical wrote:
Yesterday I watched another new movie, and stutter like **bleep**…

Can you upload a clip to Mediafire?