New Release - WD TV Live Firmware Version 1.06.43 (1/17/13)

Just for you guys to know, we are looking more closely at what can work with the rollback issue.  No promises, but I should have something soon.

richUK wrote:
mavhun - you obviously did not read the first post from WD.

Very Important: Rolling back to version 1.05.04 or earlier may break your WDTV.

Note the word ‘may’, they removed the old firmware because they found in testing that it could break the player.
I also assume that you were not on the latest firmware when you rolled back to 1.04.22 or your ver edit would not have worked.
As a warning to others you should not attempt to install any firmware from the GPL page mentioned above as this will damage your player.

Rich, I know of people who rolled back their Live Plus beyond the “authorized” rollback version (to rollback version 1.05.04) and their Plus did not brick, and it lived to see another day – and beyond.

That said, everyone is on his own here – no guarantees.

EDIT:    At this point, I find it helpful to make it much easier for folks to locate the two rollback versions of FW 1.05.04 – it is a very stable version for both units.  (It’s been on my Live Plus well over a year, now.) 

Here below, are the official names of the rollback FW; Google search the filename you want to download and you will get lots of hits. 

Remember to rollback to the “Official WD recommended” firmware beforehand.  Know, too, that no tweaking of rollback VER file needs to be done – it is baked into the cake, so just run it.

I am posting this info, because I want to encourage WD to repost this stuff so people do not have to scrounge around googling for the previous FW, and instead, they can download it directly from WD. 

For the Live Plus – google for file named

For the older  Live – google for file named

Good luck to those who go forward with this rollback!

Report back here how it went for you.

My post was really replying to the question ‘why would WD remove the old firmwares’, I was explaining the reason. I do note that a number of people have rolled back without any problems but I must also assume that WD did find some reason to remove the old firmwares. One of the posters links was to the GPL page where you can download code which can be installed on the player, however if you use this code it most certainly will damage your player and that’s why I posted the other warning.


   replying to the question ‘why would WD remove the old firmwares’

Perhaps it was due to “over confidence” , that THIS time, they got it right! 

To the folks working in the WD Firmware Repair Division:  Keep trying and get it right soon (otherwise you might not work at WD too much longer.)   :wink:    (Sorry, couldn’t resist – “The Devil made me do it”.)

New firmware release still no support on replaygain. Not happy…When do you think WD will release new firmware supporting replaygain. I hate always turning the volume of my receiver.

mike27oct wrote:
At this point, I find it helpful to make it much easier for folks to locate the two rollback versions of FW 1.05.04

It would be really easy for people if WD

a) would keep all firmwares for a model in one page (with notes on what fw not to downgrade to)

b) change the update process allowing rollbacks without manipulated ver files

The new firmware message would of course only pop up when a higher number is found online (and could also be turned off as with the SMP). That way people could go from version to version easily.

Since we’e still trying to suss out the 24p problem I’ve rolled back from 1.06.34 to 1.06.15 and from there to 1.2.21 (the last firmware where 23.976 could be set manually) without any problems.

I’ve finally solved the problem of risking my Live box with the “unrevertable” latest release; boy am I glad I resisted the update.  I bought a used Live with 1.06.43V already on it (I needed a second unit for another TV). 

Simply put , “BOOOOO…”    Here is my experience, with the unit connected via HDMI to a Sharp LC37D90U (1080p LCD, 60Hz).  Wired connection to my LAN, IOMega 1T USB hard drive with some movies connected to rear USB port.

  • On power up, the WD logo comes up and screen blanks,  left LED stays on much longer (maybe 3 times the wait of 1.05.04V).  The right LED starts flashing while it finds the USB drive, which takes about 2 times longer than with 1.05.04V.  Annoying but tolerable
  • I set up the Network connection;  auto Address, my LAN workgroup, new name for this box (to be different from my other one).  At this point, my existing Live is not ON in case there’s any conflict.  Connection check - first problem - It gets an IP address OK but complains that the DNS server address is invalid even though in the network setup menu  IT DISPLAYS A VALID IP ADDRESS AND CORRECT DNS ADDRESS!!
  • Performed Factory Default Reset, then Connection Check again; still complaining about invalid DNS. Unplugged the unit and went and checked my other one; the DNS address is identical, and that Live (1.05.04V) has never had a problem with the network
  • Shut off my first Live and went back to the new one.  Playing a hunch, set Network mode to manual, set an IP adress outside of my LANs DHCP range, left the DNS setting as-is since it was correct.  Performed a paper-clip reset.  The Connection test now passes WITH THE SAME DNS ADDRESS AS BEFORE!!
  • Set the Network mode back to Auto, restarted and confirmed that the Live IPaddress changed back to the one I first saw.  Now, however, Connection Check passes WITH ALL THE SAME ADDRESSES DISPLAYED THAT WERE FAILING EARLIER!.  The unit continues to work after several power-off cycles.
  • Checked YouTube access - second problem ;  It freezes with the new Leanback logo for minutes without the progress bar moving - FAIL!  I’ve got a networked Bluray player that runs Leanback and the progress bar takes maybe 10 seconds to sweep across and open the app.  I quickly checked Accuweather; no problem reaching the internet, so it’s not my network
  • Checked the MKV jitter problem that I hoped would be fixed: - third problem.   no sign of it on my second TV, but it doesn’t support 24Hz.  I moved the box to my main TV that does 24Hz; confirmed auto-framerate is working.  However, the same MKV that jitters on 1.05.04V still does under 1.06.43V.  I will be reverting this Live back to 1.05.04V since I want YouTube to work

Brief analysis of each problem:

1 - Invalid DNS :  Here I’m not sure if setting to manual or the paper clip reset fixed it.  The key point however is that the unit was lying to me;  it showed identical network settings (IP, mask, DNS) when it first was failing with auto IP mode, as it does now while its still working under auto mode.  I don’t know how long it will last; maybe it’ll fail again when the IP lease expires.  I probably won’t know since this puppy is going to be reloaded with 1.05.04V (the “brick” potential is no longer a threat to household peace)

2 - YouTube:  This is just shameful WD!  No amount of power, paper-clip, or factory reload resets appear to correct this.  What’s the problem here? I note several other WD Live owners on this forum with the same complaint.  Is there a hardware revision problem?  Do I have to have a YouTube account to use this app?  If so, VERY LAME!  Bring back the version you had in 1.05.04V; it has some quirks but is useable and it ALWAYS WORKS!

3- (24p) MKV jitter:  I discovered this in 1.05.04V and have been hoping it got fixed.  Appears it didn’t, and from some other threads on this forum (thanks for the link techflaws), looks like its a problem with the Live Streaming too.  The new thing uncovered here is that it appears to only happen with 24p capable TVs.  There was no sign of the jitter on my older 60Hz set I started testing with.  The symptom is that the video exhibits a jitter, as if skipping a frame periodically.  When I toggle the pause button, I discovered that I could find a “phase” where the file plays smoothly.  Some files play fine from that point to the end as long as you don’t pause them.  If you pause, you have to hunt for the correct “phase” again, luckily from the pause point and not from the beginning of the film.  Other files will pop out of phase at major scene changes, requiring one to hunt the smooth phase with the pause.  The MKVs were created from VOB files using Handbrake, .264 coded at 24p rate.  I also tried the same file in an MP4 container, but the same thing happens, which starts to look like a CODEC issue.   I had mentioned this in another thread some time ago but wasn’t sure if it was the file or the player, plus 1.05.04V had already been obsolete.  I guess this is now a legitimate problem to log against 1.06.43V, and I hope WD fixes it (along with the other issues) in a future update.

@ RPH_16by9

All very interesting.  Thanks for the analysis – hope WD folks read it, too.

As for MKV jitter:  I run v1.05.04 on my Plus. NO problemo with MKVs; even on my 24p Panasonic TV.  I do not use Handbrake to make my MKV files.  I use AnyDVD HD to make an ISO file, and from the ISO I use ByteCopy to create the MKV.  They are perfect.  So, the problem you are experiencing is not from the firmware, but from Handbrake, I presume.

I use Handbrake to create m4v files from ISO files for streaming and viewing on the iPad.  I use the default setting for iPad.  They work great on iPad, but if viewed on TV there are issues with slight jitter and some graininess.  Big deal; they were not made for TV viewing; they were made as much smaller files for the iPad, and they are sufficient for that platform (the iPad is a Gen 3 w/1080p).


slish76 wrote:


I would like to know to which firmware can I rollback since the latest shows to have much more problems than the earlier one…

Slow boot up

Slow start on play.

It hangs playing simple avi files.

It just works with internet radio

You need to read back a few pages where we discuss v1.05.04 as a stable version.  Go back 3 or 4 pages at least…

ok, thanks a lot =)

Not happy to say, this “new” release is a [Deleted]

Never again will buy any product of wd.

Very same problems here.

Never again will buy a wd product. 

It is a promise I made to myself.

A quick update on my second Live player;  I’ve stepped it back to 1.06.15V in preparation for final jump back to 1.05.04V.  The DNS problem did not show up, and YouTube (non-leanback) works perfectly just like my 1.05.04V box.  I am rethinking stepping back to 1.05.04V since this TV only supports 60Hz anyways so auto match-framerate is meaningless i.e.: doesn’t matter if it is not working in this load.

On the 24Hz jitter front, I did a lot of web surfing regarding this topic;  a LOT of players out there have problems handling 24Hz coded material, with symptoms that range from the subtle that I have experienced up to completely unwatchable.  On the Handbrake forum, there was mention in a few threads of jitter-judder-strobe, whatever you want to call it. Many found the same thing I did, that is, the files play fine on a PC (VLC typically), pointing fault away from  Handbrake and towards the players.  Several users found that setting “Constant Frame Rate” cleaned everything up, but, reported by a few, caused the audio to gradually lose sync through a movie. 

So I tried it .  I recoded the same VOB files that were exhibiting the problem I described, this time with CFR checked.  The source file was coded at 59.94Hz , so I picked 23.976Hz as the target file frame rate.  Choosing 24Hz here may cause the audio desync problem but I haven’t checked.  The final file size with CFR is only slightly larger than without, and yields nice smooth playback on the Live without the pause-phase effect.  I’m tempted to bring the player back up to 1.06.43V, but the YouTube mess is a showstopper for me.

@RPH- Im trying to drum up some interest in getting Wd to give us back the youtube classic player and not this leanback garbage…please post here:

With reference to the jitter problems with some 23.976fps mkvs on some TVs, (mine a Samsung 24p capableTV)  I came to the conclusion it was the way they were encoded and then muxed,

The reason I suspect this is that the files that play without jitter were muxed with Mkvmerge. (I use MeGui to produce MKVs which muxes the streams with Mkvmerge and have never had problems.)

To test I remuxed the problem MKVs with Mkvmerge. This gets rid of the jitters and you get smooth playback, BUT it introduces some video/audio sync problems.

I decided to experiment with various settings on the WDTV box. I am still on version Version 1.04.22_V as that works for me, apart from the problem I am discussing here.

What I found that seemed to work is going into settings and turning OFF “match video framerate”. The few MKVs I tried seemed to play OK with no jitter and no a/v sync problems.

Maybe those on the latest firmware with this problem could see if that works for them?


In case anyone is following this…

As an addendum to my previous post I found 2 other solutions that seemed to work for the files I have problems with.

I demuxed the a/v files, reencoded the ac3 audio (using Aften AC3 in MeGui) with a 100ms delay. Remuxed with Mkvmerge and plays OK

The other solution for those who have VideoRedo TVSuite 4 H.264 beta just resave it with the 100ms delay and plays OK too, no jitter.


PS I would confirm tho that this jitter problem is not present when playing the same MKV files using dnla on my Samsung TV BUT the picture quality through the WDTV Live is far superior.

I’ve had not files out of sync after muxing to MKV, ever. There is some judder though and contrary to your findings, so far the only thing that seems to help is remux to m2ts.

I have based my experince on those MKV files I have had problems with so your experince may vary depending on the files you are trying to play.


jspitz wrote:

I updated from 1.06.15 to 1.06.43 to find a major problem.  I use the WDTV Live at 1080i component through a Sony ES receiver, plugged into a ~12 year old Toshiba CRT TV.  Every single time the WDTV is turned off, the video reverts back to composite.  After I re-configure the WDTV to use component video, it performs perfectly fine … until it is powered off again.

I’m experiencing the same problem with the component setting reverting to composite after a power cycle.