WDTV Live SMP > Jerky Playback on ALL Files with VC-1 Codec :((

^^very weird with that VC-1 issue, looks like R_Strev got same problem :dizzy_face:

I have uploaded the Legacy Theme from the Hub on my SMP device and on every startup shows me WDTV Live HUB hope there is no connection with that problem:smileyvery-happy:

I can remember the First Time I archieved my Discs to hardrive using makemkv caused errors in form of audio sync issues on every file (right from the beginnging) on with my WDTV gen2 personally dont use makemkv anymore :smiley:

trying to cange the container format  mt2s first, will report then:wink:

ok, changed a movie from mkv to mt2s container (with extactly the same content inside) and now Playback is fine as is should be, but on 25 gb File the mt2s Container is about 1,3 gb larger than the same content in an MKV Container very annoying -.-

I Don’t like this unnecessary waste of HDD Space:cry:there coming some gigs together…lost space:confounded:

Techflaws: You told me that you haven’t git Jerky Playback with VC-1 Files on your device which Firmware Version do you got and which tool are u using to Rip BD’s:smiley:

I will also try going back to fetch back the primary Mochi Theme insteadt of Legacy Theme maybe this caused this Problem too i don’t know everything possible on this device:smileyvery-happy:

“Themes” will not affect video playback  (they only change the appearance of the GUI)

I have quite a few blu-ray rips to MKV files that have VC1 video.  Never had any problems when playing any of them.  They were all ripped from blu-rays using MakeMKV.  Think I have SMP set on auto currently, so 24FPS sources play at 1080p-24.  Samsung TV.  Don’t really know what to suggest.

hmm thats really strange… for some people VC1 works on MKV but for me of course not -,-

maybe i should try antother (older) firwmare or maybe i should try another (newer) version of mkvtoolnix still using 4.3.0:confounded:

I’m using MakeMKV and MKVToolnix 5.8.0 where necessary. I’m merely pointing that out your problem does not necessarily have to be related to the VC-1 codec but to a general 24 FPS problem WD is trying to fix. You could upload a small sample clip (split with MKVToolnix) to sendspace.com so we can try it on our equipment.

Every other BD with AVC Codec runs fine with 24p and my TV definatly supports it:wink:

It not runs perfectly smooth but nearly (almost good enough to live with it) but i mean on my old gen.2 playback was marginally smoother but up close, the Jerky Playback i have only with the VC-1 Files is something different it shrugs every 2-3 seconds  :dizzy_face:

Here is a sample-clip

 
 

Ok, first I think you are confusing FPS (frames per second) and Hz (refresh rate).  Having a file that is 24p doesn’t mean that your TV or SMP Hz should be @ 24Hz.

Second, you say that the issue is with mkvs that you muxed with mkvtoolnix, but goes away with you convert to m2ts. So most likely the issue is with how your are muxing the video.

So here’s what you can do.  Since you are using AnyDvd, take one of the videos you are having issues with and  create an ISO with ImgBurn.  Then check to see if have the same issue with the ISO.

If you don’t, then use MediaInfo to get the info of both the ISO and the offending mkv and post both here.

Tinwarble - if what you say is true why does the TV change to 24hz when you play a 24fps film and you have match frame rate on?

Well, that’s a long complicated answer, something that I just don’t have time to go into.  Yes, your TV shows 24Hz, but it’s not displaying the video at 24fp, that’s only what the TV is receiving.  And I’m not even going to get into that, for that you can see the post here: http://forum.blu-ray.com/showthread.php?t=209386

But as I said, the problem is most likely in how the video is muxed considering that the mkv is jerky, but the m2ts isn’t.

You said “Having a file that is 24p doesn’t mean that your TV or SMP Hz should be @ 24Hz.”
I simply asked why the player changes my TV to 24Hz when I play a 24fps video if what you say is true.
Should the player change the TV or not?

Of course it should. There’s still some judder however, cause this feature does not work as it should ATM.

Tinwarble: I don’t know what i’m doing wrong merging Video and Audio to mkv together using mkvtoolnix, like usually i never change the framerate or something i just select to Play both tracks (V + A) as Forced Titles and and disable the Header Compression I’m doing so for years now the same way with mkvtoolnix and ALL these Files even with AVC or VC-1 play Fine on my old gen.2 device:wink:

I have to correct: The Faulty Playback on the SMP with VC1 Files is not every 3 Seconds its every 1 second I get an hard shrug/jerk on the Playback:cry:

Has anyone checked the sample?

Not yet, probably will make it tonight. Try this in the meatime.

ok^^ i try it,  will report back then:wink:

Your clip is a bit short. There’s a bit judder for me but no way as bad as in my clip (check the tricycle when it’s moving out of the picture and the skull at the end). However, since both clips run just fine when muxed to m2ts, it’s not related to VC-1 (you have set match framerate to on, right?).

yeah, sorry about that short clip (my internet connection is not the best took me 20 minutes to upload it - i can upload another sample for you if you want me to:wink:

I just tried your sample (thank you for that:smiley:) and it runs great !!! :smileyvery-happy: thats exactly how its should be:wink:

I recorded it with my Camera, this is the way Your sample looks like:

>> Smooth

And this is the Way my VC-1 Files look like (jerky)

>> not Smooth

^^this is how it goes the whole entire Movie long:cry:

My Video Settings are set on 1080p, 24hz on default > no changes.

How can I make my MKV VC1-Files run like yours, plz tell me the Secret:smileyvery-happy:

Not much to say. I ripped the movie with MakeMKV and split the file with MKVToolnix.

Did you ever figure this out? I am having the same issue… VC-1 MKV stutters right from the beginning of playing.

I am playing from a connected USB HDD

So I figured out my problem, I tried the following:

  • Playing over NAS Network share (wired Qnap) Skipped less but still skipped.

  • Playing off different External HDD (WD My Book) Skipped just as bad

I switched to the front USB port, everything runs perfect\ with either the Seagate or the WD drive.

What is with this? Faulty USB port? A Firmware driver issue?