New Release - WD TV Live Firmware Version 1.06.43 (1/17/13)

Very same problems here.

Never again will buy a wd product. 

It is a promise I made to myself.

A quick update on my second Live player;  I’ve stepped it back to 1.06.15V in preparation for final jump back to 1.05.04V.  The DNS problem did not show up, and YouTube (non-leanback) works perfectly just like my 1.05.04V box.  I am rethinking stepping back to 1.05.04V since this TV only supports 60Hz anyways so auto match-framerate is meaningless i.e.: doesn’t matter if it is not working in this load.

On the 24Hz jitter front, I did a lot of web surfing regarding this topic;  a LOT of players out there have problems handling 24Hz coded material, with symptoms that range from the subtle that I have experienced up to completely unwatchable.  On the Handbrake forum, there was mention in a few threads of jitter-judder-strobe, whatever you want to call it. Many found the same thing I did, that is, the files play fine on a PC (VLC typically), pointing fault away from  Handbrake and towards the players.  Several users found that setting “Constant Frame Rate” cleaned everything up, but, reported by a few, caused the audio to gradually lose sync through a movie. 

So I tried it .  I recoded the same VOB files that were exhibiting the problem I described, this time with CFR checked.  The source file was coded at 59.94Hz , so I picked 23.976Hz as the target file frame rate.  Choosing 24Hz here may cause the audio desync problem but I haven’t checked.  The final file size with CFR is only slightly larger than without, and yields nice smooth playback on the Live without the pause-phase effect.  I’m tempted to bring the player back up to 1.06.43V, but the YouTube mess is a showstopper for me.

@RPH- Im trying to drum up some interest in getting Wd to give us back the youtube classic player and not this leanback garbage…please post here:

http://community.wdc.com/t5/WD-TV-Live-Firmware-Networking/WD-TV-Live-Youtube-Petition/td-p/540335

With reference to the jitter problems with some 23.976fps mkvs on some TVs, (mine a Samsung 24p capableTV)  I came to the conclusion it was the way they were encoded and then muxed,

The reason I suspect this is that the files that play without jitter were muxed with Mkvmerge. (I use MeGui to produce MKVs which muxes the streams with Mkvmerge and have never had problems.)

To test I remuxed the problem MKVs with Mkvmerge. This gets rid of the jitters and you get smooth playback, BUT it introduces some video/audio sync problems.

I decided to experiment with various settings on the WDTV box. I am still on version Version 1.04.22_V as that works for me, apart from the problem I am discussing here.

What I found that seemed to work is going into settings and turning OFF “match video framerate”. The few MKVs I tried seemed to play OK with no jitter and no a/v sync problems.

Maybe those on the latest firmware with this problem could see if that works for them?

Barry

In case anyone is following this…

As an addendum to my previous post I found 2 other solutions that seemed to work for the files I have problems with.

I demuxed the a/v files, reencoded the ac3 audio (using Aften AC3 in MeGui) with a 100ms delay. Remuxed with Mkvmerge and plays OK

The other solution for those who have VideoRedo TVSuite 4 H.264 beta just resave it with the 100ms delay and plays OK too, no jitter.

Barry

PS I would confirm tho that this jitter problem is not present when playing the same MKV files using dnla on my Samsung TV BUT the picture quality through the WDTV Live is far superior.

I’ve had not files out of sync after muxing to MKV, ever. There is some judder though and contrary to your findings, so far the only thing that seems to help is remux to m2ts.

I have based my experince on those MKV files I have had problems with so your experince may vary depending on the files you are trying to play.

Barry

jspitz wrote:

I updated from 1.06.15 to 1.06.43 to find a major problem.  I use the WDTV Live at 1080i component through a Sony ES receiver, plugged into a ~12 year old Toshiba CRT TV.  Every single time the WDTV is turned off, the video reverts back to composite.  After I re-configure the WDTV to use component video, it performs perfectly fine … until it is powered off again.

I’m experiencing the same problem with the component setting reverting to composite after a power cycle.

Don’t change the subject title please.

barrygreybeard wrote:

I have based my experince on those MKV files I have had problems with so your experince may vary depending on the files you are trying to play.

Obviously. Still you’re the first one complaining about out of sync MKVs so I really doubt it’s a firmware bug.

richUK wrote:
Don’t change the subject title please.

Why?

Apologies if I violated some perception of decorum, but the forum posting instructions from 2009 ( http://community.wdc.com/t5/New-to-WD-Community/Posting-Messages/td-p/24)) clearly state that changing the subject is permissible.  I though twice before posting, but it appears that posts with altered titles still remain properly threaded.

"From the “Posting Messages” instructions: “When you reply to a post, the subject line will be filled in for you automatically. You can change it if you want.”

BarryGB

I believe turning off auto match framerate has the same effect as what I observed with a 60Hz TV, i.e.: jitter-strobe goes away, but 3-2 pulldown judder becomes apparent, depending on the TVs de-judder capabilities or lack thereof.    When enabled, the Live checks the list of permissible display modes that the TV passes back via HDMI, and selects the mode that matches the framerate that it parses from the playing video file.   You can see it do this when you start playing a 24Hz file; depending on the TV, a popdown box, upper right corner on Sharp Aquos sets, indicates the HDMI frame rate switch to 24Hz.  When the file play ends or is stopped, the popdown appears again as the Live shifts gears back to the default (60Hz) rate.  When you turn auto match framerate OFF, the Live maintains the HDMI link mode at default, and, for 24Hz files, performs 3-2 pulldown (Telecine) to match the 60Hz default.  I’ve not seen the problem occur on a 60Hz TV, whether the files were coded at constant framerate or not, nor do the troublesome variable framerate files exhibit problems when played on a PC application like VLC. 

If your toolchain yields constant framerate coded 24Hz files, you probably won’t see this problem.  I’m in the process of re-coding my library to constant frame rate as every one of the files I cranked with variable frame rate (the Handbrake default) exhibit the pause-phase characteristic I described.  Coded at constant framerate, they play perfectly with no sign of the jitter-strobe effect, and audio seems to remain locked in sync through to the end of the film.

RPH_16by9 wrote:
If your toolchain yields constant framerate coded 24Hz files, you probably won’t see this problem.

My TV switches to 24p and the files have a constant framerate but there’s still judder on some files, even from m2ts containers.

Techflaws wrote:


barrygreybeard wrote:

I have based my experince on those MKV files I have had problems with so your experince may vary depending on the files you are trying to play.


Obviously. Still you’re the first one complaining about out of sync MKVs so I really doubt it’s a firmware bug.

You misunderstood what I was saying. I had jitter problem with a few MKVs on my WDTV Live and SamsungTV. I put that down to WDTV not liking the way they were encoded and/or muxed as they played fine with other players. Trying to solve the problem I remuxing those files with Mkvmerge but that caused the a/v to go out of sync over time. I wasn’t saying that was a WDTV firmware problem and I wasn’t complaining either! I just stated an observation. The problem was also visible in VLC on my computer. I was saying that that was not a way to solve MY jitter problem!

RPH_16by9 wrote:

BarryGB

If your toolchain yields constant framerate coded 24Hz files, you probably won’t see this problem.

Thanks RPH-16by9, yes I can see my TV exhibits the mode when the resolution changes but in the files I have a problem with MediaInfo states it is in constant rate mode so its not that in my case. I still go back to the way its encoded/muxed as reencoding the 5.1 ac3 audio streams and remuxing does solve my problem for me. As for turning off auto match framerate I see no evidence of pulldown judder on my SamsungTV after doing so, so maybe as you say it’s dejuddering capabilities are good.

Barry

I always had 24fps jitter. It never worked for me. All firmwares. All movies at 24fps have hiccups. My wife doesnt notice, but I do. She doesnt notice too when 60 or 24 mode… What can I say, if I notice, I want it fixed. My PS3 doesnt have this problem, it supports 24fps just fine with BluRay movies, so its not the LCD.

The Option “media Library” On/Off dont work.

Before I had ver:1.04.17, I can see good the film in my Hard Disk with many dates of Computer (not film) beacuse I turn Off “media library” Option (You recomenced), But This option now dont work. WD TV Live want scan all Disk.

Just to rule out several variables that could also have been responsible for the jitter/strobe effect, I recoded the same VOB file movie using Handbrake with Variable Frame Rate checked.  Sure enough, the resultant file immediately displays the problem as soon as I start playing it and toggle the pause button a few times.   This at least discounts the possibility that Handbrake had some encoding or muxing problem last summer that got fixed in the latest release.  The only other variable here was the selected encode framerate; I had originally selected 24fps whereas my recent encodings were done with 23.976fps selected.  I don’t know what Handbrake does differently between the two settings but apparently that difference alone does not account for the jitter/strobe effect.

For those Live owners that experience the same jitter/strobe at 24Hz that I have experienced, all I can suggest is to try the same tool chain with the same settings.  I have no idea what Handbrake is doing to the file with CFR or VFR selected, much less what was done in a file created by a different tool chain.   Please keep in mind that the specific problem I am discussing on this forum is easily identified by noting that the picture can smooth out by toggling the pause button.  This is the critical difference between jitter/strobe and what is understood as judder, which I suspect some forum posters may be observing.  Judder doesn’t go away and come back as you toggle the pause button.

Problem is, all the demo files in the 24p-thread have constant framerate. I also never use Handbrake on my rips.

New firmware release still no support on replaygain. When do you think WD will release new firmware supporting replaygain. I hate always turning the volume of my receiver.