New Release - WD TV Live Streaming Media Player Firmware Version 1.16.13 (7/23/13)

In this fix: Resolved issue with Windows PlayTo not playing MP4, 3GP and AACADTS files

Yes, I can PlayTo MP4 files now, but there is strange behavior with playTo images.
First image is displayed correctly. Second image flashes briefly and black screen.
Third image is displayed correctly. Fourth again briefly and so on only over one image is displayed correctly.
It is so with both Windows 7 (Media Player) and Windows Phone (Lumia 620).
If I send images from Windows phone to windows 7 all images are displayed correctly.

This behavior was also with previous firmware.
Any help?

Trying to roll back to previous firmware… I downloaded proper file 1.15 folder but when I try to do rollback, it tells me I am going to 3.something… Could the wrong files posibly be posted ?? what am I missing

rorkin wrote:

Trying to roll back to previous firmware… I downloaded proper file 1.15 folder but when I try to do rollback, it tells me I am going to 3.something… Could the wrong files posibly be posted ?? what am I missing

Thats OK the firmware has to fool the player to roll back. It will however install the correct firmware. You will find that the new firmware icon will pop up after the firmware is installed, ignore that.

 I purchased mine yesterday, and followed the indication  to update a new firmware … the F@#$ thing becomes unusable to the point I had to return it this morning!!. I changed the unit thinking it was a hardware problem, but reading this forum I realize it’s the firmware that makes the unit to:

  1. Netflix crash

  2. Does not turn-off the attached hard drive when the unit is off

  3. Make the remote control inoperative after 20 minutes of use

  4. The YouTube app loses audio.

  5. 1080p MKV files stutter 

WD media player it’s in paper the best product out there… when it works.  Sorry WD but when I purchase something it has to work out of the box, is not cool tfor me  to have to look at forums ways to fix this **bleep**.

1 Like


  1. Netflix crash

  2. Does not turn-off the attached hard drive when the unit is off

  3. The remote control becomes inoperative after 20 minutes of use, and I had to disconect the power cord in order to reset the box.

  4. The YouTube app loses audio.

  5. Problems playing 1080p MKV files 

I will  try to not update this box anymore and use the firmware 1.12 as recommended by other members of the community. 

  1. It does when set to deep standby. Some HDDs even turn off themselves after 10 mins in regular standby

  2. Never happened with ANY model I owned

  3. 1080p work just fine apart from the 24 FPS issue.

I left the WD attached all night to the HDD it did not turn off. I couldn’t find on the settings the option “deep standby” you mention.
I do have problem playing differents MKV 1080p files, they start fine but suddenly the image stop and the audio kept going. I think is the unit and not the files as I am able to watch them perfectly at my SONY BD player.
Good to hear you never had remote control problems with any of the models you own, maybe insted of igoing back to officedepot and ask for my money back, We can just exchange mine for one of yours :wink:

Pd: while writing this, the unit froze up again and had to unplug it.


I am still unable to find the option for “deep standby”, but I did perform a factory reset, reinstall firmware, factory reset again. So far the problems are minimised; Hulu plus still iffy, but MKV 1080p movies are running fine. I will give it a try for a couple of days

In order to put the unit into standby you need to press the off button for at least 5 seconds.

You say that the unit keeps freezing up.  Are you trying to do the same thing each time or is the unit freezing by trying to do many different things?  Is the remote not working or is it the unit freezing up?

Just remember, this is a forum and not a WD help desk.  Coming onto these forums and bagging the product and then having a go at someone who is trying to help you will not get you too far.


The remote control problem was corrected when I performed a factory reset, reinstalled the firmware, and factory reset again.  I did that following an advice from another user and not from WD customer service representative who advice me to return the unit (2nd one) as defective. The unit got completely freeze at the menu dashboard with message “complying media library”   I disable the option of media library from the settings, and the unit works fine again.
I sincerely apologize for my lack of style as I can see gives the impression I was trying to have a go with someone that just was trying to help me, it was not my intention, I was just frustrated with the situation of purchasing a new item, exchanged it thinking it was a defective hardware, had to call a customer service line two times,  and research online for 3 days in order to watch a movie.  I do appreciate all advices here  I found this forum really helpful and the unit is working great as a 3rd generation media player should be in the first place coming out of the box.   Again thanks to all of you guys for being supportive with this angry novice. 

My problem is simple,

After upgrading to 1.16.13 i still have blank screen regularly (every few seconds to 5 minutes) when playing a mkv from a usb drive.

Is the player connected via HDMI? What happens when you

  • connect via composite

  • switch cables

  • play from another USB drive?

I already have a thread dedicated to my problem, but just to keep track of it:

  • Cannot play MKV from my NAS via wifi (even after rollback to previous FW).
  • These are MKVs that worked fine prior to the update
  • MKVs work fine when being played through USB.

Since the update, I can no longer log into my network shares (none, not the ones on my MAC, NAS, Win7 pc’s).

I’ve tried :

  • Reset of router (since the NAS is via the Linksys E4200)

  • Reset of WD player

  • Making sure the drive permissions were ok

  • Password resets on the accounts related to the NAS 

I can connect to everything fine from all sources of my network, but the WD Player. 

I’ve rolled back the firmware, hoping it would fix it - but to no avail. Literally, my WD player is now rendered absolutely useless. (Most of the Live services don’t work in my country, only YouTube does – and well, that one is just easier on a laptop)

I am hoping it is unrelated to the firmware update, but I have to admit, the issue started when I updated the firmware (last night, hadn’t used the media player in a while, movies played fine - logging in as well, I updated after movie night and that’s it.)

Anyone ANY idea?

Well, if rolling back your firmware didn’t fix it, then it’s not likely a firmware issue. 

When you say you can not log onto shares, does that mean you can’t SEE them, or that it refuses to let you connect to them (tells you the password is wrong or something else?)

Since you also did some resets, make sure the workgroup name is still correct.  (The default is WORKGROUP, so if your home network has a different name, you’ll need to change that.)

Workgroup name is the same, I can see the shares, keep getting wrong password/username. While I am 200% certain they are correct.
This is actually the first time it’s gone this wrong :stuck_out_tongue:

ps. I enabled Media server, that way it works - just doesn’t load any subs (external). But it’s a work around. I’ve re-updated to the latest firmware. While I realize that “rollback, issue persists = issue isn’t firmware”, the issue appeared after updating the firmware.

I am going to put this in its own topic

Yes… its true. WD TV rebooths while playing Youtube.

also it does not recognize any usb drives. I tried 5 usb drives . 

Total **bleep** product and waster of money.

I just brought this new WD TV live and it does not connetc to Netflix. I mean Netflix screen is stuckup at the splash screen. It shows loading Netflix and nothing starts for 15mins. I mean never starts netflix. 

The Youtub restarts the WD player.

I am not able to see any USB drive files. I tried different USB drives with different files and with both the usb slots. Nothing works.

What kind of player is this WD live. Its a dead product. 

How to get money back. 

The WDTV SMP seems a good device, but user interface is very limited. I bought a WDTV gen3, but a bit disappoinged with its options. I want to access to dropbox and web broswer, because most of my favourate online media is streaming directly from their web sites, not from things alike youtube.

I really wish thoese apps will be included in next firmware release  or give the user some options, that I can install some applications by myself. This OS is a linux variant, it should be capable to do so.

Is the support for this thing even alive at this point???

5 months and counting for Youtube crashing the player.

Support is VERY much alive and well for this product. They actually called me yesterday to figure out an issue I was havving. And the Youtube Leanback **bleep** yes but that’s on Youtube not WD.