[APP] Transmission various versions for firmware V4+ (05/2020)

Live Counter

Note: Can’t see live counter image above? Try again later as my WDMyCloud is offline!

Transmission has the features you want from a BitTorrent client: encryption, a web interface, peer exchange, magnet links, DHT, uTP, UPnP and NAT-PMP port forwarding, webseed support, watch directories, tracker editing, global and per-torrent speed limits, and more.

_This is Transmission v2.84 and v2.9x for firmware V4+ successfully built with 64K page size memory patch. For setups and details, refer to https://www.transmissionbt.com/._

For those interested on how to build from the source, refer to this thread. It may help others to continue supporting the 64K page size memory for other packages. Below are my simplified instructions on how to get it installed on the V4 firmware (will not work on older firmwares).

AND I have also made an online generic 64K page size memory package installer to simplify the installations of Debian packages on WDMyCloud. This will not work on older version 3 WD firmwares and I’m not planning to support it either as I’m sticking with the V4 firmwares. Based on dynamic server-side FastCGI, perl and shell scripts, I’ll be using this method for newer guides from now onwards. Feel free to parse the script codes. All bug reports, opinions and suggestions are welcomed.

The Generic Online Installer:

1) Auto download of required debs including its dependencies if any.
2) Debs installation in the required order to prevent dependency issues.
3) Auto run custom configurations if any.

If you proceed further, you are fully aware of the usual WD’s _warranty void _clauses including disclaimer from any damages that may resulted from this guide.

  • Enable SSH on your NAS from the WD DashBoard settings if not done so. SSH to your NAS port 22 using i.e. putty root@wdmycloud.

  • To proceed with the installation, first you need to get the username and password from me. The credentials will expire hourly e.g. “1AM,2AM,3AM…” to prevent intentional abuse on my network resources. Click on the link below to get the credentials :

    WDMyCloud | TeaNazaR.com

  • After obtaining the credentials, just copy & paste into the SSH terminal session of your WDMyCloud:

    export NAZAR78_USER=user; export NAZAR78_PASS=pass; export NAZAR78_KEYS=keys;

  • Then run the online installer on your WDMyCloud copy & paste as below, follow the instructions and enjoy (-:

    Version 2.84-1:
    curl teanazar.com/installer.fcgi?transmission_2.84-1|sh;

    Version 2.90-1:
    curl teanazar.com/installer.fcgi?transmission_2.90-1|sh;

    Version 2.92-1:
    curl teanazar.com/installer.fcgi?transmission_2.92-1|sh;

    Version 2.93-1:
    curl teanazar.com/installer.fcgi?transmission_2.93-1|sh;

    Version 2.94-1:
    curl teanazar.com/installer.fcgi?transmission_2.94-1|sh;

    Version 3.00-1:
    curl teanazar.com/installer.fcgi?transmission_3.00-1|sh;

For quick backup and restore when WD release newer firmware update:

  • Before updating firmware:
    tar zcf /shares/Public/transmission.tar.gz ~/.config/transmission-daemon;

  • After updating firmware:
    tar xf /shares/Public/transmission.tar.gz -C /;

  • Run the online installer again. Your settings will be preserved and you may then remove the tar backup.

How to change the webGUI interface theme (Thanks Joaco_AR for sharing in this thread):

Download and unzip the new theme into path /root:
cd && wget https://github.com/killemov/Shift/archive/master.zip && unzip master.zip;

Edit environment with "nano ~/.profile" and add/replace as below:
export TRANSMISSION_WEB_HOME=/root/Shift-master

Edit crontab with "crontab -e" and replace as below:
@reboot export TRANSMISSION_WEB_HOME=/root/Shift-master && /usr/local/bin/transmission-daemon

Stop then restart the daemon:
export TRANSMISSION_WEB_HOME=/root/Shift-master && transmission-stop && transmission-daemon;

Another webGUI interface theme (Highly recommended! Thanks Joaco_AR for sharing in this thread):

Download and untar the new theme into path /root:
cd && curl -L https://github.com/ronggang/transmission-web-control/raw/master/release/transmission-control-full.tar.gz | tar xz;

Edit environment with "nano ~/.profile" and add/replace as below:
export TRANSMISSION_WEB_HOME=/root/web

Edit crontab with "crontab -e" and replace as below:
@reboot export TRANSMISSION_WEB_HOME=/root/web && /usr/local/bin/transmission-daemon

Stop then restart the daemon:
export TRANSMISSION_WEB_HOME=/root/web && transmission-stop && transmission-daemon;

Online Installer change log:

[20141105] Show path details during configurations.
[20141106] Ensure daemon is not running during configurations else settings can't be saved. Enabled 'watch-dir' in '/shares/Public/Transmission/Downloads' for new install.
[20141118] Printing of package size during install. Check and warn available rootfs space before installing. Changed tmp path to allocate larger than 100Mb installs.
[20160301] Added Transmission v2.90-1.
[20160307] Added Transmission v2.92-1.
[20180401] Added Transmission v2.93-1.
[20190306] Added Transmission v2.94-1.
[20200525] Added Transmission v3.00-1.

I was struggling this moring to get my little netbook setup to run a ubuntu envro just to try to build this. So mad props. But I still need help. when I try to install the deb you link to with dpkg it says I’m missing a bunch of files.

dpkg: warning: files list file for package 'libffi5:armhf' missing; assuming package has no files currently installed

 there are tons more but I have only every really worked with apt-get. any help would be greatly appreciated.

Ignore those warnings about missing file. After install just run “transmission-daemon”…

1 Like

Hi, I am a complete newbie when it come to all this although am an experienced windows user.
I managed to get transmission installed and up and running. I set my download to a test torrent to datavolume/shares/cliff/downloads (my share folder).

The torrent downloaded fine but if I try to open the folder I get access denied?

I can rename the folder but cannot open it or delete it, any pointers someone can give me?

Many thanks.

Sorry to hear about the permissions thing. I wasted hours on it once. The Magic trick its to open the transmission-daemon settings.json file and edit the umask from 18 to 0

stop the daemon first though.


nano $HOME/.config/transmission-daemon/settings.json
1 Like

Hi . I did all in the guide. Application started with no problem as well as the possibility to change directories. I did start some torrents and 10 min after the My Cloud completely locked up. I had to unplug from the power outlet to make the device wok again. Any clues Thank you

Thanks for the response that led me to a light bulb. I had got the new firmware v4 and forgot that when trying to install the transmission v2.82 I did a apt-get update. I think since I had been folllowing the guild to install the older version of transmission. When I ran the update command was right after I pointed apt-get to a older (not compatable with V4) repo.

I reflashed the new V4 firmware from the dashboard followed your guide and edited the transmission-daemon/settings.json file for the way I like it and BOOM good to go. Thanks for putting this up Saved me alot of time setting up a compiling machine.

Thanks for quick reply. I changed the mask setting to 0 but still won’t let me open the folder.

I’m now aquiring a load of torrents on my disc I can’t delete now.

I’ve tried changing ownership in windows but it won’t allow to even do that.

Thank you for the reply but think I probably need to swat up on what I’m doing, and learn a bit of the language.

A little knowledge can b a dangerous thing ! 

Many Thanks

I know after I manually flashed the newest firmware and followed this guide everything worked perfectly. This worked for me on the old version of transmission mabey try it.


chown (your username):share /etc/default/transmission-daemon

chown (your username):share /var/lib/transmission-daemon/info/*

chown (your username):share /usr/bin/transmission*

usermod -a -G debian-transmission (your username)


 BE SURE TO CHANGE THE (your username) to the user you created in the dashboard.

I found this in a guide here http://insinuations.wordpress.com/2014/05/06/transmission-in-wds-my-cloud/

I missed out the permission part, because I’m running non-root which has full sudo access. Have updated the guide to create dir as mode 777.

If you already created the paths, just use root to chmod those paths:

chmod -R 777 /DataVolume/shares/Public/Transmission/;

Rodrack wrote:
Hi . I did all in the guide. Application started with no problem as well as the possibility to change directories. I did start some torrents and 10 min after the My Cloud completely locked up. I had to unplug from the power outlet to make the device wok again. Any clues Thank you

Try wait a while, I too experienced it, but not just for transmission. Seems WD’s indexing trashing when I monitor the running processes via top. For this, we just need to wait an update from WD. Else you can disable by renaming the binaries, kill the processes or reboot to take effect:



Hi, I Have this problem when i trie to download any torrent:

Error: Unable to save resume file: No such file or directory

I tried to change the site of downloads but i allways have this problem.

could you help me…

Did you changed the dir settings manually? Restarted the daemon? You need to ensure all paths from the guide are having read and write permissions. Recursively change the path permission by issuing: chmod -R 777 your_path. Then try a new torrent…

What download speeds are you guys getting ? :smiley:

johnsheppardwd wrote:

What download speeds are you guys getting ? :smiley:

Depends on the bandwidth and availability…

All up and running at last. Many thanks.

I would like to add a watch folder so that it will automatically download torrents that are added to this folder. I assume this is possible? I have looked at my .json file and cannot see any commands for this. Can I add the command after I stop transmission and open the json file for editing?

Many Thanks once again, Cliff

"utp-enabled": true, 
    "watch-dir": "/shares/username/Downloads", 
    "watch-dir-enabled": true

 Yes you can, stop the daemon first then add the two last line above, then start the daemon again.


Thank you very much Nazar78.

I edited the file. Set the download folder and now if I add a torrent it changes the extention to .added ?

so my torrent file goes from xxxxxxx.torrent to xxxxxxx.torrent.added

It does not show up in transmission as downloading though? Any ideas ?

Sorry to be a pain but guess we all start from zero !

Many Thanks, Cliff

It also adds the torrent file to my torrent folder as well as a xxxxxx.torrent file after renaming the watched one to added 

Yes the renamed extention is correct and you’ll also see a new torrent file being created. I don’t use watch folder, I’m using magnet uri instead (paste into the webui open url dialog) but I just tested the watch folder feature it works.

The torrent was added and started downloading immediately once I drop a torrent file in the watch folder. My watch folder is the same as my download folder.

  • Check if your torrent file is not corrupted with other pc client? 
  • Try another watch folder?
  • Did you also configured and enabled other folders such as incomplete? I never tried this though. Sharing your json minus credentials here would help.

Thanks once again Nazar78.

I finally got it working by rebooting the My Cloud Drive.

Thank you for all your help, Cliff