WD MyCloud Remote Access Not Working


#1

I have two WD devices connected to my Router: WD MyCloud Mirror and a WD MyCloud. The Mirror device works perfectly when connected via local or other WiFi; and it works well using 4G devices.

My WD MyCloud works perfectly when connected via local or other WiFi; but DOES NOT WORK when attempting to be accessed remotely either via WiFi networks or 4G devices.

I am getting a Network Connection Failure (905). I also get 900 and 907 error messages as well.

I am hearing proper Port Forwarding configuration is necessary. However Port Forwarding from which device? From BOTH the WD MyCloud app AND the Router? I need very specific instructions.

It was working properly up until about 3 weeks ago. Very odd. This is a very frustrating process. If one of my two devices is not working remotely, it sort of invalidates having it in the first place.

If anyone can assist, that would be great.
I thought I tried everything regarding Port Forwarding, but I may have missed something.

Thanks!


#2

It is entirely possible that if both My Cloud devices are using the same ports for remote access that your router is getting confused on how to route traffic. If one searches, via the magnifying glass icon upper right, this subforum they’ll find other discussions where people had trouble with remote access when two or more My Cloud devices were on the same local network.

When configuring the My Cloud to use manual port numbers one also has to configure their router to port forward those port numbers to the My Cloud IP address. Generally one would configure the My Cloud for a static IP address by either reserving the IP address within the router or setting a static IP in the My Cloud Dashboard > Settings > Network page. Then one would configure two ports for remote access on the Dashboard > Settings > General > Cloud Access > Remote Access > Configure > Manual. I would assume you would give each My Cloud unique port numbers. One would then configure port forwarding within their router (perform an internet search for your router model/brand on how to port forward) to forward those ports to their respective My Cloud IP addresses.


#3

Thank you for your reply.
Can you please provide the link to and example of a WD Community post regarding “remote access when two or more My Cloud devices were on the same local network”? I can’t seem to find an example of that scenario.

The problem I am having is the assignment of unique port numbers for each of the two WD My Cloud devices I have. I changed the port numbers of the WD My Cloud but I got a failure message. It appears the instructions for both devices (WD My Cloud Mirror, and the WD My Cloud) are identical and using the same port numbers; but do not recommend other, specific numbers if you have more than one device.

Thanks!


#4

Do a subforum search for “multiple my cloud remote access” and you’ll get several hits for past discussions on remote access issues with multiple My Cloud’s. Here are a couple of those past threads:

https://community.wd.com/t/multiple-myclouds/173045/

https://community.wd.com/t/remote-access-to-multiple-myclouds/96835/

https://community.wd.com/t/multiple-my-clouds-on-same-home-network/164926/

On the port number question leave one My Cloud using the default ports of 80 and 443, then try configuring the other My Cloud using alternate port numbers like for example; 8080 and 4443. One would then configure four port forwarding entries in their router to point to the first and second My Cloud’s IP address based on the port numbers.


#5

Hi Bennor, this is great, thanks. I try your recommendations tonight when I get home from work.

A few last questions…

  1. See the attached link.
    http://www.belkin.com/us/support-article?articleNum=10790

I have a Belkin router that is asking for TCP and/or UDP port types; not HTTP and HTTPS. By looking that the screen shot in the link, for one of the devices, how would I key in HTTP=80 and the HTTPS=443? One as TCP and the other as UDP? Both TCP? Looks like there are 4 required entries, not 2. For each device, do I key in just the two entries you suggested and leave the other two blank?

Please let me know. Sorry, not an expert at this.
Appreciate your guidance.

Thanks!


#6

Generally you would select “Both” for the “Type” then input the port number. By selecting “Both” it should allow traffic on both the TCP and the UDP port type.


#7

Thanks Bennor,

Using the Belkin Router link I sent you earlier, this is what I will enter tonight on the Belkin Router. Hope I got this right…
4 entries. 2 per device. Not sure I can do it this way. May have to add another Virtual Server, and place the contents of Fields 3 & 4 in the new Fields 1 &2 for the second Virtual Server.
But I can try it both ways and see what works. And I will do these steps AFTER I configure the Port Forwarding in the two WD devices.

Let me know if I got this right…thanks!

Configure your Belkin Router to forward the ports assigned above to the Static TCP/IP addresses for your My Cloud devices as follows:

  1. Under the Firewall section, click “Virtual Servers”

  2. Click the “Enable” box and enter the following information (as an example):

• Field 1 – Enter “80” on the fields under Inbound port. Set Protocol to Both. Enter the WD My Cloud Mirror Static TCP/IP address in the Private IP address field and enter the same port numbers (80 and 80) in the Private port fields.
• Field 2 – Enter “443” on the fields under Inbound port. Set Protocol to Both. Enter the WD My Cloud Mirror Static TCP/IP address in the Private IP address field and enter the same port numbers (443 and 443) in the Private port fields.
• Field 3 – Enter “9080” on the fields under Inbound port. Set Protocol to Both. Enter the WD My Cloud Static TCP/IP address in the Private IP address field and enter the same port numbers (9080 and 9080) in the Private port field.
• Field 4 – Enter “9443” on the fields under Inbound port. Set Protocol to Both. Enter the WD My Cloud Static TCP/IP address in the Private IP address field and enter the same port numbers (9443 and 9443) in the Private port fields.

Reboot my Modem, Router and WD Devices (not necessarily in order or simultaneously)


#8

Hi,

I have a DL2100 MC NAS, and I fixed this problem for myself just this past weekend!

I, too, could not reach my NAS remotely with the MC app either. What I did to fix it:

First, I checked in the complete user manual for ideas. Then, from Dashboard, I went into Settings/General to the Cloud Access section and saw that Cloud Service WAS turned On, but below that (in Connection Status) it also showed it was not connected. So, in Cloud Service there is a configuration link, I clicked on it to be sure it was in Auto setting (the default) and saved this config by clicking on Apply,

The Connection Status showed, Connected, so then I checked my remote Access, and it worked again. I checked access via a wi-fi hotspot near me and via my cell plan, both could access the NAS via remote connection and play media files again.

So, problem was caused by lack of connection config. Who knows why, because I never messed in this section. Perhaps a reboot or FW update changed things.

OK, so if this info solves your problem, please be sure to click the indicator button that this problem was solved; for others who see this thread.


#9

Mike, many thanks for your ideas. Glad you got yours working again.
I am positive my Connection Status showed “Connected” but I could be wrong and will look again.
I will add that to my list of things to try tonight. Keep you and the group overall posted.

Bennor’s suggestions regarding the use of Port Forwarding are very logical as well.
The only problem, is that I had remote access working for both NAS devices as recently as 2-3 weeks ago under my current configuration and no Port Forwarding configured in my Belkin Router. The fact that it just only now ceased to work is especially puzzling.

Thanks again for the message.
Stay tuned tomorrow for results. LOL


#10

Robert,

My MC did not work correctly until I had set the Configuration to Auto and saved it. Auto will set up the port forwarding; no need to use Manual config to do this. This image shows my Cloud Access screen from the Dashboard after I reset Config to Auto. It actually may have shown Auto, but it was not connected, so I clicked on Manual and back to Auto and hit Apply. Then I had this screen.


#11

Ahhh gotcha. Thanks Mike.
Again, I think I already had mine set to Auto with a Connection Status of Connected when I lost remote access a few weeks back.

But what I can do is toggle it again from Auto to Manual and back to Auto again, to see if that works.

I am fascinated by how the remote access functionality (for one of my two Cloud devices), can derail like this for seemingly no apparent reason. My fear is that the Auto setting is buggy; whereas, the Manual Port Forwarding option (with a Static IP) might be an ideal Plan B option. If it works of course. Remember I am running two concurrent devices off my Belkin Router; not one, so it’s entirely possible I have unknown port conflicts. Again, thought I didn’t initially, but we’ll see.

Since your recommended solution is simpler, I’ll try that first. If it fails, I’ll go to Bennor’s Plan B.

Thanks man.


#12

I have had my DL2100 for over two years, and this is the first instance of it losing cloud access. I just ignored/forgot about it for a while since I don’t use remote access that often, but I tried to use it this past weekend and remembered I had the problem, II have had one or two instances of losing Cloud Access (On/Off) after FW update early on and the pie graph disappeared and doing a 4 sec reset fixed things and I restored/switched Cloud Access to ON again (but did not need to fool with its config)…

So if my suggestion doesn’t help, try a 4 sec of NAS and reset and re-do the cloud access section again. I really don’t think the Auto setting is flaky, tho, it just gets its configs screwed up once in a while. I need to return to saving my (working well) config setting once in a while again!


#13

Hi Mike, thanks again for the tips. My Cloud devices on my network normally function like a well oiled machine. Never really had a problem, so this was a challenge to fix. Looked liked the Auto/Manual/Auto toggle solution worked. Much appreciate the help.

Interestingly, I tried the Port Forwarding solution first just out of curiosity and respect for Bennor’s suggestion, but it didn’t work. That’s very puzzling, as it should have, because the static assignments of TCP/IP addresses and ports should have removed any potential conflicts. Another puzzle for another day.

I still believe something is buggy. My issue surfaced outside of a FW update, so it’s hard to point a finger at the FW. It’s possible a non-flushed cache can disrupt a working network at times, but additional variables of differing architectures and products trying to always work together harmoniously may come into play as well. Too much to speculate now.

I’ll keep an eye on how stable this solution is before passing final judgment, but for now I have to consider this fixed.

Thanks again!

Bennor - if you are still following this thread, happy to get your thoughts on why Port Forwarding didn’t work. I honestly thought it was an excellent and very logical suggestion.


#14

Robert,

Real glad the same solution worked for us both. That’s reassuring. Basically, all we did was put the config back the way it was when we first got the NAS, I do remember once looking in that section of Dashboard to see the setting when I was first exploring the thing. the toggle we used (to move the needle) just helped get the config back to Auto and applied again.

I have bookmarked our thread, so if it becomes necessary to get in contact again, meanwhile, glad I could help.
Mike