Transmission client isn't available

Update 5.05.111 is available now. You must download it manually and install from file. This works for me.
But for me Transmission whiteout remote access is useless.

Can you share a download link?

Go to downloads https://support.wdc.com/downloads.aspx?lang=enscroll to Product Firmware, select your product, expand the Current Firmware.

1 Like

As i mention few post earlier i cant install it from this file

I’d check /var/log/user.log for any specific errors after the latest “SYSTEM: Installing firmware update.” message. Hope it can provide you more information about that upgrade failure.

how to get to transmission web interface?

so there is no remote support yet? … god saved me i am not updating os 5 in next six months untill everything works as b4

At last Transmission is available with the new firmware update as Support promised. The update has got fine and I have been able to installed the Transmission app properly. At the beginning it didn’t work. When I tried to configure the app it took me to a black error page. Nevertheless, after some minutes it worked perfectly for me. It seems it takes some minutes to run the app.

Let’s see if everything goes fine in the next days.

To enable remote access, go to web dashboard, go to transmission app and press configure. It will open a tab. There you will see a long url remotewd.com:(port number) note the port number and the full url address.

Now go to settings, network, scroll to bottom, enable portforwarding. Add port (you noted before) to tcp list.

Done. Now access the transmission remotely with that url noted in step 1.

1 Like

@benqu, can you contact the WD support team directly to report the issue if you continue to see the firmware update failure?

1 Like

WTF?? WD can’t produce working product??
Transmission still not working despite this package had been include into last update.
I need to go some dynamic dns address everytime? For what? For access my transmission service inside my local network? What kind of the security risks, when app not supported authentification???
This app doesn’t work correctly!

So far it worked fine for me but the browser does disconnect from the server after some minutes, and I need to access to the NAS again to open the transmission page. I suppose WD support will work on this for the next firmware release

You shouldn’t thing that “it worked fine”… It wasn’t. Anyway.

WD are trying catch balance between customer sutisfaction and security demands on 2020.
I wold ask you, WD, you must have do this more fluently.
WD, you should provide official way to rolllback to OS 3 and working on you problems as long as you want. No way.

This works but it’s DDNS, so it’ll randomly change the next time you come to access the DDNS URL.

This method doesn’t works.

What we will write in service? can you tell us a method in details?

why we don’t enter it on local network with IP address, just 192.168.18.100:9092? Everytime we access it by dashboard then go to app then do to Transmission then go to Configure?

1 Like

They should just make credentials mandatory if they’re so uppity about security.

1 Like

so to enable remote I checked
/mnt/HD/HD_a2/Nas_Prog/Transmission/config/setting.json
I see one of the setting is “rpc-bind-address”: “127.0.0.1”
which mean it only bind to localhost
I changed it to “rpc-bind-address”: “0.0.0.0” then I restart transmission with
pkill -HUP transmission-da

now I can finally use Chrome extension on any remote client to add torrent or download into transmission.
my chrome extension setting just need
ip: your.nas.ip
port: 9091
path : /apps/transmission/rpc

btw to find the setting.json I just ssh into the NAS check the
ps
you will see something like this
3361 root 301m S transmission-daemon -M --port 9091 --config-dir /mnt/HD/HD_a2/Nas_Prog/Transmission/config --download-dir /mnt/HD/HD_a2/Transmission --pid-file /var/run/addon_transmission.pid

the folder after–config-dir will contain the setting.json

9 Likes

Thats a perfect solution @iqboss,
Thankyou very much for your kind support.
now Transmission is perfectly run.
the only problem remaining is about RAM and porocesses.
Do anyone know about it?