My Cloud Transmission Update 1.07

I’ve seen the recent alert regarding Transmission client for My Cloud (specifically for my EX2100) but the only details I can find are on the link from the My Cloud app store which simply says:

[Version 1.07:

Anyone have more information on the update? The previous version has been 1.05 for months/years.

Bear in mind that there is already a version number issue, in that the app store version number is the 1.05 or 1.07, but the ‘about’ option within the actual app states Transmission 2.77 (14031) once you have installed version 1.05.

Unfortunately i’ve updated, the app doesn’t work since the update. I tried reinstall, reboot but nothing. Very disappointing

Wow, that’s such a pain. Have you managed to restore to an earlier version? There’s a chance I still have the earlier EX2100 Transmission installer so let me know if you want it.

I don’t know if the issue is directly related but the previous installed version (1.05 in the WD App Store) refused to start a couple of times recently. The first time it happened I thought the install had become corrupted, and nothing I tried would bring the web interface back, including a restart of the EX2100. Then seemingly randomly it came back as if nothing had happened.

It disappeared again a week or two back again but only lasted minutes. The reason I tell you this is maybe the newer release also just needs a bit of time?

Even if I’m right, I’m going to avoid the update until I hear good things.

I couldn’t restore it becouse I don’t find any previous installer. If you can share it, it would be very kind. Thank you in advance

Really sorry but I’ve just had a search and I only have previous system installers, Transmission install and updates are all done neatly via the App Store interface.

But there are some installers on the WD Support website, go to software and downloads, then select your model, and at the bottom there is a section called Software For GPL / Firmware, and at the bottom of this list is Third Party Apps GPL Codes. Select this last one and it pulls down a list (the EX2100 list is dated 2/26/2015.

Hit the download link by Transmission and it’ll download the whole lot as a .tar file. Unzip this and within the Open_Source_Packages folder you’ll find transmission-2.77.tar.gz - It is the same 2.77 as the version running on my EX2100 so maybe if you install this manually via the link above where it says Installed Apps in the My Cloud app store, it might just work!

Let me know how you get on.

I found transmission-2.77.tar.gz but i cannot install by manual install. I guess it should be a .bin file…
But thanks

What a pity. It might be worth putting out a request here for the bin installer.

I’m not sure if this is any help, but there’s a text file within the tar.gz which explains something about building an app form the files included. So here is the text just in case:

  • Modification of or tampering with the Software, including but not limited to *
  • any Open Source Software, is solely at Your own risk. Western Digital is not *
  • responsible for any such modification or tampering. Western Digital will not *
  • support any product in which You have or have attempted to modify the *
  • Software supplied by Western Digital. *

  1. Introduction
    This Package will include all GPL source code of the WDMyClound NAS 3rd party Apps.

  2. Apps GPL modules list

  3. Build the App
    3.1 using mksapkg to create the apps that could be install in the Web UI.
    3.1.1 using “./mksapkg -h” to check the support modules
    Supported model_name:

    3.2 For example: build aMule for WDMyCloudDL4100
    3.2.1 cd Apps
    3.2.2 cd WDMyCloudDL4100_WDMyCloudDL2100
    3.2.3 cd aMule
    3.2.4 …/mksapkg -E -s -m WDMyCloudDL4100
    3.2.5 cd …
    3.2.6 You could find that “WDMyCloudDL4100_aMule_1.05.bin(02262015)” is created.

Someone here seems to know what all that is about:

And here is possibly the bin file you are after:

I really appreciate your help, but this doesn’t work for me, maybe the reason is that I need it on PR2100 not EX2.
Meanwhile I installed Transmission 1.07 on my EX2 Ultra from the app store and it works well. Something went wrong with my PR2100, i tried a system only restore, but it didn’t help. The app starts but I cannot set the preferences or add a torrent file.

That sounds similar to the two times Transmission 1.05/2.77 stopped working for me. It just righted itself both times (second time very quickly) so there’s still hope. I’ll hang on another week or two for other reports before I give it a go.

The annoying thing is locating, accessing and editing the .json settings file which I amended to allow for more simultaneous downloads and to add a password for remote access.

Can you click the settings cog bottom left (on your EX2 Ultra) in Transmission, then ‘About’ from the menu, then copy and paste the version number? The 1.05 installer installed Transmission 2.77 (14031).

I had the same problem with my WDMycloud. I edited the file settings.json and changed the following item:
“rpc-host-whitelist”: “*”,

Now it works

Finally it works :slight_smile: the version number is: Transmission 2.94 (d8e60ee44f)


I have similar problem. After updating the app its not working anymore. Capture version
Rebooted, still not working.
Tried to uninstall - uninstall popup is displayed, but when the process is finished, the app is not uninstalled.

Stuck. :frowning:

P.S. I have no knowledge of linux.

I removed all installed apps included transmission, except plex. I rebooted the NAS, installed transmission again and then the app worked fine.

Thanks for the reply.
I managed to fix uninstallation issue.
Now im able to add or remove transmission, but unfortunately the app is broken:
none of the settings buttons work, config button is absent.

  • not able to add any torrents for download. :confused:

Same problem as skabais.
Since the transmission update, nothing is working anymore.
None of the buttons are working and not able to ad any torrent.
Help please!


Came back after work today, by the habit opened Transmission to check the status and found out that all is working fine… :confused:

Version 2.94 :slight_smile:

The same thing happened to me before the update. It would half load the interface but everything else missing including the torrents. I sweated over it for a couple of evenings (though nothing drastic) with no luck, then mysteriously it started working again as if nothing had happened!